summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-12-02 05:40:50 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-12-02 05:40:50 +0000
commit7c9c0065f82876d1292ee22cdaf2904f8d98234b (patch)
tree9b545e615f77b1eca04b3884d6e7f8d739d19491 /app-editors
parentVersion bump #71588. (Manifest recommit) (diff)
downloadgentoo-2-7c9c0065f82876d1292ee22cdaf2904f8d98234b.tar.gz
gentoo-2-7c9c0065f82876d1292ee22cdaf2904f8d98234b.tar.bz2
gentoo-2-7c9c0065f82876d1292ee22cdaf2904f8d98234b.zip
Initial commit. Closes bug# 69561
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/leo/ChangeLog10
-rw-r--r--app-editors/leo/Manifest15
-rw-r--r--app-editors/leo/files/digest-leo-4.21
-rw-r--r--app-editors/leo/files/leoConfig.py.patch27
-rw-r--r--app-editors/leo/leo-4.2.ebuild39
-rw-r--r--app-editors/leo/metadata.xml5
6 files changed, 97 insertions, 0 deletions
diff --git a/app-editors/leo/ChangeLog b/app-editors/leo/ChangeLog
new file mode 100644
index 000000000000..ad53a55f5d54
--- /dev/null
+++ b/app-editors/leo/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-editors/leo
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.1 2004/12/02 05:40:50 pythonhead Exp $
+
+*leo-4.2 (01 Dec 2004)
+
+ 01 Dec 2004; Rob Cakebread <pythonhead@gentoo.org> +metadata.xml,
+ +files/leoConfig.py.patch, +leo-4.2.ebuild:
+ Initial commit. Closes bug# 69561
+
diff --git a/app-editors/leo/Manifest b/app-editors/leo/Manifest
new file mode 100644
index 000000000000..08486f2dcce0
--- /dev/null
+++ b/app-editors/leo/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 c67121e056a79785b0aa61a252e4d8bc leo-4.2.ebuild 952
+MD5 9ac4199ebe7cd3e7e311274994767f82 metadata.xml 160
+MD5 d9b0348cd947b5d9223a6768d531d482 ChangeLog 291
+MD5 a58113f7350bb99e9ba2d4ad5fa8e620 files/leoConfig.py.patch 963
+MD5 786b8586255990e3d34ad8d5bee99fe3 files/digest-leo-4.2 63
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBrqrUz2gxt1z4IGYRAjS/AKC/FMl3Qa7PP0jY/4NvNErnTwF9iACfTTCD
+qidOW3bS+AO/gj3kDraEuME=
+=lee/
+-----END PGP SIGNATURE-----
diff --git a/app-editors/leo/files/digest-leo-4.2 b/app-editors/leo/files/digest-leo-4.2
new file mode 100644
index 000000000000..b9f4941b20ac
--- /dev/null
+++ b/app-editors/leo/files/digest-leo-4.2
@@ -0,0 +1 @@
+MD5 3051d5a9089ad2f948997237c8e21126 leo-4.2-final.zip 1819202
diff --git a/app-editors/leo/files/leoConfig.py.patch b/app-editors/leo/files/leoConfig.py.patch
new file mode 100644
index 000000000000..2352d232f5c1
--- /dev/null
+++ b/app-editors/leo/files/leoConfig.py.patch
@@ -0,0 +1,27 @@
+--- /var/tmp/portage/leo-4.2/work/leo-4.2-final/src/leoConfig.py 2004-07-20 08:11:58.000000000 -0700
++++ /var/tmp/abeni/leoConfig.py 2004-11-08 22:49:31.055019376 -0800
+@@ -9,6 +9,7 @@
+ import os
+ import string
+ import sys
++import shutil
+
+ class baseConfig:
+ """The base class for Leo's configuration handler."""
+@@ -84,10 +85,12 @@
+
+ def init (self):
+
+- try:
+- self.configDir = sys.leo_config_directory
+- except:
+- self.configDir = g.os_path_join(g.app.loadDir,"..","config")
++ self.configDir = os.path.expanduser("~/.leo")
++ if not os.path.exists(self.configDir):
++ os.mkdir(self.configDir)
++ config_file = "%s/leoConfig.txt" % \
++ g.os_path_join(g.app.loadDir,"..","config")
++ shutil.copy(config_file, self.configDir)
+
+ self.configFileName = g.os_path_join(self.configDir,"leoConfig.txt")
+
diff --git a/app-editors/leo/leo-4.2.ebuild b/app-editors/leo/leo-4.2.ebuild
new file mode 100644
index 000000000000..669777d67a30
--- /dev/null
+++ b/app-editors/leo/leo-4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.2.ebuild,v 1.1 2004/12/02 05:40:50 pythonhead Exp $
+
+inherit eutils python
+
+MY_P=${P}-final
+DESCRIPTION="Leo is an outlining editor and literate programming tool."
+HOMEPAGE="http://leo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/leo/${MY_P}.zip"
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/python
+ dev-lang/tk"
+S=${WORKDIR}/${MY_P}
+
+
+src_unpack() {
+ unpack ${A} || die "Failed to unpack ${A}"
+ cd ${S} || die "Failed to cd ${S}"
+ epatch ${FILESDIR}/leoConfig.py.patch || \
+ die "epatch failed on leoConfig.py.patch"
+}
+
+src_install() {
+ python_version
+ INST_DIR=/usr/lib/python${PYVER}/site-packages/leo
+ dodir ${INST_DIR}
+ dodir /usr/bin
+ dodoc ${S}/PKG-INFO MANIFEST doc/*
+ rm -rf PKG-INFO MANIFEST doc/*
+ cp -r * ${D}/${INST_DIR}/
+ echo "#!/bin/bash" > leo
+ echo "exec /usr/bin/python ${INST_DIR}/src/leo.py \"\$1\"" >> leo
+ exeinto /usr/bin
+ doexe leo
+}
diff --git a/app-editors/leo/metadata.xml b/app-editors/leo/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/app-editors/leo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>