summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-03-03 14:59:18 +0000
committerAli Polatel <hawking@gentoo.org>2008-03-03 14:59:18 +0000
commit76c869e7b41f3c5f61d71b2ed98f32e6bbda5efc (patch)
tree7f1f6f2748e72d75a63ad2edfd6224c33122ba05 /app-editors
parentVersion bump. Fixes some memory leaks and other bugs. (diff)
downloadgentoo-2-76c869e7b41f3c5f61d71b2ed98f32e6bbda5efc.tar.gz
gentoo-2-76c869e7b41f3c5f61d71b2ed98f32e6bbda5efc.tar.bz2
gentoo-2-76c869e7b41f3c5f61d71b2ed98f32e6bbda5efc.zip
Version bump. Fixes some memory leaks and other bugs.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/ChangeLog7
-rw-r--r--app-editors/vim/vim-7.1.266.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index 7f122360fff9..e31d69dda563 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vim
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.296 2008/01/09 21:26:52 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.297 2008/03/03 14:59:17 hawking Exp $
+
+*vim-7.1.266 (03 Mar 2008)
+
+ 03 Mar 2008; Ali Polatel <hawking@gentoo.org> +vim-7.1.266.ebuild:
+ Version bump. Fixes some memory leaks and other bugs.
*vim-7.1.213 (09 Jan 2008)
diff --git a/app-editors/vim/vim-7.1.266.ebuild b/app-editors/vim/vim-7.1.266.ebuild
new file mode 100644
index 000000000000..fbe3c7fb68db
--- /dev/null
+++ b/app-editors/vim/vim-7.1.266.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.1.266.ebuild,v 1.1 2008/03/03 14:59:18 hawking Exp $
+
+inherit vim
+
+VIM_VERSION="7.1"
+VIM_GENTOO_PATCHES="vim-${VIM_VERSION}-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unstable/unix/vim-${VIM_VERSION}.tar.bz2
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-extra.tar.gz
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="${DEPEND}
+ !minimal? ( ~app-editors/vim-core-${PV} )"
+RDEPEND="${RDEPEND}
+ !<app-editors/nvi-1.81.5-r4
+ !minimal? ( ~app-editors/vim-core-${PV} )"