summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-01-18 03:26:25 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-01-18 03:26:25 +0000
commit725cbaeece39052a0396c16e93a64d067a601c1c (patch)
tree9fe18d76a9ae5d96d81afc964f17c0d71b7c2399 /app-editors
parentRDEPEND on >=x11-apps/xinit-1.0.5-r2, which has a patch that allows users to ... (diff)
downloadgentoo-2-725cbaeece39052a0396c16e93a64d067a601c1c.tar.gz
gentoo-2-725cbaeece39052a0396c16e93a64d067a601c1c.tar.bz2
gentoo-2-725cbaeece39052a0396c16e93a64d067a601c1c.zip
Revision bump.
- rewrote src_install to not blow away ${T} (Bug #154997) - backport fix for building with userpriv to stable ebuild (Bug #196939) - general ebuild cleanup and QA (Portage version: 2.1.4)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ted/ChangeLog13
-rw-r--r--app-editors/ted/files/digest-ted-2.17-r1 (renamed from app-editors/ted/files/digest-ted-2.17)0
-rw-r--r--app-editors/ted/ted-2.12.ebuild12
-rw-r--r--app-editors/ted/ted-2.17-r1.ebuild77
-rw-r--r--app-editors/ted/ted-2.17.ebuild66
5 files changed, 96 insertions, 72 deletions
diff --git a/app-editors/ted/ChangeLog b/app-editors/ted/ChangeLog
index 798310369d28..3c3beba51afd 100644
--- a/app-editors/ted/ChangeLog
+++ b/app-editors/ted/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-editors/ted
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ChangeLog,v 1.23 2007/02/21 21:23:06 peper Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ChangeLog,v 1.24 2008/01/18 03:26:24 dirtyepic Exp $
+
+*ted-2.17-r1 (18 Jan 2008)
+
+ 18 Jan 2008; Ryan Hill <dirtyepic@gentoo.org> ted-2.12.ebuild,
+ -ted-2.17.ebuild, +ted-2.17-r1.ebuild:
+ Revision bump.
+ - rewrote src_install to not blow away ${T} (Bug #154997)
+ - backport fix for building with userpriv to stable ebuild (Bug #196939)
+ - general ebuild cleanup and QA
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-editors/ted/files/digest-ted-2.17 b/app-editors/ted/files/digest-ted-2.17-r1
index 9b83c7135399..9b83c7135399 100644
--- a/app-editors/ted/files/digest-ted-2.17
+++ b/app-editors/ted/files/digest-ted-2.17-r1
diff --git a/app-editors/ted/ted-2.12.ebuild b/app-editors/ted/ted-2.12.ebuild
index 7c2e850efa84..0da724181e8a 100644
--- a/app-editors/ted/ted-2.12.ebuild
+++ b/app-editors/ted/ted-2.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.12.ebuild,v 1.12 2005/05/04 01:02:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.12.ebuild,v 1.13 2008/01/18 03:26:24 dirtyepic Exp $
DESCRIPTION="X-based rich text editor."
HOMEPAGE="http://www.nllgg.nl/Ted"
@@ -26,6 +26,9 @@ src_unpack() {
}
src_compile() {
+ # This is a fix for userpriv &| usersandbox.
+ export RPM_BUILD_ROOT="${S}"
+
for dir in Ted tedPackage appFrame appUtil ind bitmap libreg; do
cd ${S}/${dir}
econf --cache-file=../config.cache || die "econf failed"
@@ -40,6 +43,9 @@ src_compile() {
}
src_install() {
+ # This is a fix for userpriv &| usersandbox.
+ export RPM_BUILD_ROOT="${S}"
+
mkdir ${T}/pkg
cd ${T}/pkg || die "Couldn't cd to package"
tar --use=gzip -xvf ${S}/tedPackage/Ted*.tar.gz || die "couldnt unpack tedPackage/Ted*.tar.gz"
@@ -53,6 +59,4 @@ src_install() {
dodir /usr/share/doc/${P}
cp -R ${T}/pkg/Ted ${D}/usr/share/doc/${P} || die "couldnt cp temp/pkg/Ted"
-
- rm -rf ${T}
}
diff --git a/app-editors/ted/ted-2.17-r1.ebuild b/app-editors/ted/ted-2.17-r1.ebuild
new file mode 100644
index 000000000000..e2ddb8d840ac
--- /dev/null
+++ b/app-editors/ted/ted-2.17-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.17-r1.ebuild,v 1.1 2008/01/18 03:26:24 dirtyepic Exp $
+
+DESCRIPTION="X-based rich text editor"
+HOMEPAGE="http://www.nllgg.nl/Ted"
+SRC_URI="ftp://ftp.nluug.nl/pub/editors/ted/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/openmotif
+ >=media-libs/tiff-3.5.7
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.2.3"
+
+S="${WORKDIR}/Ted-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/Ted
+ sed -i \
+ -e 's@^CFLAGS=@CFLAGS= -DDOCUMENT_DIR=\\"/usr/share/doc/${PF}/\\"@' \
+ makefile.in
+}
+
+src_compile() {
+ # This is a fix for userpriv &| usersandbox.
+ RPM_BUILD_ROOT="${S}"
+ for dir in Ted tedPackage appFrame appUtil ind bitmap libreg; do
+ cd "${S}"/${dir}
+ econf --cache-file=../config.cache || die "econf ${dir} failed"
+ done
+
+ # The makefile doesn't really allow parallel make, but it does
+ # no harm either.
+ cd "${S}"
+ emake \
+ DEF_AFMDIR=-DAFMDIR=\\\"/usr/share/Ted/afm\\\" \
+ DEF_INDDIR=-DINDDIR=\\\"/usr/share/Ted/ind\\\" \
+ package.shared \
+ || die "emake failed"
+}
+
+src_install() {
+ # This build system is a little insane. Above we made a package, here we
+ # will unpack it and install it. We have to do it this way or it doesn't
+ # link properly. We could rewrite the Makefile, but this works just as
+ # well.
+
+ # This is a fix for userpriv &| usersandbox.
+ RPM_BUILD_ROOT="${S}"
+
+ mkdir "${S}"/pkg
+ cd "${S}"/pkg
+ # can't use unpack here
+ tar xf ../tedPackage/Ted*.tar.gz || die "failed unpacking ted package"
+
+ insinto /usr/share/Ted/afm
+ doins afm/*
+ insinto /usr/share/Ted/ind
+ doins ind/*
+
+ dobin bin/Ted
+
+ doman Ted/Ted.1
+ rm Ted/Ted.1
+
+ # must stay uncompressed (used internally)
+ insinto /usr/share/doc/${PF}
+ doins Ted/TedDocument-en_US.rtf
+ rm Ted/TedDocument-en_US.rtf
+
+ dodoc Ted/*
+}
diff --git a/app-editors/ted/ted-2.17.ebuild b/app-editors/ted/ted-2.17.ebuild
deleted file mode 100644
index c87e5733df01..000000000000
--- a/app-editors/ted/ted-2.17.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.17.ebuild,v 1.4 2007/06/26 01:34:52 mr_bones_ Exp $
-
-DESCRIPTION="X-based rich text editor"
-HOMEPAGE="http://www.nllgg.nl/Ted"
-SRC_URI="ftp://ftp.nluug.nl/pub/editors/ted/${P}.src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-
-DEPEND="x11-libs/openmotif
- >=media-libs/tiff-3.5.7
- >=media-libs/jpeg-6b
- >=media-libs/libpng-1.2.3"
-
-S="${WORKDIR}/Ted-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"/Ted
- sed -i \
- -e 's@^CFLAGS=@CFLAGS= -DDOCUMENT_DIR=\\"/usr/share/doc/${PF}/Ted/\\"@' \
- makefile.in
-}
-
-src_compile() {
- # This is a fix for userpriv &| usersandbox.
- export RPM_BUILD_ROOT="${S}"
- for dir in Ted tedPackage appFrame appUtil ind bitmap libreg; do
- cd ${S}/${dir}
- econf --cache-file=../config.cache || die "econf failed"
- done
-
- # The makefile doesn't really allow parallel make, but it does
- # no harm either.
- cd ${S}
- emake \
- DEF_AFMDIR=-DAFMDIR=\\\"/usr/share/Ted/afm\\\" \
- DEF_INDDIR=-DINDDIR=\\\"/usr/share/Ted/ind\\\" \
- package.shared \
- || die "couldnt emake"
-}
-
-src_install() {
- # This is a fix for userpriv &| usersandbox.
- export RPM_BUILD_ROOT="${S}"
-
- mkdir ${T}/pkg
- cd ${T}/pkg || die "Couldn't cd to package"
- tar --use=gzip -xvf ${S}/tedPackage/Ted*.tar.gz || die "couldnt unpack tedPackage/Ted*.tar.gz"
-
- dodir /usr/share/Ted
- cp -R ${T}/pkg/afm ${D}/usr/share/Ted/afm || die "couldnt cp temp/pkg/afm"
- cp -R ${T}/pkg/ind ${D}/usr/share/Ted/ind || die "couldnt cp temp/pkg/ind"
-
- exeinto /usr/bin
- doexe ${T}/pkg/bin/* || die "couldnt doexe temp/pkg/bin/*"
-
- dodir /usr/share/doc/${P}
- cp -R ${T}/pkg/Ted ${D}/usr/share/doc/${P} || die "couldnt cp temp/pkg/Ted"
-
- rm -rf ${T}
-}