summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-06-07 16:43:46 +0000
committerJim Ramsay <lack@gentoo.org>2010-06-07 16:43:46 +0000
commit65b9d1c71df24e7caa7f77a063c450a55b9d9020 (patch)
treee66b937c076dc307fc232bffcdf3e0ea16e312e7 /app-editors
parentvim-7.2.442 is released (Fixes bug #308927) (diff)
downloadgentoo-2-65b9d1c71df24e7caa7f77a063c450a55b9d9020.tar.gz
gentoo-2-65b9d1c71df24e7caa7f77a063c450a55b9d9020.tar.bz2
gentoo-2-65b9d1c71df24e7caa7f77a063c450a55b9d9020.zip
vim-7.2.442 is released (Fixes bug #308927)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/ChangeLog7
-rw-r--r--app-editors/vim/vim-7.2.442.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index 05658eba344d..d28b5d9c1f28 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vim
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.347 2010/05/09 18:55:49 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.348 2010/06/07 16:43:46 lack Exp $
+
+*vim-7.2.442 (07 Jun 2010)
+
+ 07 Jun 2010; Jim Ramsay <lack@gentoo.org> +vim-7.2.442.ebuild:
+ vim-7.2.442 is released (Fixes bug #308927)
*vim-7.2.416 (09 May 2010)
diff --git a/app-editors/vim/vim-7.2.442.ebuild b/app-editors/vim/vim-7.2.442.ebuild
new file mode 100644
index 000000000000..dc012ad27c28
--- /dev/null
+++ b/app-editors/vim/vim-7.2.442.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.2.442.ebuild,v 1.1 2010/06/07 16:43:46 lack Exp $
+
+EAPI=3
+inherit vim
+
+VIM_VERSION="7.2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-extra.tar.gz
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ vim_src_prepare
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ epatch "${FILESDIR}"/${PN}-7.1-interix-link.patch
+ epatch "${FILESDIR}"/${PN}-7.1.319-interix-cflags.patch
+ fi
+ epatch "${FILESDIR}"/${PN}-7.1.285-darwin-x11link.patch
+}