summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2011-08-13 15:55:04 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2011-08-13 15:55:04 +0000
commit4bfea2752015e0815cdb378820f83272f837a5e2 (patch)
tree508aba35608c24567d0cde174e3ab7b20514c73e /app-editors
parentRevision bump to fix bug #241002 (OpenRC related improvements) and bug #36305... (diff)
downloadgentoo-2-4bfea2752015e0815cdb378820f83272f837a5e2.tar.gz
gentoo-2-4bfea2752015e0815cdb378820f83272f837a5e2.tar.bz2
gentoo-2-4bfea2752015e0815cdb378820f83272f837a5e2.zip
Version bump, remove old files.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/ChangeLog9
-rw-r--r--app-editors/scite/files/scite-1.79-install.patch20
-rw-r--r--app-editors/scite/files/scite-2.28-no-lua.patch (renamed from app-editors/scite/files/scite-1.79-no-lua.patch)7
-rw-r--r--app-editors/scite/scite-2.28.ebuild83
4 files changed, 95 insertions, 24 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index 6bff14bce9f9..3798d01f21c1 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/scite
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.120 2011/08/07 03:16:29 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.121 2011/08/13 15:55:04 nelchael Exp $
+
+*scite-2.28 (13 Aug 2011)
+
+ 13 Aug 2011; Krzysztof Pawlik <nelchael@gentoo.org>
+ -files/scite-1.79-install.patch, -files/scite-1.79-no-lua.patch,
+ +scite-2.28.ebuild, +files/scite-2.28-no-lua.patch:
+ Version bump, remove old files.
07 Aug 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> scite-2.27.ebuild:
x86 stable wrt bug #377087
diff --git a/app-editors/scite/files/scite-1.79-install.patch b/app-editors/scite/files/scite-1.79-install.patch
deleted file mode 100644
index 52f51e65b676..000000000000
--- a/app-editors/scite/files/scite-1.79-install.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- scite/gtk/makefile.orig 2006-10-09 06:26:55 -0300
-+++ scite/gtk/makefile 2006-10-09 06:36:09 -0300
-@@ -123,11 +123,14 @@
-
- ifdef gnomeprefix
- ifdef GTK2
-- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
-+ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
-+ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
- else
-- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
-+ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
-+ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
- endif
-- $(INSTALL) -m 644 -D Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
-+ $(INSTALL) -m 755 -d $(DESTDIR)$(pixmapdir)/
-+ $(INSTALL) -m 644 Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
- endif
-
- uninstall:
diff --git a/app-editors/scite/files/scite-1.79-no-lua.patch b/app-editors/scite/files/scite-2.28-no-lua.patch
index 2511cef0faf9..884d509d67f4 100644
--- a/app-editors/scite/files/scite-1.79-no-lua.patch
+++ b/app-editors/scite/files/scite-2.28-no-lua.patch
@@ -1,6 +1,7 @@
---- scite/src/SciTEProps.cxx 2008-04-05 17:23:22.000000000 +0200
-+++ scite/src/SciTEProps.cxx 2008-04-05 17:23:41.000000000 +0200
-@@ -1461,10 +1461,12 @@
+diff -Nru scite228.vanilla/scite/src/SciTEProps.cxx scite228/scite/src/SciTEProps.cxx
+--- scite228.vanilla/scite/src/SciTEProps.cxx 2011-08-01 04:49:30.000000000 +0200
++++ scite228/scite/src/SciTEProps.cxx 2011-08-13 17:43:39.380238668 +0200
+@@ -1651,10 +1651,12 @@
// return the int value of the command name passed in.
int SciTEBase::GetMenuCommandAsInt(SString commandName) {
diff --git a/app-editors/scite/scite-2.28.ebuild b/app-editors/scite/scite-2.28.ebuild
new file mode 100644
index 000000000000..fd6855e8d3c8
--- /dev/null
+++ b/app-editors/scite/scite-2.28.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-2.28.ebuild,v 1.1 2011/08/13 15:55:04 nelchael Exp $
+
+EAPI="1"
+
+inherit toolchain-funcs eutils
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://www.scintilla.org/SciTE.html"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="Scintilla"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="lua"
+
+RDEPEND="x11-libs/gtk+:2
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}/gtk"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/scintilla/gtk"
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e "s#-Os##" \
+ || die "error patching makefile"
+
+ cd "${WORKDIR}/scite/gtk"
+ sed -i makefile \
+ -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
+ || die "error patching makefile"
+
+ cd "${S}"
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ -e 's#-g root#-g 0#' \
+ -e "s#-Os##" \
+ || die "error patching makefile"
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${PN}-2.28-no-lua.patch"
+}
+
+src_compile() {
+ make -C ../../scintilla/gtk || die "prep make failed"
+ if use lua; then
+ emake || die "make failed"
+ else
+ emake NO_LUA=1 || die "make failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin || die
+ dodir /usr/share/{pixmaps,applications} || die
+
+ make prefix="${D}/usr" install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv "${D}/usr/bin/SciTE" "${D}/usr/bin/scite" || die
+ dosym /usr/bin/scite /usr/bin/SciTE || die
+
+ # replace .desktop file with our own working version
+ rm -f "${D}/usr/share/applications/SciTE.desktop"
+ insinto /usr/share/applications
+ doins "${FILESDIR}/scite.desktop" || die
+
+ doman ../doc/scite.1 || die
+ dodoc ../README || die
+}