summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 18:35:33 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 18:35:33 +0000
commit49c2df05cf62c2fde2407e5265fdf5f3f30ad4bc (patch)
tree360e3baa20d2825c7a03e188f3b3538515410045 /app-editors
parentVersion bump. Remove intermediate version. (diff)
downloadgentoo-2-49c2df05cf62c2fde2407e5265fdf5f3f30ad4bc.tar.gz
gentoo-2-49c2df05cf62c2fde2407e5265fdf5f3f30ad4bc.tar.bz2
gentoo-2-49c2df05cf62c2fde2407e5265fdf5f3f30ad4bc.zip
QA: Respect LDFLAGS and CC (bug 243556), fixed building with --as-needed (bug 246881)
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/dav/ChangeLog9
-rw-r--r--app-editors/dav/dav-0.8.5.ebuild20
-rw-r--r--app-editors/dav/files/dav-0.8.5-asneeded.patch12
3 files changed, 35 insertions, 6 deletions
diff --git a/app-editors/dav/ChangeLog b/app-editors/dav/ChangeLog
index 9b30028b6280..ec032e43d082 100644
--- a/app-editors/dav/ChangeLog
+++ b/app-editors/dav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/dav
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/dav/ChangeLog,v 1.11 2007/03/12 18:29:52 armin76 Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/dav/ChangeLog,v 1.12 2008/12/30 18:35:33 angelos Exp $
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org>
+ +files/dav-0.8.5-asneeded.patch, dav-0.8.5.ebuild:
+ QA: Respect LDFLAGS and CC (bug 243556), fixed building with --as-needed
+ (bug 246881)
12 Mar 2007; Raúl Porcel <armin76@gentoo.org> dav-0.8.5.ebuild:
x86 stable
diff --git a/app-editors/dav/dav-0.8.5.ebuild b/app-editors/dav/dav-0.8.5.ebuild
index 150f36d0148a..9e2ec85be66c 100644
--- a/app-editors/dav/dav-0.8.5.ebuild
+++ b/app-editors/dav/dav-0.8.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/dav/dav-0.8.5.ebuild,v 1.9 2007/03/12 18:29:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/dav/dav-0.8.5.ebuild,v 1.10 2008/12/30 18:35:33 angelos Exp $
+
+inherit eutils toolchain-funcs
DESCRIPTION="A minimal console text editor"
HOMEPAGE="http://dav-text.sourceforge.net/"
@@ -16,10 +18,20 @@ IUSE=""
DEPEND="sys-libs/ncurses"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
src_compile() {
- emake CFLAGS="${CFLAGS}" LDFLAGS="-lncurses ${CFLAGS}" || die
+ emake CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -lncurses" \
+ CC="$(tc-getCC)" \
+ || die "emake failed"
}
src_install() {
- emake DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die
+ dodoc README
}
diff --git a/app-editors/dav/files/dav-0.8.5-asneeded.patch b/app-editors/dav/files/dav-0.8.5-asneeded.patch
new file mode 100644
index 000000000000..75a43c67f43d
--- /dev/null
+++ b/app-editors/dav/files/dav-0.8.5-asneeded.patch
@@ -0,0 +1,12 @@
+diff -u -r a/Makefile b/Makefile
+--- a/Makefile 2004-02-22 02:04:07.000000000 +0100
++++ b/Makefile 2008-12-30 19:31:19.000000000 +0100
+@@ -12,7 +12,7 @@
+ LDFLAGS=-lncurses -O3 -Wall
+
+ dav: $(OBJECTS)
+- $(CC) $(LDFLAGS) $(OBJECTS) -o dav
++ $(CC) $(OBJECTS) $(LDFLAGS) -o dav
+
+ install:
+ mkdir -p $(DESTDIR)/usr/bin