summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-02-04 14:54:31 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-02-04 14:54:31 +0000
commit39e47fd94005605059fa6af63bae14d6108a9b79 (patch)
tree70d754a5cdb6f47c2e5d69d6b6171e43ac8e0013 /app-editors
parentAdd in patch, fixes bug #165255. (diff)
downloadgentoo-2-39e47fd94005605059fa6af63bae14d6108a9b79.tar.gz
gentoo-2-39e47fd94005605059fa6af63bae14d6108a9b79.tar.bz2
gentoo-2-39e47fd94005605059fa6af63bae14d6108a9b79.zip
add a check for uncompressed man pages and clean up
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/ChangeLog6
-rw-r--r--app-editors/emacs/emacs-21.4-r6.ebuild9
2 files changed, 11 insertions, 4 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index a6daf0d1a04e..7d7ba6d5ac92 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/emacs
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.116 2007/02/03 11:25:24 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.117 2007/02/04 14:54:31 opfer Exp $
+
+ 04 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
+ -emacs-21.4-r5.ebuild, emacs-21.4-r6.ebuild:
+ add a check for uncompressed man pages and clean up
03 Feb 2007; Christian Faulhammer <opfer@gentoo.org> emacs-21.4-r6.ebuild:
determine compression suffix correctly and finally
diff --git a/app-editors/emacs/emacs-21.4-r6.ebuild b/app-editors/emacs/emacs-21.4-r6.ebuild
index 804fd2529cbc..2e3e5b532332 100644
--- a/app-editors/emacs/emacs-21.4-r6.ebuild
+++ b/app-editors/emacs/emacs-21.4-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r6.ebuild,v 1.4 2007/02/03 11:25:24 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r6.ebuild,v 1.5 2007/02/04 14:54:31 opfer Exp $
inherit flag-o-matic eutils alternatives toolchain-funcs
@@ -160,7 +160,10 @@ src_install() {
update-alternatives() {
# extract the suffix of the manpages to determine the correct compression program
- local suffix=`ls /usr/share/man/man1/emacs.emacs-* |sed s/".*\."//g|tail -n 1`
+ local suffix=".`ls /usr/share/man/man1/emacs.emacs-* |sed s/".*\."//g|tail -n 1`"
+ if [ suffix = 1 ]; then
+ suffix=""
+ fi
# this creates symlinks for binaries and man pages, so the correct ones in a slotted
# environment can be accessed
@@ -171,7 +174,7 @@ update-alternatives() {
for j in emacs emacsclient etags ctags
do
- alternatives_auto_makesym "/usr/share/man/man1/$j.1.${suffix}" "/usr/share/man/man1/$j.emacs-*"
+ alternatives_auto_makesym "/usr/share/man/man1/$j.1${suffix}" "/usr/share/man/man1/$j.emacs-*"
done
}