summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2006-12-10 13:55:11 +0000
committerRyan Hill <dirtyepic@gentoo.org>2006-12-10 13:55:11 +0000
commit346ed34ef9d0a63eb5d84b863939701903ffdcd7 (patch)
treed207cdf2705a2b63931e55974c1001767af5e08b /app-editors
parentChanged perl-core to virtual (diff)
downloadgentoo-2-346ed34ef9d0a63eb5d84b863939701903ffdcd7.tar.gz
gentoo-2-346ed34ef9d0a63eb5d84b863939701903ffdcd7.tar.bz2
gentoo-2-346ed34ef9d0a63eb5d84b863939701903ffdcd7.zip
Fix building with GCC 4.1. Bug #149758.
(Portage version: 2.1.2_rc3)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/geresh/ChangeLog8
-rw-r--r--app-editors/geresh/files/digest-geresh-0.4.12
-rw-r--r--app-editors/geresh/files/geresh-0.4.1-gcc4.patch21
-rw-r--r--app-editors/geresh/geresh-0.4.1.ebuild14
-rw-r--r--app-editors/geresh/metadata.xml7
5 files changed, 45 insertions, 7 deletions
diff --git a/app-editors/geresh/ChangeLog b/app-editors/geresh/ChangeLog
index 006bf0c1325e..92ef9775280b 100644
--- a/app-editors/geresh/ChangeLog
+++ b/app-editors/geresh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/geresh
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/geresh/ChangeLog,v 1.7 2005/07/08 16:02:53 dholm Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/geresh/ChangeLog,v 1.8 2006/12/10 13:55:11 dirtyepic Exp $
+
+ 10 Dec 2006; Ryan Hill <dirtyepic@gentoo.org>
+ +files/geresh-0.4.1-gcc4.patch, metadata.xml, geresh-0.4.1.ebuild:
+ Fix building with GCC 4.1. Bug #149758.
08 Jul 2005; David Holm <dholm@gentoo.org> geresh-0.4.1.ebuild:
Added to ~ppc.
diff --git a/app-editors/geresh/files/digest-geresh-0.4.1 b/app-editors/geresh/files/digest-geresh-0.4.1
index a36509d19487..9107e6549acf 100644
--- a/app-editors/geresh/files/digest-geresh-0.4.1
+++ b/app-editors/geresh/files/digest-geresh-0.4.1
@@ -1 +1,3 @@
MD5 25e2cc7aed0b1273ca66a50a4e4d2de4 geresh-0.4.1.tar.gz 160030
+RMD160 df7688de34eb5fff93e55962b22feac83ec8fd08 geresh-0.4.1.tar.gz 160030
+SHA256 510070fd0521783dbc210bd47452fb22c965ded4dc687793e8624503d52b2ff2 geresh-0.4.1.tar.gz 160030
diff --git a/app-editors/geresh/files/geresh-0.4.1-gcc4.patch b/app-editors/geresh/files/geresh-0.4.1-gcc4.patch
new file mode 100644
index 000000000000..10e6c4912127
--- /dev/null
+++ b/app-editors/geresh/files/geresh-0.4.1-gcc4.patch
@@ -0,0 +1,21 @@
+diff -Naur geresh-0.4.1-orig/editbox.h geresh-0.4.1/editbox.h
+--- geresh-0.4.1-orig/editbox.h 2006-12-10 07:42:48.000000000 -0600
++++ geresh-0.4.1/editbox.h 2006-12-10 07:43:09.000000000 -0600
+@@ -671,7 +671,7 @@
+ int para_num
+ );
+
+- void EditBox::redraw_unwrapped_paragraph(
++ void redraw_unwrapped_paragraph(
+ Paragraph &p,
+ int window_start_line,
+ bool only_cursor,
+@@ -683,7 +683,7 @@
+ bool eop_is_selected
+ );
+
+- void EditBox::redraw_wrapped_paragraph(
++ void redraw_wrapped_paragraph(
+ Paragraph &p,
+ int window_start_line,
+ bool only_cursor,
diff --git a/app-editors/geresh/geresh-0.4.1.ebuild b/app-editors/geresh/geresh-0.4.1.ebuild
index 91be8cdbd5f0..357ac0c3d79d 100644
--- a/app-editors/geresh/geresh-0.4.1.ebuild
+++ b/app-editors/geresh/geresh-0.4.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/geresh/geresh-0.4.1.ebuild,v 1.8 2005/07/08 16:02:53 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/geresh/geresh-0.4.1.ebuild,v 1.9 2006/12/10 13:55:11 dirtyepic Exp $
+
+inherit eutils
DESCRIPTION="A simple multi-lingual console text editor with bidi & utf support"
HOMEPAGE="http://www.typo.co.il/~mooffie/geresh/"
@@ -18,6 +20,14 @@ DEPEND="dev-libs/fribidi
virtual/aspell-dict
)"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Bug #149758
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
src_install() {
make install DESTDIR="${D}" || die
}
diff --git a/app-editors/geresh/metadata.xml b/app-editors/geresh/metadata.xml
index d9cd2cad66c2..9f3fdee2246b 100644
--- a/app-editors/geresh/metadata.xml
+++ b/app-editors/geresh/metadata.xml
@@ -1,7 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
-<email>maintainer-needed@gentoo.org</email>
-</maintainer>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
</pkgmetadata>