summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-08-30 16:28:43 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-08-30 16:28:43 +0000
commit32ceb7cf5f7b52930716891960681d367ca38990 (patch)
tree6d1d20b923feaae3cb3b31659c1a067b9f0da8cf /app-editors
parentOld. (diff)
downloadgentoo-2-32ceb7cf5f7b52930716891960681d367ca38990.tar.gz
gentoo-2-32ceb7cf5f7b52930716891960681d367ca38990.tar.bz2
gentoo-2-32ceb7cf5f7b52930716891960681d367ca38990.zip
Fix build with GCC 4.7, wrt bug #431796. Add upstream metadata.
(Portage version: 2.1.11.12/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/znotes/ChangeLog7
-rw-r--r--app-editors/znotes/files/znotes-0.4.5-gcc-4.7.patch24
-rw-r--r--app-editors/znotes/metadata.xml7
-rw-r--r--app-editors/znotes/znotes-0.4.5.ebuild4
4 files changed, 38 insertions, 4 deletions
diff --git a/app-editors/znotes/ChangeLog b/app-editors/znotes/ChangeLog
index f3039baa32cc..0163d9ab2d77 100644
--- a/app-editors/znotes/ChangeLog
+++ b/app-editors/znotes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/znotes
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/znotes/ChangeLog,v 1.9 2012/05/14 20:33:21 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/znotes/ChangeLog,v 1.10 2012/08/30 16:28:42 kensington Exp $
+
+ 30 Aug 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/znotes-0.4.5-gcc-4.7.patch, metadata.xml, znotes-0.4.5.ebuild:
+ Fix build with GCC 4.7, wrt bug #431796. Add upstream metadata.
14 May 2012; Michael Palimaka <kensington@gentoo.org> -znotes-0.4.3.ebuild:
Remove old.
@@ -45,4 +49,3 @@
04 Nov 2009; Ben de Groot <yngwin@gentoo.org> +znotes-0.3.4.ebuild,
+metadata.xml:
Initial import. Ebuild slightly edited from the one provided by upstream.
-
diff --git a/app-editors/znotes/files/znotes-0.4.5-gcc-4.7.patch b/app-editors/znotes/files/znotes-0.4.5-gcc-4.7.patch
new file mode 100644
index 000000000000..ae8c4eca7b8e
--- /dev/null
+++ b/app-editors/znotes/files/znotes-0.4.5-gcc-4.7.patch
@@ -0,0 +1,24 @@
+From 9cb09430444e36415e887317525a24e542e135fb Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Fri, 31 Aug 2012 02:15:30 +1000
+Subject: [PATCH] Fix build with GCC 4.7.
+
+---
+ single_inst/qtlocalpeer.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/single_inst/qtlocalpeer.cpp b/single_inst/qtlocalpeer.cpp
+index 6d7c24f..f9663c9 100644
+--- a/single_inst/qtlocalpeer.cpp
++++ b/single_inst/qtlocalpeer.cpp
+@@ -50,6 +50,7 @@ static PProcessIdToSessionId pProcessIdToSessionId = 0;
+ #endif
+ #if defined(Q_OS_UNIX)
+ #include <time.h>
++#include <unistd.h>
+ #endif
+
+ namespace QtLP_Private {
+--
+1.7.12
+
diff --git a/app-editors/znotes/metadata.xml b/app-editors/znotes/metadata.xml
index dc439f7e84f5..1fc9dad40de4 100644
--- a/app-editors/znotes/metadata.xml
+++ b/app-editors/znotes/metadata.xml
@@ -1,5 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>qt</herd>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="sourceforge">znotes</remote-id>
+ <remote-id type="github">proton/zNotes</remote-id>
+ <bugs-to>https://github.com/proton/zNotes/issues</bugs-to>
+ </upstream>
</pkgmetadata>
diff --git a/app-editors/znotes/znotes-0.4.5.ebuild b/app-editors/znotes/znotes-0.4.5.ebuild
index aaeaf631bbf7..c67c88475be2 100644
--- a/app-editors/znotes/znotes-0.4.5.ebuild
+++ b/app-editors/znotes/znotes-0.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/znotes/znotes-0.4.5.ebuild,v 1.1 2012/01/30 07:49:35 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/znotes/znotes-0.4.5.ebuild,v 1.2 2012/08/30 16:28:42 kensington Exp $
EAPI=4
inherit qt4-r2
@@ -20,6 +20,8 @@ RDEPEND="${DEPEND}"
DOCS="CHANGELOG THANKS"
+PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )
+
src_configure() {
lrelease znotes.pro || die "lrelease failed"
qt4-r2_src_configure