summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 03:39:15 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 03:39:15 +0000
commit317490a6a3b7de516dfd676f87c67f60708e3d6c (patch)
tree4415751da95118659fa6ccf38259ff2170f9f838 /app-editors
parentadd inherit eutils (diff)
downloadgentoo-2-317490a6a3b7de516dfd676f87c67f60708e3d6c.tar.gz
gentoo-2-317490a6a3b7de516dfd676f87c67f60708e3d6c.tar.bz2
gentoo-2-317490a6a3b7de516dfd676f87c67f60708e3d6c.zip
add inherit eutils
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-21.3-r2.ebuild17
-rw-r--r--app-editors/gedit/gedit-2.4.0.ebuild4
-rw-r--r--app-editors/gedit/gedit-2.4.1.ebuild14
-rw-r--r--app-editors/jed/jed-0.99.14-r1.ebuild4
-rw-r--r--app-editors/jed/jed-0.99.16.ebuild32
-rw-r--r--app-editors/jove/jove-4.16.0.58.ebuild16
-rw-r--r--app-editors/kvim/kvim-6.2.14.ebuild16
-rw-r--r--app-editors/lpe/lpe-1.2.6.ebuild15
8 files changed, 58 insertions, 60 deletions
diff --git a/app-editors/emacs/emacs-21.3-r2.ebuild b/app-editors/emacs/emacs-21.3-r2.ebuild
index 2e260012e91b..81a336bbda7d 100644
--- a/app-editors/emacs/emacs-21.3-r2.ebuild
+++ b/app-editors/emacs/emacs-21.3-r2.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r2.ebuild,v 1.10 2004/03/16 18:46:57 usata Exp $
-
-IUSE="X nls motif leim gnome Xaw3d"
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r2.ebuild,v 1.11 2004/04/06 03:35:12 vapier Exp $
inherit flag-o-matic
-S=${WORKDIR}/${P}
DESCRIPTION="An incredibly powerful, extensible text editor"
+HOMEPAGE="http://www.gnu.org/software/emacs"
SRC_URI="mirror://gnu/emacs/${P}.tar.gz
leim? ( mirror://gnu/emacs/leim-${PV}.tar.gz )"
-HOMEPAGE="http://www.gnu.org/software/emacs"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc sparc alpha amd64 hppa ia64"
+IUSE="X nls motif leim gnome Xaw3d"
RDEPEND="sys-libs/ncurses
sys-libs/gdbm
@@ -48,7 +47,7 @@ src_compile() {
local myconf
use nls || myconf="${myconf} --disable-nls"
- if [ "`use X`" ] ; then
+ if use X ; then
myconf="${myconf}
--with-x
--with-xpm
@@ -71,7 +70,7 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
einstall || die
einfo "Fixing info documentation..."
rm -f ${D}/usr/share/info/dir
@@ -88,7 +87,7 @@ src_install () {
keepdir /usr/share/emacs/${PV}/leim
- if [ "`use gnome`" ] ; then
+ if use gnome ; then
insinto /usr/share/gnome/apps/Application
doins ${FILESDIR}/${DFILE}
fi
diff --git a/app-editors/gedit/gedit-2.4.0.ebuild b/app-editors/gedit/gedit-2.4.0.ebuild
index 9fd0ecd0a2b0..6d3a65ba5cb4 100644
--- a/app-editors/gedit/gedit-2.4.0.ebuild
+++ b/app-editors/gedit/gedit-2.4.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.4.0.ebuild,v 1.9 2003/12/13 01:16:46 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.4.0.ebuild,v 1.10 2004/04/06 03:35:48 vapier Exp $
-inherit gnome2
+inherit gnome2 eutils
IUSE="spell"
DESCRIPTION="A text editor for the Gnome2 desktop"
diff --git a/app-editors/gedit/gedit-2.4.1.ebuild b/app-editors/gedit/gedit-2.4.1.ebuild
index 6aa5f525e824..845c512658bd 100644
--- a/app-editors/gedit/gedit-2.4.1.ebuild
+++ b/app-editors/gedit/gedit-2.4.1.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.4.1.ebuild,v 1.9 2004/03/17 01:00:59 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.4.1.ebuild,v 1.10 2004/04/06 03:36:16 vapier Exp $
-inherit gnome2
+inherit gnome2 eutils
-IUSE="spell"
DESCRIPTION="A text editor for the Gnome2 desktop"
HOMEPAGE="http://www.gnome.org/"
-SLOT="0"
+
LICENSE="GPL-2"
-KEYWORDS="x86 ppc alpha sparc hppa ~amd64 ia64 ~mips"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha hppa ~amd64 ia64 ~mips"
+IUSE="spell"
RDEPEND=">=gnome-base/libglade-2
>=dev-libs/popt-1.5
@@ -20,13 +21,12 @@ RDEPEND=">=gnome-base/libglade-2
>=gnome-base/libgnomeprintui-2.4
>=x11-libs/gtksourceview-0.7
spell? ( virtual/aspell-dict )"
-
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0
>=app-text/scrollkeeper-0.3.11
>=dev-util/intltool-0.25"
-DOCS="AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README THANKS TODO"
+DOCS="AUTHORS BUGS ChangeLog INSTALL NEWS README THANKS TODO"
src_unpack() {
unpack ${A}
diff --git a/app-editors/jed/jed-0.99.14-r1.ebuild b/app-editors/jed/jed-0.99.14-r1.ebuild
index 7fa4617ebd14..091981d164a8 100644
--- a/app-editors/jed/jed-0.99.14-r1.ebuild
+++ b/app-editors/jed/jed-0.99.14-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.14-r1.ebuild,v 1.14 2004/01/18 20:14:46 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.14-r1.ebuild,v 1.15 2004/04/06 03:36:23 vapier Exp $
+
+inherit eutils
IUSE="X gpm"
diff --git a/app-editors/jed/jed-0.99.16.ebuild b/app-editors/jed/jed-0.99.16.ebuild
index db48f14fc40b..c71e61fa0721 100644
--- a/app-editors/jed/jed-0.99.16.ebuild
+++ b/app-editors/jed/jed-0.99.16.ebuild
@@ -1,34 +1,35 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.16.ebuild,v 1.7 2004/01/18 20:14:46 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.16.ebuild,v 1.8 2004/04/06 03:37:20 vapier Exp $
-IUSE="X gpm"
+inherit eutils
P0=${PN}-0.99-16
S=${WORKDIR}/${P0}
DESCRIPTION="Console S-Lang-based editor"
-SRC_URI="ftp://ftp.jedsoft.org/pub/davis/jed/v0.99/${PN}-0.99-16.tar.bz2"
HOMEPAGE="http://www.jedsoft.org/jed/"
+SRC_URI="ftp://ftp.jedsoft.org/pub/davis/jed/v0.99/${PN}-0.99-16.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
+IUSE="X gpm"
DEPEND=">=sys-libs/slang-1.4.5
X? ( virtual/x11 )
gpm? ( sys-libs/gpm )"
-
PROVIDE="virtual/editor"
-SLOT="0"
-KEYWORDS="x86 ppc sparc "
-LICENSE="GPL-2"
-
src_compile() {
export JED_ROOT=/usr/share/jed
- ./configure --host=${CHOST} \
- --prefix=$JED_ROOT \
+ ./configure \
+ --host=${CHOST} \
+ --prefix=$PJED_ROOT} \
--bindir=/usr/bin \
--mandir=/usr/share/man || die
- if [ -n "`use gpm`" ] ; then
+ if use gpm ; then
cd src
sed -i -e 's/#MOUSEFLAGS/MOUSEFLAGS/' \
-e 's/#MOUSELIB/MOUSELIB/' \
@@ -42,20 +43,19 @@ src_compile() {
emake || die
- if [ -n "`use X`" ] ; then
+ if use X ; then
emake xjed || die
fi
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
cd doc
cp README AUTHORS
cd ${S}
- dodoc COPYING COPYRIGHT INSTALL INSTALL.unx README \
- doc/AUTHORS doc/manual/jed.tex
+ dodoc INSTALL INSTALL.unx README doc/AUTHORS doc/manual/jed.tex
cd ${S}/info
rm info.info
@@ -72,5 +72,3 @@ src_install () {
rm -rf usr/share/jed/info
# can't rm usr/share/jed/doc -- used internally by jed/xjed
}
-
-
diff --git a/app-editors/jove/jove-4.16.0.58.ebuild b/app-editors/jove/jove-4.16.0.58.ebuild
index 1a240d242ed5..e5ad797e935a 100644
--- a/app-editors/jove/jove-4.16.0.58.ebuild
+++ b/app-editors/jove/jove-4.16.0.58.ebuild
@@ -1,22 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jove/jove-4.16.0.58.ebuild,v 1.1 2004/02/26 03:16:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jove/jove-4.16.0.58.ebuild,v 1.2 2004/04/06 03:37:50 vapier Exp $
-IUSE="X"
+inherit eutils
-S=${WORKDIR}
DESCRIPTION="Jonathan's Own Version of Emacs -- a light emacs-like editor without LISP bindings"
HOMEPAGE="ftp://ftp.cs.toronto.edu/cs/ftp/pub/hugh/jove-dev/"
SRC_URI="http://ftp.debian.org/debian/pool/main/j/${PN}/${P/-/_}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/j/${PN}/${P/-/_}-1.diff.gz"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="~x86"
+IUSE="X"
DEPEND="sys-libs/ncurses
X? ( x11-libs/xview )"
+S=${WORKDIR}
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -31,8 +33,7 @@ src_unpack() {
src_compile() {
emake || die
- if use X
- then
+ if use X ; then
emake XJOVEJOME=/usr makexjove || die
fi
}
@@ -40,8 +41,7 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
- if use X
- then
+ if use X ; then
make DESTDIR=${D} XJOVEHOME=${D}/usr MANDIR=${D}/usr/share/man/man1 installxjove || die
fi
diff --git a/app-editors/kvim/kvim-6.2.14.ebuild b/app-editors/kvim/kvim-6.2.14.ebuild
index 7c19af5011b6..b0c00c4568ce 100644
--- a/app-editors/kvim/kvim-6.2.14.ebuild
+++ b/app-editors/kvim/kvim-6.2.14.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/kvim/kvim-6.2.14.ebuild,v 1.8 2004/04/04 20:49:53 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kvim/kvim-6.2.14.ebuild,v 1.9 2004/04/06 03:38:43 vapier Exp $
-IUSE="python gpm nls ruby perl"
-
-inherit kde-base
+inherit kde-base eutils
need-kde 3
-S="${WORKDIR}/${P//_}"
DESCRIPTION="KDE editor based on vim"
-SRC_URI="http://freenux.org/${PN}/${P//_}.tar.bz2"
HOMEPAGE="http://www.freehackers.org/${PN}"
+SRC_URI="http://freenux.org/${PN}/${P//_}.tar.bz2"
+
LICENSE="GPL-2"
KEYWORDS="alpha x86 sparc ~ppc ~amd64"
-newdepend ">=app-editors/vim-core-6.2
+IUSE="python gpm nls ruby perl"
+
+DEPEND=">=app-editors/vim-core-6.2
ncurses? ( >=sys-libs/ncurses-5.2-r2 )
!ncurses? ( sys-libs/libtermcap-compat )
cscope? ( dev-util/cscope )
@@ -22,6 +22,8 @@ newdepend ">=app-editors/vim-core-6.2
python? ( dev-lang/python )
ruby? ( dev-lang/ruby )"
+S="${WORKDIR}/${P//_}"
+
src_unpack() {
unpack ${A}
cd ${S}
diff --git a/app-editors/lpe/lpe-1.2.6.ebuild b/app-editors/lpe/lpe-1.2.6.ebuild
index a8c5476ea4c5..96fe38058bf7 100644
--- a/app-editors/lpe/lpe-1.2.6.ebuild
+++ b/app-editors/lpe/lpe-1.2.6.ebuild
@@ -1,34 +1,31 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lpe/lpe-1.2.6.ebuild,v 1.2 2003/10/21 00:28:57 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lpe/lpe-1.2.6.ebuild,v 1.3 2004/04/06 03:39:15 vapier Exp $
+
+inherit eutils
DESCRIPTION="Lightweight Programmers Editor"
HOMEPAGE="http://cdsmith.twu.net/professional/opensource/lpe.html"
SRC_URI="ftp://ftp.twu.net/users/cdsmith/lpe/${P}.tar.gz"
LICENSE="GPL-2"
-SLOT=0
+SLOT="0"
KEYWORDS="~x86 ~sparc"
IUSE="nls"
DEPEND="sys-libs/slang"
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
-
epatch ${FILESDIR}/${P}-gentoo.patch
}
-
src_compile() {
econf `use_enable nls` || die
-
emake || die
}
-src_install () {
+src_install() {
make \
prefix=${D}/usr \
datadir=${D}/usr/share \