summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-12-16 21:15:48 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-12-16 21:15:48 +0000
commit2a4fbea9dbaeeeec9d3e74a9b1862045db5e1258 (patch)
treee544e68d56b906720497baa5667bf9b700fb0c35 /app-editors
parentnew package - support for geographic objects to PostgreSQL (diff)
downloadgentoo-2-2a4fbea9dbaeeeec9d3e74a9b1862045db5e1258.tar.gz
gentoo-2-2a4fbea9dbaeeeec9d3e74a9b1862045db5e1258.tar.bz2
gentoo-2-2a4fbea9dbaeeeec9d3e74a9b1862045db5e1258.zip
Removed sandbox violation. Fixes #10049
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/ChangeLog5
-rw-r--r--app-editors/vim/vim-6.1-r17.ebuild9
2 files changed, 10 insertions, 4 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index 79dea44f729f..212c88613921 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,12 +1,15 @@
# ChangeLog for app-editors/vim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.33 2002/12/16 21:13:21 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.34 2002/12/16 21:15:48 rphillips Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
*vim-6.1-r17.ebuild (06 Dec 2002)
16 Dec 2002; Ryan Phillips <rphillips@gentoo.org> vim-6.1-r17.ebuild :
+ Added sandbox violation fix. Fixes #10049. Submitted by Leonardo Boshell.
+
+ 16 Dec 2002; Ryan Phillips <rphillips@gentoo.org> vim-6.1-r17.ebuild :
Took out --without-x. See bug #11221
16 Dec 2002; Ryan Phillips <rphillips@gentoo.org> vim-6.1-r17.ebuild :
diff --git a/app-editors/vim/vim-6.1-r17.ebuild b/app-editors/vim/vim-6.1-r17.ebuild
index 0ca76679a1cd..1a6c773a4fea 100644
--- a/app-editors/vim/vim-6.1-r17.ebuild
+++ b/app-editors/vim/vim-6.1-r17.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r17.ebuild,v 1.10 2002/12/16 21:13:21 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r17.ebuild,v 1.11 2002/12/16 21:15:48 rphillips Exp $
VIMPATCH="vimpatch-1-263.tar.bz2"
inherit vim
@@ -41,8 +41,11 @@ src_compile() {
use X && myconf="$myconf --without-x"
# This should fix a sandbox violation.
- addwrite "${SSH_TTY}"
-
+ for file in /dev/pty/s*
+ do
+ addwrite $file
+ done
+
#
# Build a nogui version, this will install as /usr/bin/vim
#