summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-27 16:31:57 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-27 16:31:57 +0000
commit26a25a3352135db9a3662e61a69b413f6700556d (patch)
tree8f65d52f3d6ea0d8e28fdef4d7def339dd619559 /app-editors
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-26a25a3352135db9a3662e61a69b413f6700556d.tar.gz
gentoo-2-26a25a3352135db9a3662e61a69b413f6700556d.tar.bz2
gentoo-2-26a25a3352135db9a3662e61a69b413f6700556d.zip
Version bump to 1.8.0. Continuation of app-editors/mate-text-editor.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/pluma/ChangeLog9
-rw-r--r--app-editors/pluma/metadata.xml8
-rw-r--r--app-editors/pluma/pluma-1.8.0.ebuild82
3 files changed, 99 insertions, 0 deletions
diff --git a/app-editors/pluma/ChangeLog b/app-editors/pluma/ChangeLog
new file mode 100644
index 000000000000..2652b0d6a2a9
--- /dev/null
+++ b/app-editors/pluma/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-editors/pluma
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/pluma/ChangeLog,v 1.1 2014/04/27 16:31:57 tomwij Exp $
+
+*pluma-1.8.0 (27 Apr 2014)
+
+ 27 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +metadata.xml,
+ +pluma-1.8.0.ebuild:
+ Version bump to 1.8.0. Continuation of app-editors/mate-text-editor.
diff --git a/app-editors/pluma/metadata.xml b/app-editors/pluma/metadata.xml
new file mode 100644
index 000000000000..dca1781cb290
--- /dev/null
+++ b/app-editors/pluma/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>TomWij@gentoo.org</email>
+ <name>Tom Wijsman</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-editors/pluma/pluma-1.8.0.ebuild b/app-editors/pluma/pluma-1.8.0.ebuild
new file mode 100644
index 000000000000..6d9dc59c1e78
--- /dev/null
+++ b/app-editors/pluma/pluma-1.8.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/pluma/pluma-1.8.0.ebuild,v 1.1 2014/04/27 16:31:57 tomwij Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit gnome2 multilib python-single-r1 versionator virtualx
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Pluma text editor for the MATE desktop"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="python spell"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
+# https://github.com/mate-desktop/mate-text-editor/issues/33
+RESTRICT="test"
+
+RDEPEND="app-text/rarian:0
+ dev-libs/atk:0
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2.5:2
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.19:2
+ >=x11-libs/gtksourceview-2.9.7:2.0
+ x11-libs/libICE:0
+ x11-libs/libX11:0
+ >=x11-libs/libSM-1.0
+ x11-libs/pango:0
+ virtual/libintl:0
+ spell? (
+ >=app-text/enchant-1.2:0
+ >=app-text/iso-codes-0.35:0
+ )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.15.4:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.12:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtksourceview-2.9.2:2
+ )
+ !!app-editors/mate-text-editor"
+
+DEPEND="${RDEPEND}
+ ~app-text/docbook-xml-dtd-4.1.2
+ >=app-text/scrollkeeper-dtd-1:1.0
+ >=dev-util/intltool-0.40:*
+ >=sys-devel/libtool-2.2.6:2
+ >=mate-base/mate-common-1.6:0
+ >=sys-devel/gettext-0.17:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-updater \
+ $(use_enable python) \
+ $(use_enable spell)
+}
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_test() {
+ # FIXME: This should be handled at eclass level.
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}