summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-03-19 06:09:48 +0000
committerMike Frysinger <vapier@gentoo.org>2008-03-19 06:09:48 +0000
commit1bce08929516a44169f61381d129f0e0b4d4c521 (patch)
tree039731ebda64b44ddd1adbf04aeed1aecc688602 /app-editors
parentReally revert to ~ppc. (diff)
downloadgentoo-2-1bce08929516a44169f61381d129f0e0b4d4c521.tar.gz
gentoo-2-1bce08929516a44169f61381d129f0e0b4d4c521.tar.bz2
gentoo-2-1bce08929516a44169f61381d129f0e0b4d4c521.zip
old
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/nano-2.0.6.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/app-editors/nano/nano-2.0.6.ebuild b/app-editors/nano/nano-2.0.6.ebuild
deleted file mode 100644
index 22c3a13e7411..000000000000
--- a/app-editors/nano/nano-2.0.6.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.0.6.ebuild,v 1.11 2007/10/10 06:07:36 opfer Exp $
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
- ECVS_MODULE="nano"
- ECVS_AUTH="pserver"
- ECVS_USER="anonymous"
- inherit cvs
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- if [[ ! -e configure ]] ; then
- ./autogen.sh || die "autogen failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- use ncurses \
- && myconf="--without-slang" \
- || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- --enable-color \
- --enable-multibuffer \
- --enable-nanorc \
- --disable-wrapping-as-root \
- $(use_enable spell) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- ${myconf} \
- || die "configure failed"
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml *.html
- insinto /etc
- newins doc/nanorc.sample nanorc
-
- insinto /usr/share/nano
- doins "${FILESDIR}"/*.nanorc || die
- echo $'\n''# include "/usr/share/nano/gentoo.nanorc"' >> "${D}"/etc/nanorc
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-}
-
-pkg_postinst() {
- elog "More helpful info about nano, visit the GDP page:"
- elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}