summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-04 10:59:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-04 10:59:35 +0000
commit1154ab4634420b3c2b367d6b8606facfa50e9b44 (patch)
tree794227e3b2292d6eb86c610ac98004aeafc7a8fb /app-editors
parentVersion bump. Bug 413383 (diff)
downloadgentoo-2-1154ab4634420b3c2b367d6b8606facfa50e9b44.tar.gz
gentoo-2-1154ab4634420b3c2b367d6b8606facfa50e9b44.tar.bz2
gentoo-2-1154ab4634420b3c2b367d6b8606facfa50e9b44.zip
Fix compability with app-text/texi2html >= 5 by vadmeste (from Freenode)
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/qemacs/ChangeLog8
-rw-r--r--app-editors/qemacs/qemacs-0.4.0_pre20090420-r1.ebuild51
2 files changed, 35 insertions, 24 deletions
diff --git a/app-editors/qemacs/ChangeLog b/app-editors/qemacs/ChangeLog
index 2435bb23e8d2..a02f825f5277 100644
--- a/app-editors/qemacs/ChangeLog
+++ b/app-editors/qemacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/qemacs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.51 2011/08/14 08:50:59 ulm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.52 2012/05/04 10:59:35 ssuominen Exp $
+
+ 04 May 2012; Samuli Suominen <ssuominen@gentoo.org>
+ qemacs-0.4.0_pre20090420-r1.ebuild:
+ Fix compability with app-text/texi2html >= 5 by vadmeste (from Freenode)
*qemacs-0.4.0_pre20090420-r1 (14 Aug 2011)
diff --git a/app-editors/qemacs/qemacs-0.4.0_pre20090420-r1.ebuild b/app-editors/qemacs/qemacs-0.4.0_pre20090420-r1.ebuild
index 7614446850a8..b28159fe6bf3 100644
--- a/app-editors/qemacs/qemacs-0.4.0_pre20090420-r1.ebuild
+++ b/app-editors/qemacs/qemacs-0.4.0_pre20090420-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.4.0_pre20090420-r1.ebuild,v 1.1 2011/08/14 08:50:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.4.0_pre20090420-r1.ebuild,v 1.2 2012/05/04 10:59:35 ssuominen Exp $
EAPI=4
-
inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="QEmacs is a very small but powerful UNIX editor"
@@ -14,40 +13,47 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="X png unicode xv"
+
RESTRICT="test"
-RDEPEND="
- X? ( x11-libs/libX11
+RDEPEND="png? ( media-libs/libpng:0 )
+ X? (
+ x11-libs/libX11
x11-libs/libXext
- xv? ( x11-libs/libXv ) )
- png? ( >=media-libs/libpng-1.2 )"
-
+ xv? ( x11-libs/libXv )
+ )"
DEPEND="${RDEPEND}
- app-text/texi2html"
+ >=app-text/texi2html-5"
+
+S=${WORKDIR}/${PN}
-S="${WORKDIR}/${PN}"
+DOCS="Changelog config.eg README TODO"
src_prepare() {
# Removes forced march setting and align-functions on x86, as they
# would override user's CFLAGS..
- epatch "${FILESDIR}/${PN}-0.4.0_pre20080605-Makefile.patch"
+ epatch "${FILESDIR}"/${PN}-0.4.0_pre20080605-Makefile.patch
# Make backup files optional
- epatch "${FILESDIR}/${PN}-0.4.0_pre20080605-make_backup.patch"
+ epatch "${FILESDIR}"/${PN}-0.4.0_pre20080605-make_backup.patch
# Suppress stripping
- epatch "${FILESDIR}/${P}-nostrip.patch"
+ epatch "${FILESDIR}"/${P}-nostrip.patch
- use unicode && epatch "${FILESDIR}/${PN}-0.3.2_pre20070226-tty_utf8.patch"
+ use unicode && epatch "${FILESDIR}"/${PN}-0.3.2_pre20070226-tty_utf8.patch
# Change the manpage to reference a /real/ file instead of just an
# approximation. Purely cosmetic!
- sed -i "s,^/usr/share/doc/qe,&-${PVR}," qe.1 || die
+ sed -i -e "s,^/usr/share/doc/qe,&-${PVR}," qe.1 || die
+
+ # Fix compability with app-text/texi2html >= 5
+ sed -i -e '/texi2html/s:-number:&-sections:' Makefile || die
}
src_configure() {
# when using any other CFLAGS than -O0, qemacs will segfault on startup,
# see bug 92011
replace-flags -O? -O0
- econf --cc="$(tc-getCC)" \
+ econf \
+ --cc="$(tc-getCC)" \
$(use_enable X x11) \
$(use_enable png) \
$(use_enable xv)
@@ -59,18 +65,19 @@ src_compile() {
}
src_install() {
- emake install DESTDIR="${D}"
- dodoc Changelog README TODO config.eg
+ default
+
dohtml *.html
# Fix man page location
- mv "${D}"/usr/{,share/}man || die
+ mv -vf "${ED}"/usr/{,share/}man || die
# Install headers so users can build their own plugins.
insinto /usr/include/qe
- doins cfb.h config.h cutils.h display.h fbfrender.h libfbf.h qe.h \
- qeconfig.h qestyles.h qfribidi.h
- cd libqhtml
+ doins {cfb,config,cutils,display,fbfrender,libfbf,qe,qeconfig,qestyles,qfribidi}.h
+
+ pushd libqhtml >/dev/null
insinto /usr/include/qe/libqhtml
doins css.h cssid.h htmlent.h
+ popd >/dev/null
}