summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-04 17:11:48 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-04 17:11:48 +0000
commit08cb8b4b6c43ba073e32776d419986fe99b7668a (patch)
tree412fbb1569863f10aa26d5639cfe90abb209f7be /app-editors
parentAdd fix from upstream for slow tune2fs usage #253162 by candrews. (diff)
downloadgentoo-2-08cb8b4b6c43ba073e32776d419986fe99b7668a.tar.gz
gentoo-2-08cb8b4b6c43ba073e32776d419986fe99b7668a.tar.bz2
gentoo-2-08cb8b4b6c43ba073e32776d419986fe99b7668a.zip
old
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/files/nano-2.1.2-history-justify.patch31
-rw-r--r--app-editors/nano/files/nano-2.1.4-debug.patch13
-rw-r--r--app-editors/nano/files/nano-2.1.4-open-mode.patch26
-rw-r--r--app-editors/nano/files/nano-2.1.6-cut-last.patch121
-rw-r--r--app-editors/nano/files/nano-2.1.6-cut-paste-segv.patch70
-rw-r--r--app-editors/nano/files/nanorc-gentoo29
-rw-r--r--app-editors/nano/nano-2.0.7.ebuild79
-rw-r--r--app-editors/nano/nano-2.0.8.ebuild79
-rw-r--r--app-editors/nano/nano-2.1.2-r1.ebuild84
-rw-r--r--app-editors/nano/nano-2.1.4.ebuild85
-rw-r--r--app-editors/nano/nano-2.1.5.ebuild83
-rw-r--r--app-editors/nano/nano-2.1.6-r2.ebuild86
-rw-r--r--app-editors/nano/nano-2.1.7.ebuild84
13 files changed, 0 insertions, 870 deletions
diff --git a/app-editors/nano/files/nano-2.1.2-history-justify.patch b/app-editors/nano/files/nano-2.1.2-history-justify.patch
deleted file mode 100644
index 48d98b0f5ded..000000000000
--- a/app-editors/nano/files/nano-2.1.2-history-justify.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-http://savannah.gnu.org/bugs/?23733
-
-commit 247a6e5862156ac59a83fb53ad620d38e2f05346
-Author: astyanax <astyanax@35c25a1d-7b9e-4130-9fde-d3aeb78583b8>
-Date: Sun Jun 29 06:22:31 2008 +0000
-
- Fix for 23733: search history broken with nano-2.1.1+
-
-
-
- git-svn-id: svn://svn.savannah.gnu.org/nano/trunk/nano@4270 35c25a1d-7b9e-4130-9fde-d3aeb78583b8
-
-diff --git a/src/global.c b/src/global.c
-index 3e10886..4f2a291 100644
---- a/src/global.c
-+++ b/src/global.c
-@@ -1072,13 +1072,13 @@ void shortcut_init(bool unjustify)
- add_to_sclist(MALL, "khome", do_home, 0, TRUE);
- add_to_sclist(MALL, "^E", do_end, 0, TRUE);
- add_to_sclist(MALL, "kend", do_end, 0, TRUE);
--#ifndef DISABLE_JUSTIFY
- #ifndef NANO_TINY
- add_to_sclist(MWHEREIS|MREPLACE|MREPLACE2|MWHEREISFILE, "^P", (void *) prev_history_msg, 0, FALSE);
- add_to_sclist(MWHEREIS|MREPLACE|MREPLACE2|MWHEREISFILE, "kup", (void *) prev_history_msg, 0, FALSE);
- add_to_sclist(MWHEREIS|MREPLACE|MREPLACE2|MWHEREISFILE, "^N", (void *) next_history_msg, 0, FALSE);
- add_to_sclist(MWHEREIS|MREPLACE|MREPLACE2|MWHEREISFILE, "kdown", (void *) next_history_msg, 0, FALSE);
- #endif
-+#ifndef DISABLE_JUSTIFY
- add_to_sclist(MWHEREIS|MREPLACE|MREPLACE2,
- "^W", do_para_begin_void, 0, TRUE);
- add_to_sclist(MWHEREIS|MREPLACE|MREPLACE2,
diff --git a/app-editors/nano/files/nano-2.1.4-debug.patch b/app-editors/nano/files/nano-2.1.4-debug.patch
deleted file mode 100644
index bab5f6bb34f9..000000000000
--- a/app-editors/nano/files/nano-2.1.4-debug.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-http://bugs.gentoo.org/234959
-
---- nano-2.1.4/src/text.c
-+++ nano-2.1.4/src/text.c
-@@ -649,7 +649,7 @@
- filestruct *newnode = make_new_node(openfile->current);
- size_t extra = 0;
-
-- assert(openfile->current != NULL && xopenfile->current->data != NULL);
-+ assert(openfile->current != NULL && openfile->current->data != NULL);
-
- #ifndef NANO_TINY
- update_undo(SPLIT);
diff --git a/app-editors/nano/files/nano-2.1.4-open-mode.patch b/app-editors/nano/files/nano-2.1.4-open-mode.patch
deleted file mode 100644
index 60ce7dba94ee..000000000000
--- a/app-editors/nano/files/nano-2.1.4-open-mode.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-make sure we actually pass a valid mode to open() when creating files
-
-http://bugs.gentoo.org/232079
-
-patch by Magnus Granberg
-
---- nano-2.1.1/src/files.c
-+++ nano-2.1.1/src/files.c
-@@ -1572,7 +1572,7 @@
- }
-
- if (f_open == NULL) {
-- fd_source = open(realname, O_RDONLY | O_CREAT);
-+ fd_source = open(realname, O_RDONLY | O_CREAT, S_IRUSR | S_IWUSR);
-
- if (fd_source != -1) {
- f_source = fdopen(fd_source, "rb");
-@@ -1691,7 +1691,7 @@
- int fd_source;
- FILE *f_source = NULL;
-
-- fd_source = open(tempname, O_RDONLY | O_CREAT);
-+ fd_source = open(tempname, O_RDONLY | O_CREAT, S_IRUSR | S_IWUSR);
-
- if (fd_source != -1) {
- f_source = fdopen(fd_source, "rb");
diff --git a/app-editors/nano/files/nano-2.1.6-cut-last.patch b/app-editors/nano/files/nano-2.1.6-cut-last.patch
deleted file mode 100644
index bf9e90d776d0..000000000000
--- a/app-editors/nano/files/nano-2.1.6-cut-last.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-http://bugs.gentoo.org/240330
-
-From a203163ac137a7b184e7e7a03ab7254e502d0775 Mon Sep 17 00:00:00 2001
-From: astyanax <astyanax@35c25a1d-7b9e-4130-9fde-d3aeb78583b8>
-Date: Tue, 14 Oct 2008 01:14:12 +0000
-Subject: [PATCH] 2008-10-13 Chris Allegretta <chrisa@asty.org>
- * Remove CUTTOEND as an undo type as it's unneeded, fix u->to_end logic in undo struct.
- * undo.c (update_undo): Don't free cutbuffer if NULL, fix for Savannah bug #24499
-
-git-svn-id: svn://svn.savannah.gnu.org/nano/trunk/nano@4339 35c25a1d-7b9e-4130-9fde-d3aeb78583b8
----
- ChangeLog | 4 ++++
- src/cut.c | 2 +-
- src/nano.h | 2 +-
- src/text.c | 12 +++++-------
- 4 files changed, 11 insertions(+), 9 deletions(-)
-
-diff --git a/ChangeLog b/ChangeLog
-index 5f0f132..c14b724 100644
---- a/ChangeLog
-+++ b/ChangeLog
-@@ -1,3 +1,7 @@
-+2008-10-13 Chris Allegretta <chrisa@asty.org>
-+ * Remove CUTTOEND as an undo type as it's unneeded, fix u->to_end logic in undo struct.
-+ * undo.c (update_undo): Don't free cutbuffer if NULL, fix for Savannah bug #24499
-+
- 2008-10-04 Chris Allegretta <chrisa@asty.org>
- * cut.c (Add_undo): Save last cut undo information so it can be used for next uncut, fixes
- Savannah bug 24183.
-diff --git a/src/cut.c b/src/cut.c
-index 2689986..f92f9b3 100644
---- a/src/cut.c
-+++ b/src/cut.c
-@@ -245,7 +245,7 @@ void do_copy_text(void)
- void do_cut_till_end(void)
- {
- #ifndef NANO_TINY
-- add_undo(CUTTOEND);
-+ add_undo(CUT);
- #endif
- do_cut_text(FALSE, TRUE, FALSE);
- }
-diff --git a/src/nano.h b/src/nano.h
-index c82122d..3bc10f1 100644
---- a/src/nano.h
-+++ b/src/nano.h
-@@ -170,7 +170,7 @@ typedef enum {
- } function_type;
-
- typedef enum {
-- ADD, DEL, REPLACE, SPLIT, UNSPLIT, CUT, CUTTOEND, UNCUT, INSERT, OTHER
-+ ADD, DEL, REPLACE, SPLIT, UNSPLIT, CUT, UNCUT, INSERT, OTHER
- } undo_type;
-
- /* Structure types. */
-diff --git a/src/text.c b/src/text.c
-index 97e1f19..915d1c1 100644
---- a/src/text.c
-+++ b/src/text.c
-@@ -408,7 +408,7 @@ void redo_cut(undo *u) {
- #ifdef DEBUG
- fprintf(stderr, "Undoing multi-^K cut, u->linescut = %d\n", u->linescut);
- #endif
-- for (i = 0, t = openfile->current; i < u->linescut; i++) {
-+ for (i = 0, t = openfile->current; i < u->linescut && t->next != NULL ; i++) {
-
- #ifdef DEBUG
- fprintf(stderr, "Advancing, lineno = %d, data = \"%s\"\n", t->lineno, t->data);
-@@ -505,7 +505,6 @@ void do_undo(void)
- renumber(f);
- break;
- case CUT:
-- case CUTTOEND:
- undidmsg = _("text cut");
- undo_cut(u);
- break;
-@@ -629,7 +628,6 @@ void do_redo(void)
- renumber(f);
- break;
- case CUT:
-- case CUTTOEND:
- undidmsg = _("text cut");
- redo_cut(u);
- break;
-@@ -890,13 +888,12 @@ void add_undo(undo_type current_action)
- u->strdata = data;
- break;
- case CUT:
-- case CUTTOEND:
- u->mark_set = openfile->mark_set;
- if (u->mark_set) {
- u->mark_begin_lineno = openfile->mark_begin->lineno;
- u->mark_begin_x = openfile->mark_begin_x;
- }
-- u->to_end = (current_action == CUTTOEND);
-+ u->to_end = (ISSET(CUT_TO_END)) ? TRUE : FALSE;
- last_cutu = u;
- break;
- case UNCUT:
-@@ -951,7 +948,7 @@ void update_undo(undo_type action)
- /* Change to an add if we're not using the same undo struct
- that we should be using */
- if (action != fs->last_action
-- || (action != CUT && action != CUTTOEND && action != INSERT
-+ || (action != CUT && action != INSERT
- && openfile->current->lineno != fs->current_undo->lineno)) {
- add_undo(action);
- return;
-@@ -1016,7 +1013,8 @@ void update_undo(undo_type action)
- #endif
- break;
- case CUT:
-- case CUTTOEND:
-+ if (!cutbuffer)
-+ break;
- if (u->cutbuffer)
- free(u->cutbuffer);
- u->cutbuffer = copy_filestruct(cutbuffer);
---
-1.6.0.1
-
diff --git a/app-editors/nano/files/nano-2.1.6-cut-paste-segv.patch b/app-editors/nano/files/nano-2.1.6-cut-paste-segv.patch
deleted file mode 100644
index aab3643bb9a2..000000000000
--- a/app-editors/nano/files/nano-2.1.6-cut-paste-segv.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-https://savannah.gnu.org/bugs/?24447
-
-commit af3b86f16fc3e3f07a1d067528ecd84dd72a58d2
-Author: astyanax <astyanax@35c25a1d-7b9e-4130-9fde-d3aeb78583b8>
-Date: Sat Oct 4 11:10:11 2008 +0000
-
- 2008-10-04 Chris Allegretta <chrisa@asty.org>
- * cut.c (Add_undo): Save last cut undo information so it can be used for next uncut, fixes
- Savannah bug 24183.
-
-
-
- git-svn-id: svn://svn.savannah.gnu.org/nano/trunk/nano@4338 35c25a1d-7b9e-4130-9fde-d3aeb78583b8
-
-diff --git a/ChangeLog b/ChangeLog
-index 98e9253..5f0f132 100644
---- a/ChangeLog
-+++ b/ChangeLog
-@@ -1,3 +1,7 @@
-+2008-10-04 Chris Allegretta <chrisa@asty.org>
-+ * cut.c (Add_undo): Save last cut undo information so it can be used for next uncut, fixes
-+ Savannah bug 24183.
-+
- GNU nano 2.1.6 - 2008.10.03
- 2008-10-03 Pascal Gentil <pascal.gentil@univ-rennes1.fr>
- * fortran.nanorc: Sample python syntax highlighting file
-diff --git a/src/text.c b/src/text.c
-index 407b7ec..97e1f19 100644
---- a/src/text.c
-+++ b/src/text.c
-@@ -822,6 +822,7 @@ void add_undo(undo_type current_action)
- undo *u, *cutu;
- char *data;
- openfilestruct *fs = openfile;
-+ static undo *last_cutu = NULL; /* Last thing we cut to set up the undo for uncut */
-
- /* Ugh, if we were called while cutting not-to-end, non-marked and on the same lineno,
- we need to abort here */
-@@ -896,22 +897,22 @@ void add_undo(undo_type current_action)
- u->mark_begin_x = openfile->mark_begin_x;
- }
- u->to_end = (current_action == CUTTOEND);
-+ last_cutu = u;
- break;
- case UNCUT:
-- for (cutu = u; cutu != NULL && cutu->type != CUT; cutu = cutu->next)
-- ;
-- if (cutu->type == CUT) {
-- u->cutbuffer = cutu->cutbuffer;
-- u->cutbottom = cutu->cutbottom;
-- if (!cutu->mark_set)
-- u->linescut = cutu->linescut;
-+ if (!last_cutu)
-+ statusbar(_("Internal error: can't setup uncut. Please save your work."));
-+ else if (last_cutu->type == CUT) {
-+ u->cutbuffer = last_cutu->cutbuffer;
-+ u->cutbottom = last_cutu->cutbottom;
-+ if (!last_cutu->mark_set)
-+ u->linescut = last_cutu->linescut;
- else {
- filestruct *c;
- for (c = u->cutbuffer; c != NULL; c = c->next)
- u->linescut++;
- }
-- } else
-- statusbar(_("Internal error: can't setup uncut. Please save your work."));
-+ }
- break;
- case OTHER:
- statusbar(_("Internal error: unknown type. Please save your work."));
diff --git a/app-editors/nano/files/nanorc-gentoo b/app-editors/nano/files/nanorc-gentoo
deleted file mode 100644
index 86bd86444ecd..000000000000
--- a/app-editors/nano/files/nanorc-gentoo
+++ /dev/null
@@ -1,29 +0,0 @@
-
-## Here is an example for ebuilds/eclasses
-##
-# syntax "ebuild" "\.e(build|class)$"
-## All the standard portage functions
-# color brightgreen "^src_(unpack|compile|install|test)" "^pkg_(config|nofetch|setup|(pre|post)(inst|rm))"
-## Highlight bash related syntax
-# color green "\<(case|do|done|elif|else|esac|exit|fi|for|function|if|in|local|read|return|select|shift|then|time|until|while)\>"
-# color green "(\{|\}|\(|\)|\;|\]|\[|`|\\|\$|<|>|!|=|&|\|)"
-# color green "-(e|d|f|r|g|u|w|x|L)\>"
-# color green "-(eq|ne|gt|lt|ge|le|s|n|z)\>"
-## Highlight variables ... official portage ones in red, all others in bright red
-# color brightred "\$\{?[a-zA-Z_0-9]+\}?"
-# color red "\<(ARCH|HOMEPAGE|DESCRIPTION|IUSE|SRC_URI|LICENSE|SLOT|KEYWORDS|FILESDIR|WORKDIR|(P|R)?DEPEND|PROVIDE|DISTDIR|RESTRICT|USERLAND)\>"
-# color red "\<(S|D|T|PV|PF|P|PN|A)\>" "\<C(XX)?FLAGS\>" "\<LDFLAGS\>" "\<C(HOST|TARGET|BUILD)\>"
-## Highlight portage commands
-# color magenta "\<use(_(with|enable))?\> [!a-zA-Z0-9_+ -]*" "inherit.*"
-# color brightblue "e(begin|end|conf|install|make|warn|infon?|error|patch)"
-# color brightblue "\<die\>" "\<use(_(with|enable))?\>" "\<inherit\>" "\<has\>" "\<(has|best)_version\>" "\<unpack\>"
-# color brightblue "\<(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)\>"
-# color brightblue "\<do(python|sed|dir|hard|sym|html|jar|mo)\>" "\<keepdir\>"
-# color brightblue "prepall(|docs|info|man|strip)" "prep(info|lib|lib\.(so|a)|man|strip)"
-# color brightblue "\<(|doc|ins|exe)into\>" "\<f(owners|perms)\>" "\<(exe|ins|dir)opts\>"
-## Highlight common commands used in ebuilds
-# color blue "\<make\>" "\<(cat|cd|chmod|chown|cp|echo|env|export|grep|let|ln|mkdir|mv|rm|sed|set|tar|touch|unset)\>"
-## Highlight comments (doesnt work that well)
-# color yellow "#.*$"
-## Highlight strings (doesnt work that well)
-# color brightyellow ""(\\.|[^\"])*"" "'(\\.|[^'])*'"
diff --git a/app-editors/nano/nano-2.0.7.ebuild b/app-editors/nano/nano-2.0.7.ebuild
deleted file mode 100644
index b7806a85a397..000000000000
--- a/app-editors/nano/nano-2.0.7.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.0.7.ebuild,v 1.8 2008/05/10 10:28:58 vapier Exp $
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
- ECVS_MODULE="nano"
- ECVS_AUTH="pserver"
- ECVS_USER="anonymous"
- inherit cvs
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- if [[ ! -e configure ]] ; then
- ./autogen.sh || die "autogen failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- use ncurses \
- && myconf="--without-slang" \
- || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- --enable-color \
- --enable-multibuffer \
- --enable-nanorc \
- --disable-wrapping-as-root \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- ${myconf} \
- || die "configure failed"
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml *.html
- insinto /etc
- newins doc/nanorc.sample nanorc
-
- insinto /usr/share/nano
- doins "${FILESDIR}"/*.nanorc || die
- echo $'\n''# include "/usr/share/nano/gentoo.nanorc"' >> "${D}"/etc/nanorc
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-}
-
-pkg_postinst() {
- elog "More helpful info about nano, visit the GDP page:"
- elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}
diff --git a/app-editors/nano/nano-2.0.8.ebuild b/app-editors/nano/nano-2.0.8.ebuild
deleted file mode 100644
index c0c013bc3e08..000000000000
--- a/app-editors/nano/nano-2.0.8.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.0.8.ebuild,v 1.1 2008/08/25 18:56:11 vapier Exp $
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
- ECVS_MODULE="nano"
- ECVS_AUTH="pserver"
- ECVS_USER="anonymous"
- inherit cvs
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- if [[ ! -e configure ]] ; then
- ./autogen.sh || die "autogen failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- use ncurses \
- && myconf="--without-slang" \
- || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- --enable-color \
- --enable-multibuffer \
- --enable-nanorc \
- --disable-wrapping-as-root \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- ${myconf} \
- || die "configure failed"
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml *.html
- insinto /etc
- newins doc/nanorc.sample nanorc
-
- insinto /usr/share/nano
- doins "${FILESDIR}"/*.nanorc || die
- echo $'\n''# include "/usr/share/nano/gentoo.nanorc"' >> "${D}"/etc/nanorc
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-}
-
-pkg_postinst() {
- elog "More helpful info about nano, visit the GDP page:"
- elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}
diff --git a/app-editors/nano/nano-2.1.2-r1.ebuild b/app-editors/nano/nano-2.1.2-r1.ebuild
deleted file mode 100644
index 31bb436b54cf..000000000000
--- a/app-editors/nano/nano-2.1.2-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.2-r1.ebuild,v 1.8 2008/08/16 14:29:45 vapier Exp $
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
- ECVS_MODULE="nano"
- ECVS_AUTH="pserver"
- ECVS_USER="anonymous"
- inherit cvs
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-history-justify.patch
- if [[ ! -e configure ]] ; then
- ./autogen.sh || die "autogen failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- use ncurses \
- && myconf="--without-slang" \
- || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- $(use_enable !minimal color) \
- $(use_enable !minimal multibuffer) \
- $(use_enable !minimal nanorc) \
- --disable-wrapping-as-root \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- ${myconf} \
- || die "configure failed"
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml *.html
- insinto /etc
- newins doc/nanorc.sample nanorc
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-
- insinto /usr/share/nano
- local f
- for f in "${FILESDIR}"/*.nanorc ; do
- [[ -e ${D}/usr/share/nano/${f##*/} ]] && continue
- doins "${f}" || die
- echo "# include \"/usr/share/nano/${f##*/}\"" >> "${D}"/etc/nanorc
- done
-}
-
-pkg_postinst() {
- elog "More helpful info about nano, visit the GDP page:"
- elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}
diff --git a/app-editors/nano/nano-2.1.4.ebuild b/app-editors/nano/nano-2.1.4.ebuild
deleted file mode 100644
index b7cd00c61066..000000000000
--- a/app-editors/nano/nano-2.1.4.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.4.ebuild,v 1.2 2008/08/18 03:43:38 vapier Exp $
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
- ECVS_MODULE="nano"
- ECVS_AUTH="pserver"
- ECVS_USER="anonymous"
- inherit cvs
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-debug.patch #234959
- epatch "${FILESDIR}"/${P}-open-mode.patch #232079
- if [[ ! -e configure ]] ; then
- ./autogen.sh || die "autogen failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- use ncurses \
- && myconf="--without-slang" \
- || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- $(use_enable !minimal color) \
- $(use_enable !minimal multibuffer) \
- $(use_enable !minimal nanorc) \
- --disable-wrapping-as-root \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- ${myconf} \
- || die "configure failed"
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml *.html
- insinto /etc
- newins doc/nanorc.sample nanorc
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-
- insinto /usr/share/nano
- local f
- for f in "${FILESDIR}"/*.nanorc ; do
- [[ -e ${D}/usr/share/nano/${f##*/} ]] && continue
- doins "${f}" || die
- echo "# include \"/usr/share/nano/${f##*/}\"" >> "${D}"/etc/nanorc
- done
-}
-
-pkg_postinst() {
- elog "More helpful info about nano, visit the GDP page:"
- elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}
diff --git a/app-editors/nano/nano-2.1.5.ebuild b/app-editors/nano/nano-2.1.5.ebuild
deleted file mode 100644
index bb45a6e7c6ab..000000000000
--- a/app-editors/nano/nano-2.1.5.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.5.ebuild,v 1.8 2008/10/09 19:34:18 vapier Exp $
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
- ECVS_MODULE="nano"
- ECVS_AUTH="pserver"
- ECVS_USER="anonymous"
- inherit cvs
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- if [[ ! -e configure ]] ; then
- ./autogen.sh || die "autogen failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- use ncurses \
- && myconf="--without-slang" \
- || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- $(use_enable !minimal color) \
- $(use_enable !minimal multibuffer) \
- $(use_enable !minimal nanorc) \
- --disable-wrapping-as-root \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- ${myconf} \
- || die "configure failed"
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml *.html
- insinto /etc
- newins doc/nanorc.sample nanorc
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-
- insinto /usr/share/nano
- local f
- for f in "${FILESDIR}"/*.nanorc ; do
- [[ -e ${D}/usr/share/nano/${f##*/} ]] && continue
- doins "${f}" || die
- echo "# include \"/usr/share/nano/${f##*/}\"" >> "${D}"/etc/nanorc
- done
-}
-
-pkg_postinst() {
- elog "More helpful info about nano, visit the GDP page:"
- elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}
diff --git a/app-editors/nano/nano-2.1.6-r2.ebuild b/app-editors/nano/nano-2.1.6-r2.ebuild
deleted file mode 100644
index 615147a163d1..000000000000
--- a/app-editors/nano/nano-2.1.6-r2.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.6-r2.ebuild,v 1.1 2008/10/19 06:56:40 vapier Exp $
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- ESVN_REPO_URI="svn://svn.savannah.gnu.org/nano/trunk/nano"
- inherit subversion
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- subversion_src_unpack
- else
- unpack ${A}
- fi
- cd "${S}"
- epatch "${FILESDIR}"/${P}-cut-paste-segv.patch
- epatch "${FILESDIR}"/${P}-cut-last.patch #240330
- if [[ ! -e configure ]] ; then
- ./autogen.sh || die "autogen failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- use ncurses \
- && myconf="--without-slang" \
- || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- $(use_enable !minimal color) \
- $(use_enable !minimal multibuffer) \
- $(use_enable !minimal nanorc) \
- --disable-wrapping-as-root \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- ${myconf} \
- || die "configure failed"
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml *.html
- insinto /etc
- newins doc/nanorc.sample nanorc
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-
- insinto /usr/share/nano
- local f
- for f in "${FILESDIR}"/*.nanorc ; do
- [[ -e ${D}/usr/share/nano/${f##*/} ]] && continue
- doins "${f}" || die
- echo "# include \"/usr/share/nano/${f##*/}\"" >> "${D}"/etc/nanorc
- done
-}
-
-pkg_postinst() {
- elog "More helpful info about nano, visit the GDP page:"
- elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}
diff --git a/app-editors/nano/nano-2.1.7.ebuild b/app-editors/nano/nano-2.1.7.ebuild
deleted file mode 100644
index b8f5bcaf6ae3..000000000000
--- a/app-editors/nano/nano-2.1.7.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.7.ebuild,v 1.7 2008/12/28 20:17:17 gmsoft Exp $
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- ESVN_REPO_URI="svn://svn.savannah.gnu.org/nano/trunk/nano"
- inherit subversion
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- subversion_src_unpack
- else
- unpack ${A}
- fi
- cd "${S}"
- if [[ ! -e configure ]] ; then
- ./autogen.sh || die "autogen failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- use ncurses \
- && myconf="--without-slang" \
- || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- $(use_enable !minimal color) \
- $(use_enable !minimal multibuffer) \
- $(use_enable !minimal nanorc) \
- --disable-wrapping-as-root \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- ${myconf} \
- || die "configure failed"
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml *.html
- insinto /etc
- newins doc/nanorc.sample nanorc
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-
- insinto /usr/share/nano
- local f
- for f in "${FILESDIR}"/*.nanorc ; do
- [[ -e ${D}/usr/share/nano/${f##*/} ]] && continue
- doins "${f}" || die
- echo "# include \"/usr/share/nano/${f##*/}\"" >> "${D}"/etc/nanorc
- done
-}
-
-pkg_postinst() {
- elog "More helpful info about nano, visit the GDP page:"
- elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}