summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 15:35:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 15:35:32 +0000
commit00a8e3704170f970801ab642b9a32f63a419c210 (patch)
tree7a9d9c980c238961a3aa6adebd34ab00dec7c414 /app-editors
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-00a8e3704170f970801ab642b9a32f63a419c210.tar.gz
gentoo-2-00a8e3704170f970801ab642b9a32f63a419c210.tar.bz2
gentoo-2-00a8e3704170f970801ab642b9a32f63a419c210.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit-plugins/ChangeLog8
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.12.1.ebuild81
-rw-r--r--app-editors/gedit-plugins/metadata.xml6
3 files changed, 91 insertions, 4 deletions
diff --git a/app-editors/gedit-plugins/ChangeLog b/app-editors/gedit-plugins/ChangeLog
index b88f7de3bcad..49978464bd8f 100644
--- a/app-editors/gedit-plugins/ChangeLog
+++ b/app-editors/gedit-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/gedit-plugins
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.45 2014/04/12 10:29:58 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.46 2014/04/27 15:35:32 eva Exp $
+
+*gedit-plugins-3.12.1 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org>
+ +gedit-plugins-3.12.1.ebuild, metadata.xml:
+ Version bump for Gnome 3.12.
12 Apr 2014; Pacho Ramos <pacho@gentoo.org>
-files/gedit-plugins-3.8.3-terminal-background.patch,
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.12.1.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.12.1.ebuild
new file mode 100644
index 000000000000..ce71f03513d7
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-3.12.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-3.12.1.ebuild,v 1.1 2014/04/27 15:35:32 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python3_{2,3} )
+PYTHON_REQ_USE="xml"
+
+inherit eutils gnome2 multilib python-r1
+
+DESCRIPTION="Official plugins for gedit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE_plugins="charmap git terminal"
+IUSE="+python ${IUSE_plugins}"
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ terminal? ( python )
+ python? ( ${REQUIRED_PYTHON_USE} )
+"
+
+RDEPEND="
+ >=app-editors/gedit-3.11.3[python?]
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libpeas-1.7.0[gtk,python?]
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-3.9.2:3.0
+ python? (
+ ${PYTHON_DEPS}
+ >=app-editors/gedit-3[introspection,${PYTHON_USEDEP}]
+ dev-libs/libpeas[${PYTHON_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-3.9.2:3.0[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6 )
+ terminal? ( x11-libs/vte:2.90[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable python) \
+ ITSTOOL=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # FIXME: crazy !!!
+ find "${ED}"/usr/share/gedit -name "*.py*" -delete || die
+ find "${ED}"/usr/share/gedit -type d -empty -delete || die
+
+ # FIXME: upstream made this automagic...
+ clean_plugin charmap
+ clean_plugin git
+ clean_plugin terminal
+}
+
+clean_plugin() {
+ if use !${1} ; then
+ rm -rf "${ED}"/usr/share/gedit/plugins/${1}*
+ rm -rf "${ED}"/usr/$(get_libdir)/gedit/plugins/${1}*
+ fi
+}
diff --git a/app-editors/gedit-plugins/metadata.xml b/app-editors/gedit-plugins/metadata.xml
index 570a581fa9c5..61ee411a451d 100644
--- a/app-editors/gedit-plugins/metadata.xml
+++ b/app-editors/gedit-plugins/metadata.xml
@@ -4,9 +4,9 @@
<herd>gnome</herd>
<longdescription>Official plugins for gedit</longdescription>
<use>
- <flag name='charmap'>Insert special characters just by clicking on
- them</flag>
+ <flag name="charmap">Insert special characters just by clicking on
+ them</flag>
<flag name='git'>Shows document changes related to git's HEAD</flag>
- <flag name='terminal'>Embed a terminal in the bottom pane</flag>
+ <flag name="terminal">Embed a terminal in the bottom pane</flag>
</use>
</pkgmetadata>