summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-08-18 07:55:09 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-08-18 07:55:09 +0000
commitc9712da6930288ec645fcc0831f0073df12ae9ad (patch)
tree79a746db3c494c7ff0b1e71f149efbc963f4482b /app-editors/zile
parentclean up (diff)
downloadgentoo-2-c9712da6930288ec645fcc0831f0073df12ae9ad.tar.gz
gentoo-2-c9712da6930288ec645fcc0831f0073df12ae9ad.tar.bz2
gentoo-2-c9712da6930288ec645fcc0831f0073df12ae9ad.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-editors/zile')
-rw-r--r--app-editors/zile/ChangeLog7
-rw-r--r--app-editors/zile/zile-2.3.19.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-editors/zile/ChangeLog b/app-editors/zile/ChangeLog
index 7233ae04179b..6647879ed6fc 100644
--- a/app-editors/zile/ChangeLog
+++ b/app-editors/zile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/zile
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.123 2010/07/21 07:13:52 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.124 2010/08/18 07:55:09 fauli Exp $
+
+*zile-2.3.19 (18 Aug 2010)
+
+ 18 Aug 2010; Christian Faulhammer <fauli@gentoo.org> +zile-2.3.19.ebuild:
+ version bump
21 Jul 2010; Christian Faulhammer <fauli@gentoo.org> -zile-2.3.16.ebuild:
clean up
diff --git a/app-editors/zile/zile-2.3.19.ebuild b/app-editors/zile/zile-2.3.19.ebuild
new file mode 100644
index 000000000000..3d9203c719c6
--- /dev/null
+++ b/app-editors/zile/zile-2.3.19.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.3.19.ebuild,v 1.1 2010/08/18 07:55:09 fauli Exp $
+
+EAPI=3
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="http://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="livecd test valgrind"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ test? ( valgrind? ( dev-util/valgrind ) )"
+
+src_configure() {
+ econf $(use test && use_with valgrind || echo "--without-valgrind")
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # FAQ is installed by the build system in /usr/share/zile
+ dodoc AUTHORS BUGS NEWS README THANKS || die
+
+ # Zile should never install charset.alias (even on non-glibc arches)
+ rm -f "${ED}"/usr/lib/charset.alias
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [ -e "${EROOT}"/usr/bin/emacs ] || ln -s zile "${EROOT}"/usr/bin/emacs
+ fi
+}