summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-05-15 17:17:16 +0000
committerUlrich Müller <ulm@gentoo.org>2010-05-15 17:17:16 +0000
commit884fa1bf910571f46746fca233c21146c8eecdee (patch)
tree95777490229b609909802c7df12a0522e47d7b8e /app-editors/zile
parentUpdate qimageblitz category, deps cleanup (diff)
downloadgentoo-2-884fa1bf910571f46746fca233c21146c8eecdee.tar.gz
gentoo-2-884fa1bf910571f46746fca233c21146c8eecdee.tar.bz2
gentoo-2-884fa1bf910571f46746fca233c21146c8eecdee.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/zile')
-rw-r--r--app-editors/zile/ChangeLog7
-rw-r--r--app-editors/zile/zile-2.3.16.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-editors/zile/ChangeLog b/app-editors/zile/ChangeLog
index 46d6385344f6..1c8f3608e1b0 100644
--- a/app-editors/zile/ChangeLog
+++ b/app-editors/zile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/zile
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.118 2010/05/09 17:20:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.119 2010/05/15 17:17:16 ulm Exp $
+
+*zile-2.3.16 (15 May 2010)
+
+ 15 May 2010; Ulrich Mueller <ulm@gentoo.org> +zile-2.3.16.ebuild:
+ Version bump.
09 May 2010; Raúl Porcel <armin76@gentoo.org> zile-2.3.15.ebuild:
alpha stable wrt #313867
diff --git a/app-editors/zile/zile-2.3.16.ebuild b/app-editors/zile/zile-2.3.16.ebuild
new file mode 100644
index 000000000000..4907da4cf90f
--- /dev/null
+++ b/app-editors/zile/zile-2.3.16.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.3.16.ebuild,v 1.1 2010/05/15 17:17:16 ulm Exp $
+
+EAPI=3
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="http://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="livecd test valgrind"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ test? ( valgrind? ( dev-util/valgrind ) )"
+
+src_configure() {
+ econf $(use test && use_with valgrind || echo "--without-valgrind")
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # FAQ is installed by the build system in /usr/share/zile
+ dodoc AUTHORS BUGS NEWS README THANKS || die
+
+ # Zile should never install charset.alias (even on non-glibc arches)
+ rm -f "${ED}"/usr/lib/charset.alias
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [ -e "${EROOT}"/usr/bin/emacs ] || ln -s zile "${EROOT}"/usr/bin/emacs
+ fi
+}