summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-01-31 16:08:07 +0000
committerUlrich Müller <ulm@gentoo.org>2010-01-31 16:08:07 +0000
commit68a18011ba9e6fb6c94e242fce67b65788ac8b7a (patch)
tree0fed1e2f3acc9ed106c9f6ab9b535eb6b633b234 /app-editors/zile
parentia64/s390/sh/sparc stable wrt #297690 (diff)
downloadgentoo-2-68a18011ba9e6fb6c94e242fce67b65788ac8b7a.tar.gz
gentoo-2-68a18011ba9e6fb6c94e242fce67b65788ac8b7a.tar.bz2
gentoo-2-68a18011ba9e6fb6c94e242fce67b65788ac8b7a.zip
Add prefix keywords, change EAPI to 3. Remove old.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-editors/zile')
-rw-r--r--app-editors/zile/ChangeLog10
-rw-r--r--app-editors/zile/zile-2.3.14-r1.ebuild39
-rw-r--r--app-editors/zile/zile-2.3.9.ebuild22
3 files changed, 47 insertions, 24 deletions
diff --git a/app-editors/zile/ChangeLog b/app-editors/zile/ChangeLog
index c54da889cf8f..ce680fe5a8ff 100644
--- a/app-editors/zile/ChangeLog
+++ b/app-editors/zile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/zile
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.111 2009/12/27 16:42:23 ulm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.112 2010/01/31 16:08:07 ulm Exp $
+
+*zile-2.3.14-r1 (31 Jan 2010)
+
+ 31 Jan 2010; Ulrich Mueller <ulm@gentoo.org> -zile-2.3.9.ebuild,
+ +zile-2.3.14-r1.ebuild:
+ Add prefix keywords, change EAPI to 3. Remove old.
27 Dec 2009; Ulrich Mueller <ulm@gentoo.org> zile-2.3.13.ebuild,
zile-2.3.14.ebuild:
diff --git a/app-editors/zile/zile-2.3.14-r1.ebuild b/app-editors/zile/zile-2.3.14-r1.ebuild
new file mode 100644
index 000000000000..58d86f27288e
--- /dev/null
+++ b/app-editors/zile/zile-2.3.14-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.3.14-r1.ebuild,v 1.1 2010/01/31 16:08:07 ulm Exp $
+
+EAPI=3
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="http://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="livecd test valgrind"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ test? ( valgrind? ( dev-util/valgrind ) )"
+
+src_configure() {
+ econf $(use test && use_with valgrind || echo "--without-valgrind")
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # FAQ is installed by the build system in /usr/share/zile
+ dodoc AUTHORS BUGS NEWS README THANKS || die
+
+ # Zile should never install charset.alias (even on non-glibc arches)
+ rm -f "${ED}"/usr/lib/charset.alias
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [ -e "${EROOT}"/usr/bin/emacs ] || ln -s zile "${EROOT}"/usr/bin/emacs
+ fi
+}
diff --git a/app-editors/zile/zile-2.3.9.ebuild b/app-editors/zile/zile-2.3.9.ebuild
deleted file mode 100644
index 70a3387aef32..000000000000
--- a/app-editors/zile/zile-2.3.9.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.3.9.ebuild,v 1.5 2009/08/29 10:29:16 klausman Exp $
-
-DESCRIPTION="Zile is a small Emacs clone"
-HOMEPAGE="http://www.gnu.org/software/zile/"
-SRC_URI="mirror://gnu/zile/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND="sys-libs/ncurses"
-DEPEND="${RDEPEND}
- sys-apps/help2man"
-
-src_install() {
- emake DESTDIR="${D}" install || die
- # FAQ is installed by the build system in /usr/share/zile
- dodoc AUTHORS BUGS NEWS README THANKS || die
-}