summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-01-26 05:49:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-01-26 05:49:05 +0000
commited125094357d2c3315b2670a1f2c93f7db845d17 (patch)
tree3505676c11ad95552ddfcb6ac350426533a91a57 /app-editors/xemacs
parentAdded modular X deps (bug #115679) (diff)
downloadgentoo-2-ed125094357d2c3315b2670a1f2c93f7db845d17.tar.gz
gentoo-2-ed125094357d2c3315b2670a1f2c93f7db845d17.tar.bz2
gentoo-2-ed125094357d2c3315b2670a1f2c93f7db845d17.zip
Fix modular-X deps properly. "use? || (...)" is not valid, it should be "use? ( || (...) )".
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-editors/xemacs')
-rw-r--r--app-editors/xemacs/ChangeLog6
-rw-r--r--app-editors/xemacs/Manifest12
-rw-r--r--app-editors/xemacs/xemacs-21.4.17.ebuild6
3 files changed, 9 insertions, 15 deletions
diff --git a/app-editors/xemacs/ChangeLog b/app-editors/xemacs/ChangeLog
index 8e83378029c5..5831f4411586 100644
--- a/app-editors/xemacs/ChangeLog
+++ b/app-editors/xemacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/xemacs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.59 2006/01/26 02:13:34 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.60 2006/01/26 05:45:01 robbat2 Exp $
+
+ 26 Jan 2006; Robin H. Johnson <robbat2@gentoo.org> xemacs-21.4.17.ebuild:
+ Fix modular-X deps properly. "use? || (...)" is not valid, it should be
+ "use? ( || (...) )".
*xemacs-21.4.17 (26 Jan 2006)
diff --git a/app-editors/xemacs/Manifest b/app-editors/xemacs/Manifest
index 842313340ebb..ea4a5f01a7e1 100644
--- a/app-editors/xemacs/Manifest
+++ b/app-editors/xemacs/Manifest
@@ -1,6 +1,3 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 fdbbea1a8ef759720782044b671082b3 ChangeLog 10420
MD5 df382940daa67bb8888fbae22d617cb4 files/README.Gentoo 1426
MD5 6d3780dc77d3dd7c017d8864d2f0b07d files/digest-xemacs-21.4.12 130
@@ -26,12 +23,5 @@ MD5 c49d5e1449c0ae8eade0e5ec6e3224a1 xemacs-21.4.15-r1.ebuild 5046
MD5 1e7f35e3642c3b31d3e72ec64731e488 xemacs-21.4.15-r2.ebuild 5111
MD5 c8b16d9ce480a33720c9b4ad7b510b63 xemacs-21.4.15-r3.ebuild 5210
MD5 a4f298f675fc5c0ed0ceaa6bfecce583 xemacs-21.4.15.ebuild 3835
-MD5 0e55cb5badddd5fc35215c82ff6b856d xemacs-21.4.17.ebuild 5036
+MD5 f0d97ab3a63a8119f5cadfa3703d281c xemacs-21.4.17.ebuild 5044
MD5 7dc7dbe3b86bdf29083a4a85a4f232d5 xemacs-21.4.9.ebuild 4179
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFD2DBcyiNZaEAZA+ARAu77AJ0V8OgGGepGJOUUJQ2CSQwuZPIpIgCeL/LC
-rp5fb6MVn+pboaYFNDqpzZw=
-=4dok
------END PGP SIGNATURE-----
diff --git a/app-editors/xemacs/xemacs-21.4.17.ebuild b/app-editors/xemacs/xemacs-21.4.17.ebuild
index afa52829808b..dad7fcb62092 100644
--- a/app-editors/xemacs/xemacs-21.4.17.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.17.ebuild,v 1.1 2006/01/26 02:13:34 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.17.ebuild,v 1.2 2006/01/26 05:45:01 robbat2 Exp $
inherit eutils
@@ -28,7 +28,7 @@ DEPEND="virtual/libc
nas? ( media-libs/nas )
dnd? ( x11-libs/dnd )
motif? ( >=x11-libs/openmotif-2.1.30 )
- athena? || ( ( $X_DEPEND x11-libs/libXaw ) virtual/x11 )
+ athena? ( || ( ( $X_DEPEND x11-libs/libXaw ) virtual/x11 ) )
Xaw3d? ( x11-libs/Xaw3d )
neXt? ( x11-libs/neXtaw )
xface? ( media-libs/compface )
@@ -38,7 +38,7 @@ DEPEND="virtual/libc
canna? ( app-i18n/canna )
!amd64? ( freewnn? ( app-i18n/freewnn ) )
>=sys-libs/ncurses-5.2
- X? || ( ( $X_DEPEND ) virtual/x11 )"
+ X? ( || ( ( $X_DEPEND ) virtual/x11 ) )"
PDEPEND="app-xemacs/xemacs-base
mule? ( app-xemacs/mule-base )"