summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2012-06-05 13:25:47 +0000
committerJim Ramsay <lack@gentoo.org>2012-06-05 13:25:47 +0000
commit77d8c93df4a41a79b79b20c45459d53afd11837e (patch)
tree20c850fe47a7aba5f51d660a1f72761624777d6d /app-editors/vim
parentVersion bump: 7.3.537 is released (diff)
downloadgentoo-2-77d8c93df4a41a79b79b20c45459d53afd11837e.tar.gz
gentoo-2-77d8c93df4a41a79b79b20c45459d53afd11837e.tar.bz2
gentoo-2-77d8c93df4a41a79b79b20c45459d53afd11837e.zip
Version bump: 7.3.537 is released
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/ChangeLog7
-rw-r--r--app-editors/vim/vim-7.3.537.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index 8c3c367229f1..c9034d529a8a 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.413 2012/05/02 18:38:07 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.414 2012/06/05 13:25:47 lack Exp $
+
+*vim-7.3.537 (01 Jun 2012)
+
+ 01 Jun 2012; Jim Ramsay <jim_ramsay@gentoo.org> +vim-7.3.537.ebuild:
+ Version bump: 7.3.537 is released
*vim-7.3.515 (02 May 2012)
diff --git a/app-editors/vim/vim-7.3.537.ebuild b/app-editors/vim/vim-7.3.537.ebuild
new file mode 100644
index 000000000000..5a53663b8d71
--- /dev/null
+++ b/app-editors/vim/vim-7.3.537.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.3.537.ebuild,v 1.1 2012/06/05 13:25:47 lack Exp $
+
+EAPI=3
+VIM_VERSION="7.3"
+inherit vim
+
+VIM_ORG_PATCHES="vim-patches-${PV}.patch.bz2"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ http://dev.gentoo.org/~lack/vim/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ vim_src_prepare
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ epatch "${FILESDIR}"/${PN}-7.3-interix-link.patch
+ fi
+ epatch "${FILESDIR}"/${PN}-7.1.285-darwin-x11link.patch
+}