summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-12-27 22:06:19 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-12-27 22:06:19 +0000
commit3e1eaf57a16d4be0ce825b856ac50e291fc988b3 (patch)
treeec39fef156aff51ba5415ca65726374d6d03bac4 /app-editors/vim
parent[QA] Remove unused files. (diff)
downloadgentoo-2-3e1eaf57a16d4be0ce825b856ac50e291fc988b3.tar.gz
gentoo-2-3e1eaf57a16d4be0ce825b856ac50e291fc988b3.tar.bz2
gentoo-2-3e1eaf57a16d4be0ce825b856ac50e291fc988b3.zip
[QA] Remove unused files. The vimrc file has been moved to app-editors/vim-core a while ago.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/ChangeLog6
-rw-r--r--app-editors/vim/files/vimrc93
2 files changed, 5 insertions, 94 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index 80d9300370ee..380ee599382f 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/vim
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.449 2013/12/16 09:57:57 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.450 2013/12/27 22:06:19 tomwij Exp $
+
+ 27 Dec 2013; Tom Wijsman <TomWij@gentoo.org> -files/vimrc:
+ [QA] Remove unused files. The vimrc file has been moved to app-editors/vim-
+ core a while ago.
*vim-7.4.131 (16 Dec 2013)
diff --git a/app-editors/vim/files/vimrc b/app-editors/vim/files/vimrc
deleted file mode 100644
index 2038d96d9c01..000000000000
--- a/app-editors/vim/files/vimrc
+++ /dev/null
@@ -1,93 +0,0 @@
-" Default configuration file for Vim
-" Written by Aron Griffis <agriffis@gentoo.org>
-" Modified by Ryan Phillips <rphillips@gentoo.org>
-" Added Redhat's vimrc info by Seemant Kulleen <seemant@gentoo.org>
-
-" The following are some sensible defaults for Vim for most users.
-" We attempt to change as little as possible from Vim's defaults,
-" deviating only where it makes sense
-set nocompatible " Use Vim defaults (much better!)
-set bs=2 " Allow backspacing over everything in insert mode
-set ai " Always set auto-indenting on
-"set backup " Keep a backup file
-set viminfo='20,\"50 " read/write a .viminfo file -- limit to only 50
-set history=50 " keep 50 lines of command history
-set ruler " Show the cursor position all the time
-
-
-" Added to default to high security within Gentoo. Fixes bug #14088
-set modelines=0
-
-if v:lang =~ "^ko"
- set fileencodings=euc-kr
- set guifontset=-*-*-medium-r-normal--16-*-*-*-*-*-*-*
-elseif v:lang =~ "^ja_JP"
- set fileencodings=euc-jp
- set guifontset=-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*
-elseif v:lang =~ "^zh_TW"
- set fileencodings=big5
- set guifontset=-sony-fixed-medium-r-normal--16-150-75-75-c-80-iso8859-1,-taipei-fixed-medium-r-normal--16-150-75-75-c-160-big5-0
-elseif v:lang =~ "^zh_CN"
- set fileencodings=gb2312
- set guifontset=*-r-*
-endif
-if v:lang =~ "utf8$" || v:lang =~ "UTF-8$"
- set fileencodings=utf-8,latin1
-endif
-
-" Only do this part when compiled with support for autocommands
-if has("autocmd")
- " In text files, always limit the width of text to 78 characters
- autocmd BufRead *.txt set tw=78
- " When editing a file, always jump to the last cursor position
- autocmd BufReadPost *
- \ if line("'\"") > 0 && line ("'\"") <= line("$") |
- \ exe "normal g'\"" |
- \ endif
-endif
-
-" Don't use Ex mode, use Q for formatting
-map Q gq
-
-" Switch syntax highlighting on, when the terminal has colors
-" Also switch on highlighting the last used search pattern.
-if &t_Co > 2 || has("gui_running")
- syntax on
- set hlsearch
-endif
-
-if &term=="xterm"
- set t_RV= " don't check terminal version
- set t_Co=8
- set t_Sb=^[4%dm
- set t_Sf=^[3%dm
-endif
-
-if has("autocmd")
-
-" Gentoo-specific settings for ebuilds. These are the federally-mandated
-" required tab settings. See the following for more information:
-" http://www.gentoo.org/doc/en/xml/gentoo-howto.xml
-augroup gentoo
- au!
- au BufRead,BufNewFile *.ebuild set tabstop=4 shiftwidth=4 noexpandtab
-augroup END
-
-endif " has("autocmd")
-
-" some extra commands for HTML editing
-nmap ,mh wbgueyei<<ESC>ea></<ESC>pa><ESC>bba
-nmap ,h1 _i<h1><ESC>A</h1><ESC>
-nmap ,h2 _i<h2><ESC>A</h2><ESC>
-nmap ,h3 _i<h3><ESC>A</h3><ESC>
-nmap ,h4 _i<h4><ESC>A</h4><ESC>
-nmap ,h5 _i<h5><ESC>A</h5><ESC>
-nmap ,h6 _i<h6><ESC>A</h6><ESC>
-nmap ,hb wbi<b><ESC>ea</b><ESC>bb
-nmap ,he wbi<em><ESC>ea</em><ESC>bb
-nmap ,hi wbi<i><ESC>ea</i><ESC>bb
-nmap ,hu wbi<u><ESC>ea</i><ESC>bb
-nmap ,hs wbi<strong><ESC>ea</strong><ESC>bb
-nmap ,ht wbi<tt><ESC>ea</tt><ESC>bb
-nmap ,hx wbF<df>f<df>
-