summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-01-05 11:45:50 +0000
committerBen de Groot <yngwin@gentoo.org>2015-01-05 11:45:50 +0000
commitc1f9488df1c789a69469c9727729f7c53489a32f (patch)
treef9f94fa077b6d2985a26cf445c24dd9b4bde5076 /app-editors/vim-qt
parentMask Asterisk 13 branch. (diff)
downloadgentoo-2-c1f9488df1c789a69469c9727729f7c53489a32f.tar.gz
gentoo-2-c1f9488df1c789a69469c9727729f7c53489a32f.tar.bz2
gentoo-2-c1f9488df1c789a69469c9727729f7c53489a32f.zip
version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x0F9C590B7FF324F6!)
Diffstat (limited to 'app-editors/vim-qt')
-rw-r--r--app-editors/vim-qt/ChangeLog9
-rw-r--r--app-editors/vim-qt/vim-qt-20150102.ebuild119
2 files changed, 126 insertions, 2 deletions
diff --git a/app-editors/vim-qt/ChangeLog b/app-editors/vim-qt/ChangeLog
index 5fa74014020c..03db672d51c6 100644
--- a/app-editors/vim-qt/ChangeLog
+++ b/app-editors/vim-qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vim-qt
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/ChangeLog,v 1.10 2014/11/24 12:51:50 yngwin Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/ChangeLog,v 1.11 2015/01/05 11:45:50 yngwin Exp $
+
+*vim-qt-20150102 (05 Jan 2015)
+
+ 05 Jan 2015; Ben de Groot <yngwin@gentoo.org> +vim-qt-20150102.ebuild:
+ version bump
*vim-qt-20140827-r2 (24 Nov 2014)
diff --git a/app-editors/vim-qt/vim-qt-20150102.ebuild b/app-editors/vim-qt/vim-qt-20150102.ebuild
new file mode 100644
index 000000000000..aaddb390a62a
--- /dev/null
+++ b/app-editors/vim-qt/vim-qt-20150102.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/vim-qt-20150102.ebuild,v 1.1 2015/01/05 11:45:50 yngwin Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="threads"
+inherit eutils fdo-mime flag-o-matic prefix python-single-r1
+
+DESCRIPTION="Qt GUI version of the Vim text editor"
+HOMEPAGE="https://bitbucket.org/equalsraf/vim-qt/wiki/Home"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=(
+ "https://bitbucket.org/equalsraf/${PN}.git"
+ "https://github.com/equalsraf/${PN}.git"
+ "git://gitorious.org/${PN}/${PN}.git"
+ )
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/equalsraf/${PN}/archive/package-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-package-${PV}"
+fi
+
+LICENSE="vim"
+SLOT="0"
+IUSE="acl cscope debug lua luajit nls perl python racket ruby"
+
+REQUIRED_USE="luajit? ( lua )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=app-admin/eselect-vi-1.1.8
+ >=app-editors/vim-core-7.4.560[acl?]
+ sys-libs/ncurses
+ >=dev-qt/qtcore-4.7.0:4
+ >=dev-qt/qtgui-4.7.0:4
+ acl? ( kernel_linux? ( sys-apps/acl ) )
+ cscope? ( dev-util/cscope )
+ lua? ( luajit? ( dev-lang/luajit )
+ !luajit? ( dev-lang/lua[deprecated] ) )
+ nls? ( virtual/libintl )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ racket? ( dev-scheme/racket )
+ ruby? ( || ( dev-lang/ruby:2.0 dev-lang/ruby:1.9 ) )"
+DEPEND="${RDEPEND}
+ dev-util/ctags
+ sys-devel/autoconf
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ export LC_COLLATE="C" # prevent locale brokenness
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Read vimrc from /etc/vim/
+ echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' >> "${S}"/src/feature.h
+}
+
+src_configure() {
+ use debug && append-flags "-DDEBUG"
+
+ local myconf="--with-features=huge --disable-gpm --enable-multibyte"
+ myconf+=" $(use_enable acl)"
+ myconf+=" $(use_enable cscope)"
+ myconf+=" $(use_enable nls)"
+ myconf+=" $(use_enable lua luainterp)"
+ myconf+=" $(use_with luajit)"
+ myconf+=" $(use_enable perl perlinterp)"
+ myconf+=" $(use_enable racket mzschemeinterp)"
+ myconf+=" $(use_enable ruby rubyinterp)"
+
+ if ! use cscope ; then
+ sed -i -e '/# define FEAT_CSCOPE/d' src/feature.h || die 'sed failed'
+ fi
+
+ # keep prefix env contained within the EPREFIX
+ use prefix && myconf+=" --without-local-dir"
+
+ if use python ; then
+ if [[ ${EPYTHON} == python3* ]] ; then
+ myconf+=" --enable-python3interp"
+ export vi_cv_path_python3="${PYTHON}"
+ else
+ myconf+=" --enable-pythoninterp"
+ export vi_cv_path_python="${PYTHON}"
+ fi
+ else
+ myconf+=" --disable-pythoninterp --disable-python3interp"
+ fi
+
+ econf ${myconf} --enable-gui=qt --with-vim-name=qvim --with-modified-by=Gentoo-${PVR}
+}
+
+src_install() {
+ dobin src/qvim
+ dosym qvim /usr/bin/qvimdiff
+
+ dodir /usr/share/man/man1
+ echo ".so vim.1" > "${ED}"/usr/share/man/man1/qvim.1
+ echo ".so vimdiff.1" > "${ED}"/usr/share/man/man1/qvimdiff.1
+
+ # track https://bitbucket.org/equalsraf/vim-qt/issue/93/include-desktop-file-in-source
+ # for inclusion of desktop file
+ newmenu "${FILESDIR}"/vim-qt.desktop vim-qt.desktop
+ doicon -s 64 src/qt/icons/vim-qt.png
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}