summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-19 06:42:56 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-19 06:42:56 +0000
commitce09411d8f926755b3a3200d6f322f6016ab9455 (patch)
tree0312ee8ffbf2807dbbea14c1c62976c568577439 /app-editors/vile
parentVersion bump. (diff)
downloadgentoo-2-ce09411d8f926755b3a3200d6f322f6016ab9455.tar.gz
gentoo-2-ce09411d8f926755b3a3200d6f322f6016ab9455.tar.bz2
gentoo-2-ce09411d8f926755b3a3200d6f322f6016ab9455.zip
Version bump.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/vile')
-rw-r--r--app-editors/vile/ChangeLog7
-rw-r--r--app-editors/vile/vile-9.8g.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-editors/vile/ChangeLog b/app-editors/vile/ChangeLog
index 601eaa2c6216..58fcedfa18ca 100644
--- a/app-editors/vile/ChangeLog
+++ b/app-editors/vile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vile
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/ChangeLog,v 1.39 2012/02/10 18:01:31 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/ChangeLog,v 1.40 2012/03/19 06:42:56 radhermit Exp $
+
+*vile-9.8g (19 Mar 2012)
+
+ 19 Mar 2012; Tim Harder <radhermit@gentoo.org> +vile-9.8g.ebuild:
+ Version bump.
10 Feb 2012; Fabian Groffen <grobian@gentoo.org> vile-9.8f.ebuild:
Transferred Prefix keywords
diff --git a/app-editors/vile/vile-9.8g.ebuild b/app-editors/vile/vile-9.8g.ebuild
new file mode 100644
index 000000000000..c51c230a9eae
--- /dev/null
+++ b/app-editors/vile/vile-9.8g.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.8g.ebuild,v 1.1 2012/03/19 06:42:56 radhermit Exp $
+
+EAPI="4"
+
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://invisible-island.net/vile/"
+SRC_URI="ftp://invisible-island.net/vile/current/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="perl"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ app-admin/eselect-vi"
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ $(use_with perl )
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc CHANGES* README doc/*.doc
+ dohtml doc/*.html
+}
+
+pkg_postinst() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}