summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-11 03:37:30 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-11 03:37:30 +0000
commitb092c136060c7e8391b161d56b584adf9c9b8433 (patch)
treee6416ae9d2f0764ed19d164a9bdc3315f706cc66 /app-editors/vile
parentFHS2.1 check, dependencie updates (diff)
downloadgentoo-2-b092c136060c7e8391b161d56b584adf9c9b8433.tar.gz
gentoo-2-b092c136060c7e8391b161d56b584adf9c9b8433.tar.bz2
gentoo-2-b092c136060c7e8391b161d56b584adf9c9b8433.zip
HFS2.1 fixes, added ncurses to dependencies and configure
Diffstat (limited to 'app-editors/vile')
-rw-r--r--app-editors/vile/files/digest-vile-9.2-r11
-rw-r--r--app-editors/vile/vile-9.2-r1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-editors/vile/files/digest-vile-9.2-r1 b/app-editors/vile/files/digest-vile-9.2-r1
new file mode 100644
index 000000000000..1ca7de82bff5
--- /dev/null
+++ b/app-editors/vile/files/digest-vile-9.2-r1
@@ -0,0 +1 @@
+MD5 92b9c329db3f6a528b3b82296714bf4c vile-9.2.tgz
diff --git a/app-editors/vile/vile-9.2-r1.ebuild b/app-editors/vile/vile-9.2-r1.ebuild
new file mode 100644
index 000000000000..0104c721010e
--- /dev/null
+++ b/app-editors/vile/vile-9.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.2-r1.ebuild,v 1.1 2001/04/11 03:37:30 achim Exp $
+
+A=${P}.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+SRC_URI="ftp://dickey.his.com/vile/${A}"
+HOMEPAGE="http://www.clark.net/pub/dickey/vile/vile.html"
+
+DEPEND="virtual/glibc
+ sys-devel/flex
+ >=sys-libs/ncurses-5.2
+ >=sys-devel/perl-5.6.0"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
+ --with-perl --with-ncurses
+ try make
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc CHANGES* MANIFEST README
+
+}