summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-06-24 16:47:38 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-06-24 16:47:38 +0000
commitd59b92e928dacd541dd581bfaadb2edcfb9990e6 (patch)
treefb2183f7e016b4a4415e1326dedcc9a23c16842c /app-editors/tea
parentFix samples readme install wrt#474614. (diff)
downloadgentoo-2-d59b92e928dacd541dd581bfaadb2edcfb9990e6.tar.gz
gentoo-2-d59b92e928dacd541dd581bfaadb2edcfb9990e6.tar.bz2
gentoo-2-d59b92e928dacd541dd581bfaadb2edcfb9990e6.zip
Version bump. Update upstream metadata.
(Portage version: 2.1.12.9/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/ChangeLog8
-rw-r--r--app-editors/tea/metadata.xml4
-rw-r--r--app-editors/tea/tea-36.0.1.ebuild58
3 files changed, 65 insertions, 5 deletions
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index 5e8b20719bf0..77fbbf88ad52 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/tea
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.62 2013/03/02 19:22:18 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.63 2013/06/24 16:47:38 kensington Exp $
+
+*tea-36.0.1 (24 Jun 2013)
+
+ 24 Jun 2013; Michael Palimaka <kensington@gentoo.org> +tea-36.0.1.ebuild,
+ metadata.xml:
+ Version bump. Update upstream metadata.
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> tea-33.3.0.ebuild:
Move Qt dependencies to the new category
diff --git a/app-editors/tea/metadata.xml b/app-editors/tea/metadata.xml
index 5c1c06a1516d..79ad70798a5b 100644
--- a/app-editors/tea/metadata.xml
+++ b/app-editors/tea/metadata.xml
@@ -11,8 +11,4 @@
<flag name="aspell">Enable spellchecking using <pkg>app-text/aspell</pkg></flag>
<flag name="hunspell">Enable spellchecking using <pkg>app-text/hunspell</pkg></flag>
</use>
- <upstream>
- <remote-id type="sourceforge">tea-editor</remote-id>
- <bugs-to>http://sourceforge.net/p/tea-editor/bugs/</bugs-to>
- </upstream>
</pkgmetadata>
diff --git a/app-editors/tea/tea-36.0.1.ebuild b/app-editors/tea/tea-36.0.1.ebuild
new file mode 100644
index 000000000000..fe269f772a25
--- /dev/null
+++ b/app-editors/tea/tea-36.0.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-36.0.1.ebuild,v 1.1 2013/06/24 16:47:38 kensington Exp $
+
+EAPI=5
+PLOCALES="de fr ru"
+
+inherit eutils l10n qt4-r2
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="http://semiletov.org/tea/"
+SRC_URI="http://semiletov.org/${PN}/dloads/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="aspell hunspell"
+
+RDEPEND="
+ sys-libs/zlib
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+"
+DEPEND="${RDEPEND}
+ hunspell? ( virtual/pkgconfig )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS TODO )
+
+src_configure() {
+ eqmake4 src.pro \
+ PREFIX="${EPREFIX}/usr/bin" \
+ USE_ASPELL=$(use aspell && echo true || echo false) \
+ USE_HUNSPELL=$(use hunspell && echo true || echo false)
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ newicon icons/tea_icon_v2.png ${PN}.png
+ make_desktop_entry ${PN} 'Tea Editor'
+
+ # translations
+ insinto /usr/share/qt4/translations
+ local lang
+ for lang in $(l10n_get_locales); do
+ doins translations/${PN}_${lang}.qm
+ done
+
+ # docs
+ dohtml manuals/en.html
+ if use linguas_ru; then
+ dodoc NEWS-RU
+ dohtml manuals/ru.html
+ fi
+}