summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-05-02 23:01:48 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-05-02 23:01:48 +0000
commit90e571bfeef5f44345d1bceb4723de249571ffbb (patch)
treef381e68e2c10859c0eaa9b6617722b37e0e4c052 /app-editors/tea
parentRemove old. (diff)
downloadgentoo-2-90e571bfeef5f44345d1bceb4723de249571ffbb.tar.gz
gentoo-2-90e571bfeef5f44345d1bceb4723de249571ffbb.tar.bz2
gentoo-2-90e571bfeef5f44345d1bceb4723de249571ffbb.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/ChangeLog8
-rw-r--r--app-editors/tea/tea-33.0.0.ebuild (renamed from app-editors/tea/tea-32.0.1.ebuild)30
2 files changed, 18 insertions, 20 deletions
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index b736db34b3e8..456f6f5283e9 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/tea
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.54 2012/04/24 11:35:52 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.55 2012/05/02 23:01:48 pesa Exp $
+
+*tea-33.0.0 (02 May 2012)
+
+ 02 May 2012; Davide Pesavento <pesa@gentoo.org> +tea-33.0.0.ebuild,
+ -tea-32.0.1.ebuild:
+ Version bump.
*tea-32.0.2 (24 Apr 2012)
diff --git a/app-editors/tea/tea-32.0.1.ebuild b/app-editors/tea/tea-33.0.0.ebuild
index b6a165c6485a..16e17713f221 100644
--- a/app-editors/tea/tea-32.0.1.ebuild
+++ b/app-editors/tea/tea-33.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-32.0.1.ebuild,v 1.1 2012/03/16 15:17:52 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-33.0.0.ebuild,v 1.1 2012/05/02 23:01:48 pesa Exp $
EAPI=4
LANGS="de fr ru"
@@ -16,32 +16,24 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
IUSE="aspell hunspell"
-RDEPEND="sys-libs/zlib
+RDEPEND="
+ sys-libs/zlib
x11-libs/qt-core:4
x11-libs/qt-gui:4
aspell? ( app-text/aspell )
- hunspell? ( app-text/hunspell )"
+ hunspell? ( app-text/hunspell )
+"
DEPEND="${RDEPEND}
- hunspell? ( dev-util/pkgconfig )"
+ hunspell? ( virtual/pkgconfig )
+"
DOCS="AUTHORS ChangeLog NEWS TODO"
src_configure() {
- local myopts
-
- if use aspell; then
- myopts="USE_ASPELL=true"
- else
- myopts="USE_ASPELL=false"
- fi
-
- if use hunspell; then
- myopts="${myopts} USE_HUNSPELL=true"
- else
- myopts="${myopts} USE_HUNSPELL=false"
- fi
-
- eqmake4 src.pro PREFIX="/usr/bin" ${myopts}
+ eqmake4 src.pro \
+ PREFIX="${EPREFIX}/usr/bin" \
+ USE_ASPELL=$(use aspell && echo true || echo false) \
+ USE_HUNSPELL=$(use hunspell && echo true || echo false)
}
src_install() {