summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-12-13 18:31:45 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-12-13 18:31:45 +0000
commit86936ffbcae99f9d5eb28296d8065f3b676788c7 (patch)
tree813b30f738d6e98fb52d871c563ed192f27ecbe4 /app-editors/scite
parentstable bump (diff)
downloadgentoo-2-86936ffbcae99f9d5eb28296d8065f3b676788c7.tar.gz
gentoo-2-86936ffbcae99f9d5eb28296d8065f3b676788c7.tar.bz2
gentoo-2-86936ffbcae99f9d5eb28296d8065f3b676788c7.zip
Version bump closes #74254
Diffstat (limited to 'app-editors/scite')
-rw-r--r--app-editors/scite/ChangeLog7
-rw-r--r--app-editors/scite/Manifest16
-rw-r--r--app-editors/scite/files/digest-scite-1.6.21
-rw-r--r--app-editors/scite/scite-1.6.2.ebuild75
4 files changed, 86 insertions, 13 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index f61194e37f44..d893edac6c59 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/scite
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.30 2004/10/27 05:00:36 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.31 2004/12/13 18:31:45 pythonhead Exp $
+
+*scite-1.6.2 (13 Dec 2004)
+
+ 13 Dec 2004; Rob Cakebread <pythonhead@gentoo.org> +scite-1.6.2.ebuild:
+ Version bump closes #74254
26 Oct 2004; Rob Cakebread <pythonhead@gentoo.org> -scite-1.4.9.ebuild,
scite-1.5.6.ebuild, scite-1.5.7.ebuild, scite-1.5.8.ebuild,
diff --git a/app-editors/scite/Manifest b/app-editors/scite/Manifest
index d028a83e471d..3f34eb26800c 100644
--- a/app-editors/scite/Manifest
+++ b/app-editors/scite/Manifest
@@ -1,15 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 a42dcc76c132b5e89aff50b7381590ae ChangeLog 5528
+MD5 9405e846d7461668c0f167eac249d6ba ChangeLog 5660
MD5 4eb1abff335478b86f5c65997e0148f2 metadata.xml 222
+MD5 e95ce06a88b8a57dc7de750a9536ab2d scite-1.6.2.ebuild 1893
MD5 0a80d040b409243e36c7584a148e2ab8 scite-1.6.1.ebuild 1890
-MD5 2561568c62ec3edc2b46be6638c80427 files/scite.desktop 169
+MD5 42ceb479aebfc9cd9818f0d6a0e39020 files/digest-scite-1.6.2 58
MD5 c022b3ac9b612f257e304f7f90eb7f98 files/digest-scite-1.6.1 58
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBhHHpHTu7gpaalycRAkUcAJ95yMAUAynpIIenvkqfIekGdZjKoQCfUm6M
-sSZgrjp1T8qUGEYi2EKwwI8=
-=bccl
------END PGP SIGNATURE-----
+MD5 2561568c62ec3edc2b46be6638c80427 files/scite.desktop 169
diff --git a/app-editors/scite/files/digest-scite-1.6.2 b/app-editors/scite/files/digest-scite-1.6.2
new file mode 100644
index 000000000000..edd7f730c214
--- /dev/null
+++ b/app-editors/scite/files/digest-scite-1.6.2
@@ -0,0 +1 @@
+MD5 4d34c8b669f0a8e0ae862a8e56fd8d01 scite162.tgz 1140114
diff --git a/app-editors/scite/scite-1.6.2.ebuild b/app-editors/scite/scite-1.6.2.ebuild
new file mode 100644
index 000000000000..badd3cac2221
--- /dev/null
+++ b/app-editors/scite/scite-1.6.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.6.2.ebuild,v 1.1 2004/12/13 18:31:45 pythonhead Exp $
+
+inherit toolchain-funcs
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://www.scintilla.org"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE="gtk2 lua"
+
+RDEPEND="gtk2? ( >=x11-libs/gtk+-2 )
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}/gtk
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/scintilla/gtk
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ || die "error patching makefile"
+
+ cd ${S}
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ || die "error patching makefile"
+
+}
+
+src_compile() {
+ local makeopts
+ use gtk2 || makeopts="GTK1=1"
+ #use debug && makeopts="${makeopts} DEBUG=1"
+
+ make -C ../../scintilla/gtk ${makeopts} || die "prep make failed"
+ emake ${makeopts} || die "make failed"
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/bin
+ dodir /usr/share
+ dodir /usr/share/pixmaps
+ dodir /usr/share/applications
+
+ make prefix=${D}/usr install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv ${D}/usr/bin/SciTE ${D}/usr/bin/scite
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f ${D}/usr/share/applications/SciTE.desktop
+ doins ${FILESDIR}/scite.desktop
+
+ doman ../doc/scite.1
+ dodoc ../README
+}