summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-01-14 11:55:18 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-01-14 11:55:18 +0000
commitf91636fd73d8affebf4fce966f82aa8cd5bff8cc (patch)
treeaf1ab89c33077ca41a8914e1820d1fdb8c9907dc /app-editors/qxmledit
parentLinux patches 3.1.8 and 3.1.9 (diff)
downloadgentoo-2-f91636fd73d8affebf4fce966f82aa8cd5bff8cc.tar.gz
gentoo-2-f91636fd73d8affebf4fce966f82aa8cd5bff8cc.tar.bz2
gentoo-2-f91636fd73d8affebf4fce966f82aa8cd5bff8cc.zip
version bump. Bug #397811. Thanks to Peter B. <mls@bossynet.de>
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/qxmledit')
-rw-r--r--app-editors/qxmledit/ChangeLog9
-rw-r--r--app-editors/qxmledit/qxmledit-0.6.1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/app-editors/qxmledit/ChangeLog b/app-editors/qxmledit/ChangeLog
index 298ab78d6e04..65bb5015fafd 100644
--- a/app-editors/qxmledit/ChangeLog
+++ b/app-editors/qxmledit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/qxmledit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.12 2011/11/24 12:45:18 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.13 2012/01/14 11:55:18 hwoarang Exp $
+
+*qxmledit-0.6.1 (14 Jan 2012)
+
+ 14 Jan 2012; Markos Chandras <hwoarang@gentoo.org> +qxmledit-0.6.1.ebuild:
+ version bump. Bug #397811. Thanks to Peter B. <mls@bossynet.de>
24 Nov 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #290906
diff --git a/app-editors/qxmledit/qxmledit-0.6.1.ebuild b/app-editors/qxmledit/qxmledit-0.6.1.ebuild
new file mode 100644
index 000000000000..eaa666951ff8
--- /dev/null
+++ b/app-editors/qxmledit/qxmledit-0.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit qt4-r2
+
+MY_P="qxmledit-${PV}-src"
+
+DESCRIPTION="Qt4 XML Editor"
+HOMEPAGE="http://code.google.com/p/qxmledit/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/src/"
+
+DOCS="AUTHORS NEWS README TODO"
+DOCSDIR="${WORKDIR}/${P}/"
+
+src_prepare(){
+ # fix installation path
+ sed -i "/^INST_DIR/ s/\/opt\/${PN}/\/usr\/bin/" QXmlEdit.pro || \
+ die "failed to fix installation path"
+ # fix translations
+ sed -i "/^INST_DATA_DIR/ s/\/opt/\/usr\/share/" QXmlEdit.pro || \
+ die "failed to fix translations"
+ qt4-r2_src_prepare
+}
+
+src_install(){
+ qt4-r2_src_install
+ newicon "${S}"/images/icon.png ${PN}.png
+ make_desktop_entry QXmlEdit QXmlEdit ${PN} "Qt;Utility;TextEditor;"
+}