summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-02-26 14:19:42 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-02-26 14:19:42 +0000
commite9e58b6557eb1a916229a08987c1b800f661d405 (patch)
tree809cc3cb0c23d843c8c4ba5f1c8e40b4a32c556a /app-editors/qemacs/files
parentRDEPEND on >=sys-apps/findutils-4.2.29 to prevent invalid predicate `-L' erro... (diff)
downloadgentoo-2-e9e58b6557eb1a916229a08987c1b800f661d405.tar.gz
gentoo-2-e9e58b6557eb1a916229a08987c1b800f661d405.tar.bz2
gentoo-2-e9e58b6557eb1a916229a08987c1b800f661d405.zip
version bump: CVS snapshot from upstream to fix bug 144081, reported by DMoL <master_temp@tut.by>
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-editors/qemacs/files')
-rw-r--r--app-editors/qemacs/files/digest-qemacs-0.3.2_pre200702263
-rw-r--r--app-editors/qemacs/files/qemacs-0.3.2_pre20070226-Makefile-gentoo.patch45
-rw-r--r--app-editors/qemacs/files/qemacs-0.3.2_pre20070226-make_backup.patch74
-rw-r--r--app-editors/qemacs/files/qemacs-0.3.2_pre20070226-qemacs-datadir.patch101
-rw-r--r--app-editors/qemacs/files/qemacs-0.3.2_pre20070226-tty_utf8.patch44
5 files changed, 267 insertions, 0 deletions
diff --git a/app-editors/qemacs/files/digest-qemacs-0.3.2_pre20070226 b/app-editors/qemacs/files/digest-qemacs-0.3.2_pre20070226
new file mode 100644
index 000000000000..d9c25c3361f5
--- /dev/null
+++ b/app-editors/qemacs/files/digest-qemacs-0.3.2_pre20070226
@@ -0,0 +1,3 @@
+MD5 f03330e8aaa80f9efb9214c1ce61c36e qemacs-0.3.2_pre20070226.tar.bz2 806174
+RMD160 024982b3c62093c6377be2836ee0d5d7c12cd55b qemacs-0.3.2_pre20070226.tar.bz2 806174
+SHA256 0611c5fee1f7c6538fa1c5b4108f1968f5f05eeb9165b84c72d4c6d7dd8556af qemacs-0.3.2_pre20070226.tar.bz2 806174
diff --git a/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-Makefile-gentoo.patch b/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-Makefile-gentoo.patch
new file mode 100644
index 000000000000..7cb542cdc36d
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-Makefile-gentoo.patch
@@ -0,0 +1,45 @@
+diff -u ../qemacs/Makefile ./Makefile
+--- ../qemacs/Makefile 2007-02-06 18:41:16.000000000 +0100
++++ ./Makefile 2007-02-26 14:03:24.000000000 +0100
+@@ -38,15 +38,6 @@
+ LDFLAGS+= -p
+ endif
+
+-ifdef TARGET_ARCH_X86
+-#CFLAGS+=-fomit-frame-pointer
+-ifeq ($(GCC_MAJOR),2)
+-CFLAGS+=-m386 -malign-functions=0
+-else
+-CFLAGS+=-march=i386 -falign-functions=0
+-endif
+-endif
+-
+ DEFINES=-DHAVE_QE_CONFIG_H
+
+ ########################################################
+@@ -211,15 +202,17 @@
+ rm -f config.h config.mak
+
+ install: $(TARGETS) qe.1 kmaps ligatures
+- install -m 755 qe$(EXE) $(prefix)/bin/qemacs
+- ln -sf qemacs $(prefix)/bin/qe$(EXE)
++ mkdir -p $(DESTDIR)$(prefix)/bin
++ install -m 755 qe $(DESTDIR)$(prefix)/bin/qemacs
++ install -m 755 libqhtml/csstoqe $(DESTDIR)$(prefix)/bin/csstoqe
+ ifdef CONFIG_FFMPEG
+- ln -sf qemacs $(prefix)/bin/ffplay
++ ln -sf qemacs $(DESTDIR)$(prefix)/bin/qemacs-ffplay
+ endif
+- mkdir -p $(prefix)/share/qe
+- install kmaps ligatures $(prefix)/share/qe
+- install qe.1 $(prefix)/man/man1
++ mkdir -p $(DESTDIR)$(prefix)/share/qemacs
++ install -m644 kmaps ligatures $(DESTDIR)$(prefix)/share/qe
++ mkdir -p $(DESTDIR)$(prefix)/share/man/man1
++ install -m644 qe.1 $(DESTDIR)$(prefix)/share/man/man1/qemacs.1
+ ifdef CONFIG_HTML
+- install -m 755 -s html2png$(EXE) $(prefix)/bin
++ install -m 755 -s html2png $(DESTDIR)$(prefix)/bin
+ endif
+
+ TAGS: force \ No newline at end of file
diff --git a/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-make_backup.patch b/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-make_backup.patch
new file mode 100644
index 000000000000..6d96be603127
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-make_backup.patch
@@ -0,0 +1,74 @@
+diff -u ../qemacs/buffer.c ./buffer.c
+--- ../qemacs/buffer.c 2006-12-31 20:34:01.000000000 +0100
++++ ./buffer.c 2007-02-26 15:00:50.000000000 +0100
+@@ -1528,10 +1528,12 @@
+ if (stat(filename, &st) == 0)
+ mode = st.st_mode & 0777;
+
+- /* backup old file if present */
+- strcpy(buf1, filename);
+- strcat(buf1, "~");
+- rename(filename, buf1);
++ /* backup old file if present and make-backup-files is on */
++ if(mbf == 1) {
++ strcpy(buf1, filename);
++ strcat(buf1, "~");
++ rename(filename, buf1);
++ }
+
+ ret = b->data_type->buffer_save(b, filename);
+ if (ret < 0)
+Gemeinsame Unterverzeichnisse: ../qemacs/fonts und ./fonts.
+Gemeinsame Unterverzeichnisse: ../qemacs/libqhtml und ./libqhtml.
+Nur in ../qemacs: Makefile.orig.
+Gemeinsame Unterverzeichnisse: ../qemacs/plugin-example und ./plugin-example.
+diff -u ../qemacs/qe.c ./qe.c
+--- ../qemacs/qe.c 2007-02-26 14:58:27.000000000 +0100
++++ ./qe.c 2007-02-26 15:02:13.000000000 +0100
+@@ -67,6 +67,7 @@
+ int trace_buffer_state;
+ int no_init_file;
+ const char *user_option;
++mbf = 1;
+
+ /* mode handling */
+
+@@ -4816,6 +4817,14 @@
+ do_refresh(qs->first_window);
+ }
+
++static void make_backup_files(EditState *s) {
++ if(mbf == 1) {
++ mbf = 0;
++ } else {
++ mbf = 1;
++ }
++}
++
+ /* compute default path for find/save buffer */
+ static void get_default_path(EditState *s, char *buf, int buf_size)
+ {
+diff -u ../qemacs/qeconfig.h ./qeconfig.h
+--- ../qemacs/qeconfig.h 2007-01-12 16:06:16.000000000 +0100
++++ ./qeconfig.h 2007-02-26 15:03:30.000000000 +0100
+@@ -86,6 +86,7 @@
+ do_changecase_region, 0, "*v")
+ CMDV( KEY_CTRLX(KEY_CTRL('u')), KEY_NONE, "upcase-region",
+ do_changecase_region, 1, "*v")
++ CMD0( KEY_NONE, KEY_NONE, "make-backup-files", make_backup_files)
+
+ /* keyboard macros */
+ CMD0( KEY_CTRLX('('), KEY_NONE, "start-kbd-macro", do_start_macro)
+diff -u ../qemacs/qe.h ./qe.h
+--- ../qemacs/qe.h 2007-01-12 16:06:16.000000000 +0100
++++ ./qe.h 2007-02-26 15:02:41.000000000 +0100
+@@ -1422,6 +1422,8 @@
+ void fill_border(EditState *s, int x, int y, int w, int h, int color);
+ int qe_bitmap_format_to_pix_fmt(int format);
+
++int mbf;
++
+ /* shell.c */
+ EditBuffer *new_shell_buffer(const char *name, const char *path,
+ const char **argv, int is_shell);
+Gemeinsame Unterverzeichnisse: ../qemacs/tests und ./tests.
diff --git a/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-qemacs-datadir.patch b/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-qemacs-datadir.patch
new file mode 100644
index 000000000000..f34700dff609
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-qemacs-datadir.patch
@@ -0,0 +1,101 @@
+diff -u ../qemacs/config.eg ./config.eg
+--- ../qemacs/config.eg 2006-12-09 20:02:07.000000000 +0100
++++ ./config.eg 2007-02-26 14:55:51.000000000 +0100
+@@ -1,6 +1,6 @@
+ // Sample qemacs config file
+ //
+-// copy it in ~/.qe/config
++// copy it in ~/.qemacs/config
+ //
+ // You can call any Qemacs command with a C like syntax.
+ //
+Gemeinsame Unterverzeichnisse: ../qemacs/fonts und ./fonts.
+Gemeinsame Unterverzeichnisse: ../qemacs/libqhtml und ./libqhtml.
+diff -u ../qemacs/Makefile ./Makefile
+--- ../qemacs/Makefile 2007-02-26 14:57:04.000000000 +0100
++++ ./Makefile 2007-02-26 14:56:34.000000000 +0100
+@@ -209,7 +209,7 @@
+ ln -sf qemacs $(DESTDIR)$(prefix)/bin/qemacs-ffplay
+ endif
+ mkdir -p $(DESTDIR)$(prefix)/share/qemacs
+- install -m644 kmaps ligatures $(DESTDIR)$(prefix)/share/qe
++ install -m644 kmaps ligatures $(DESTDIR)$(prefix)/share/qemacs
+ mkdir -p $(DESTDIR)$(prefix)/share/man/man1
+ install -m644 qe.1 $(DESTDIR)$(prefix)/share/man/man1/qemacs.1
+ ifdef CONFIG_HTML
+Nur in ../qemacs: Makefile.orig.
+Gemeinsame Unterverzeichnisse: ../qemacs/plugin-example und ./plugin-example.
+diff -u ../qemacs/qe.c ./qe.c
+--- ../qemacs/qe.c 2007-02-06 18:41:16.000000000 +0100
++++ ./qe.c 2007-02-26 14:55:51.000000000 +0100
+@@ -6920,10 +6920,10 @@
+ user_option = user;
+ /* compute resources path */
+ pstrcpy(qs->res_path, sizeof(qs->res_path),
+- CONFIG_QE_PREFIX "/share/qe:" CONFIG_QE_PREFIX "/lib/qe:"
+- "/usr/share/qe:/usr/lib/qe");
++ CONFIG_QE_PREFIX "/share/qemacs:" CONFIG_QE_PREFIX "/lib/qemacs:"
++ "/usr/share/qemacs:/usr/lib/qemacs");
+ if (user) {
+- /* use ~USER/.qe instead of ~/.qe */
++ /* use ~USER/.qemacs instead of ~/.qemacs */
+ /* CG: should get user homedir */
+ snprintf(path, sizeof(path), "/home/%s", user);
+ home_path = path;
+@@ -6933,7 +6933,7 @@
+ if (home_path) {
+ pstrcat(qs->res_path, sizeof(qs->res_path), ":");
+ pstrcat(qs->res_path, sizeof(qs->res_path), home_path);
+- pstrcat(qs->res_path, sizeof(qs->res_path), "/.qe");
++ pstrcat(qs->res_path, sizeof(qs->res_path), "/.qemacs");
+ }
+ }
+
+@@ -6942,7 +6942,7 @@
+ {func_noarg: show_usage}},
+ { "no-init-file", "q", NULL, CMD_OPT_BOOL, "do not load config files",
+ {int_ptr: &no_init_file}},
+- { "user", "u", "USER", CMD_OPT_ARG, "load ~USER/.qe/config instead of your own",
++ { "user", "u", "USER", CMD_OPT_ARG, "load ~USER/.qemacs/config instead of your own",
+ {func_arg: set_user_option}},
+ { "version", "V", NULL, 0, "display version information and exit",
+ {func_noarg: show_version}},
+diff -u ../qemacs/qe-doc.html ./qe-doc.html
+--- ../qemacs/qe-doc.html 2006-12-09 19:37:12.000000000 +0100
++++ ./qe-doc.html 2007-02-26 14:55:51.000000000 +0100
+@@ -519,7 +519,7 @@
+ <h2 class="section"> 4.1 Resource path </h2>
+
+ <p>All resources and configuration files are looked in the following paths:
+-<tt>`/usr/share/qe:/usr/local/share/qe:/usr/lib/qe:/usr/local/lib/qe:~/.qe'</tt>
++<tt>`/usr/share/qemacs:/usr/local/share/qemacs:/usr/lib/qemacs:/usr/local/lib/qemacs:~/.qemacs'</tt>
+ </p>
+ <hr size="6">
+ <a name="SEC16"></a>
+@@ -541,7 +541,7 @@
+ </tr></table>
+ <h2 class="section"> 4.2 Configuration file </h2>
+
+-<p>QEmacs tries to load a configuration file in <tt>`~/.qe/config'</tt>. Each
++<p>QEmacs tries to load a configuration file in <tt>`~/.qemacs/config'</tt>. Each
+ line of the configuration file is a QEmacs command with a C like syntax
+ ('-' in command name can be replaced by '_').
+ </p>
+diff -u ../qemacs/qe-doc.texi ./qe-doc.texi
+--- ../qemacs/qe-doc.texi 2006-12-09 19:37:12.000000000 +0100
++++ ./qe-doc.texi 2007-02-26 14:55:51.000000000 +0100
+@@ -237,11 +237,11 @@
+ @section Resource path
+
+ All resources and configuration files are looked in the following paths:
+-@file{/usr/share/qe:/usr/local/share/qe:/usr/lib/qe:/usr/local/lib/qe:~/.qe}
++@file{/usr/share/qemacs:/usr/local/share/qemacs:/usr/lib/qemacs:/usr/local/lib/qemacs:~/.qemacs}
+
+ @section Configuration file
+
+-QEmacs tries to load a configuration file in @file{~/.qe/config}. Each
++QEmacs tries to load a configuration file in @file{~/.qemacs/config}. Each
+ line of the configuration file is a QEmacs command with a C like syntax
+ ('-' in command name can be replaced by '_').
+
+Gemeinsame Unterverzeichnisse: ../qemacs/tests und ./tests.
diff --git a/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-tty_utf8.patch b/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-tty_utf8.patch
new file mode 100644
index 000000000000..31a890cd123b
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-tty_utf8.patch
@@ -0,0 +1,44 @@
+Gemeinsame Unterverzeichnisse: ../qemacs/fonts und ./fonts.
+Gemeinsame Unterverzeichnisse: ../qemacs/libqhtml und ./libqhtml.
+Gemeinsame Unterverzeichnisse: ../qemacs/plugin-example und ./plugin-example.
+Gemeinsame Unterverzeichnisse: ../qemacs/tests und ./tests.
+diff -u ../qemacs/tty.c ./tty.c
+--- ../qemacs/tty.c 2007-02-08 00:27:33.000000000 +0100
++++ ./tty.c 2007-02-26 15:07:41.000000000 +0100
+@@ -78,7 +78,6 @@
+ /* input handling */
+ enum InputState input_state;
+ int input_param;
+- int utf8_state;
+ int utf8_index;
+ unsigned char buf[10];
+ char *term_name;
+@@ -374,15 +373,19 @@
+
+ /* charset handling */
+ if (s->charset == &charset_utf8) {
+- if (ts->utf8_state == 0) {
+- const char *p;
+- p = (const char *)ts->buf;
+- ch = utf8_decode(&p);
+- } else {
+- ts->utf8_state = utf8_length[ts->buf[0]] - 1;
+- ts->utf8_index = 0;
+- return;
+- }
++ /* Make sure utf8 input works correctly 20040314 <damm@opensource.se> */
++ ts->utf8_index++;
++
++ if (utf8_length[ts->buf[0]] == ts->utf8_index) {;
++ const char *p;
++ p = (const char *)ts->buf;
++ ch = utf8_decode(&p);
++ ts->utf8_index = 0;
++ }
++ else {
++ return;
++ }
++
+ } else {
+ ch = ts->buf[0];
+ }