summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-02-19 12:20:02 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-02-19 12:20:02 +0000
commit006363cec53d797fb7d1cae1d65ea8fcb797be3a (patch)
tree70b62716ddd28b74afbe9d6e2ca2f729d60a66e6 /app-editors/nedit
parentQuoted NTOP_OPTS in /etc/conf.d/ntop to fix bug #80663 (diff)
downloadgentoo-2-006363cec53d797fb7d1cae1d65ea8fcb797be3a.tar.gz
gentoo-2-006363cec53d797fb7d1cae1d65ea8fcb797be3a.tar.bz2
gentoo-2-006363cec53d797fb7d1cae1d65ea8fcb797be3a.zip
fix to compile with all motif versions, mark stable
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-editors/nedit')
-rw-r--r--app-editors/nedit/ChangeLog5
-rw-r--r--app-editors/nedit/nedit-5.5.ebuild9
2 files changed, 10 insertions, 4 deletions
diff --git a/app-editors/nedit/ChangeLog b/app-editors/nedit/ChangeLog
index 70ad85305175..5da499f03a8f 100644
--- a/app-editors/nedit/ChangeLog
+++ b/app-editors/nedit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/nedit
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/ChangeLog,v 1.34 2005/01/01 13:32:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/ChangeLog,v 1.35 2005/02/19 12:20:02 lanius Exp $
+
+ 19 Feb 2005; Heinrich Wendel <lanius@gentoo.org> nedit-5.5.ebuild:
+ fix to compile with all motif versions, mark stable
28 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/app-editors/nedit/nedit-5.5.ebuild b/app-editors/nedit/nedit-5.5.ebuild
index fa56912fecf2..c64f0eceb3b2 100644
--- a/app-editors/nedit/nedit-5.5.ebuild
+++ b/app-editors/nedit/nedit-5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5.ebuild,v 1.2 2005/01/01 13:32:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5.ebuild,v 1.3 2005/02/19 12:20:02 lanius Exp $
inherit gcc
@@ -10,16 +10,19 @@ SRC_URI="mirror://sourceforge/nedit/${P}-src.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~amd64 ~alpha"
+KEYWORDS="x86 ~ppc ~sparc ~mips amd64 ~alpha"
IUSE="spell"
RDEPEND="spell? ( virtual/aspell-dict )
- virtual/x11"
+ x11-libs/openmotif"
DEPEND="${RDEPEND}
dev-util/yacc
x11-libs/openmotif"
src_compile() {
+ sed -i -e "s:-Wl,-Bstatic::" makefiles/Makefile.linux
+ sed -i -e "s:0.93.0:0.94.0:" util/check_lin_tif.c
+ sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:" makefiles/Makefile.linux
sed -i -e 's:"/bin/csh":"/bin/sh":' source/preferences.c
make CC=$(gcc-getCC) linux || die
}