summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPrakash Shetty <crux@gentoo.org>2001-07-03 07:23:35 +0000
committerPrakash Shetty <crux@gentoo.org>2001-07-03 07:23:35 +0000
commitf09d6a0c7084bb0ba4aa3ddafe99735cb1a5b47a (patch)
treea92ad4a7f2d58ac20b6e9a4a7e639913b4203246 /app-editors/nano
parentfixed a crux typo (diff)
downloadgentoo-2-f09d6a0c7084bb0ba4aa3ddafe99735cb1a5b47a.tar.gz
gentoo-2-f09d6a0c7084bb0ba4aa3ddafe99735cb1a5b47a.tar.bz2
gentoo-2-f09d6a0c7084bb0ba4aa3ddafe99735cb1a5b47a.zip
Moved Nano Editor to app-editors as advised by Daniel
Added Files: app-editors/nano/nano-1.0.2.ebuild app-editors/nano/nano-1.0.3.ebuild app-editors/nano/files/digest-nano-1.0.2 app-editors/nano/files/digest-nano-1.0.3 Removed Files: app-text/nano/nano-1.0.2.ebuild app-text/nano/nano-1.0.3.ebuild app-text/nano/files/digest-nano-1.0.2 app-text/nano/files/digest-nano-1.0.3
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/files/digest-nano-1.0.21
-rw-r--r--app-editors/nano/files/digest-nano-1.0.31
-rw-r--r--app-editors/nano/nano-1.0.2.ebuild28
-rw-r--r--app-editors/nano/nano-1.0.3.ebuild24
4 files changed, 54 insertions, 0 deletions
diff --git a/app-editors/nano/files/digest-nano-1.0.2 b/app-editors/nano/files/digest-nano-1.0.2
new file mode 100644
index 000000000000..e7e35b02c4ee
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.0.2
@@ -0,0 +1 @@
+MD5 5535dcaf7f412d6fe0b9f4505f3ff4e9 nano-1.0.2.tar.gz
diff --git a/app-editors/nano/files/digest-nano-1.0.3 b/app-editors/nano/files/digest-nano-1.0.3
new file mode 100644
index 000000000000..0936b44e535c
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.0.3
@@ -0,0 +1 @@
+MD5 520a7d3330485cd747d0ebfd48a3fd57 nano-1.0.3.tar.gz
diff --git a/app-editors/nano/nano-1.0.2.ebuild b/app-editors/nano/nano-1.0.2.ebuild
new file mode 100644
index 000000000000..c44afe2b2eb1
--- /dev/null
+++ b/app-editors/nano/nano-1.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Prakash Shetty (Crux) <ps@gnuos.org>
+
+#Note: ${A} is now auto-generated from SRC_URI; you shouldn't set it manually
+#A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Clone of PICO with more Fuctions in a smaller Size"
+#SRC_URI="http://www.nano-editor.org/dist/v1.0/${A}"
+SRC_URI="http://www.nano-editor.org/dist/v1.0/${P}.tar.gz"
+HOMEPAGE="http://www.nano-editor.org"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/ncurses-5.2"
+
+src_compile() {
+ cd ${S}
+# try ./configure --prefix=/usr --enable-extra
+# FHS 2.2 compliance:
+ try ./configure --prefix=/usr --enable-extra --mandir=/usr/share/man --infodir=/usr/share/info
+ try make
+}
+
+src_install () {
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc COPYING ChangeLog README
+}
diff --git a/app-editors/nano/nano-1.0.3.ebuild b/app-editors/nano/nano-1.0.3.ebuild
new file mode 100644
index 000000000000..3f9b358f5c45
--- /dev/null
+++ b/app-editors/nano/nano-1.0.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Prakash Shetty (Crux) <ps@gnuos.org>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Clone of PICO with more Fuctions in a smaller Size"
+#SRC_URI="http://www.nano-editor.org/dist/v1.0/${A}"
+SRC_URI="http://www.nano-editor.org/dist/v1.0/${P}.tar.gz"
+HOMEPAGE="http://www.nano-editor.org"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/ncurses-5.2"
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr --enable-extra --mandir=/usr/share/man --infodir=/usr/share/info
+ try make
+}
+
+src_install () {
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc COPYING ChangeLog README
+}