summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-15 14:12:35 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-15 14:12:35 +0000
commite7cba808510984e6a2c723603aa2b78f3bf3d81d (patch)
treea7617f1c26a2546ddb721bdcfadb83aa8a382adc /app-editors/nano
parentfix SRC_URI typo (diff)
downloadgentoo-2-e7cba808510984e6a2c723603aa2b78f3bf3d81d.tar.gz
gentoo-2-e7cba808510984e6a2c723603aa2b78f3bf3d81d.tar.bz2
gentoo-2-e7cba808510984e6a2c723603aa2b78f3bf3d81d.zip
old
(Portage version: 2.1.5.5)
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/nano-1.2.5.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-editors/nano/nano-1.2.5.ebuild b/app-editors/nano/nano-1.2.5.ebuild
deleted file mode 100644
index 89259ea392a2..000000000000
--- a/app-editors/nano/nano-1.2.5.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.2.5.ebuild,v 1.6 2008/05/10 10:28:58 vapier Exp $
-
-inherit eutils
-
-MY_P=${PN}-${PV/_}
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-SRC_URI="http://www.nano-editor.org/dist/v1.2/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc s390 sh sparc x86"
-IUSE="nls build spell justify debug slang ncurses"
-
-DEPEND=">=sys-libs/ncurses-5.2
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( =sys-libs/slang-1* ) )"
-
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- local myconf=""
- use build && myconf="${myconf} --disable-wrapping-as-root"
- use ncurses || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- --enable-color \
- --enable-multibuffer \
- --enable-nanorc \
- $(use_enable justify) \
- $(use_enable spell speller) \
- $(use_enable debug) \
- $(use_enable nls) \
- ${myconf} \
- || die "configure failed"
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- if use build ; then
- rm -r "${D}"/usr/share
- else
- cat "${FILESDIR}"/nanorc-* >> nanorc.sample
- dodoc ChangeLog README nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml *.html
- insinto /etc
- newins nanorc.sample nanorc
- fi
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-}