summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-18 04:09:28 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-18 04:09:28 +0000
commitc9c84a3d53beffa7dcbd48626e2ff6fcc552eb00 (patch)
tree8836278a9e71888711fec28e0c571357117aea62 /app-editors/nano
parentver bump (Manifest recommit) (diff)
downloadgentoo-2-c9c84a3d53beffa7dcbd48626e2ff6fcc552eb00.tar.gz
gentoo-2-c9c84a3d53beffa7dcbd48626e2ff6fcc552eb00.tar.bz2
gentoo-2-c9c84a3d53beffa7dcbd48626e2ff6fcc552eb00.zip
version bump
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/files/1.3.4-nomac.patch11
-rw-r--r--app-editors/nano/files/digest-nano-1.3.41
-rw-r--r--app-editors/nano/nano-1.3.4.ebuild64
3 files changed, 76 insertions, 0 deletions
diff --git a/app-editors/nano/files/1.3.4-nomac.patch b/app-editors/nano/files/1.3.4-nomac.patch
new file mode 100644
index 000000000000..99787f01a966
--- /dev/null
+++ b/app-editors/nano/files/1.3.4-nomac.patch
@@ -0,0 +1,11 @@
+--- src/global.c.orig 2004-08-18 00:00:51.573889920 -0400
++++ src/global.c 2004-08-18 00:00:54.842393032 -0400
+@@ -1043,8 +1043,6 @@
+ N_("No conversion from DOS/Mac format"), NO_CONVERT);
+ toggle_init_one(TOGGLE_DOS_KEY, N_("Writing file in DOS format"),
+ DOS_FILE);
+- toggle_init_one(TOGGLE_MAC_KEY, N_("Writing file in Mac format"),
+- MAC_FILE);
+ toggle_init_one(TOGGLE_BACKUP_KEY, N_("Backup files"), BACKUP_FILE);
+ }
+ toggle_init_one(TOGGLE_SMOOTH_KEY, N_("Smooth scrolling"), SMOOTHSCROLL);
diff --git a/app-editors/nano/files/digest-nano-1.3.4 b/app-editors/nano/files/digest-nano-1.3.4
new file mode 100644
index 000000000000..1929bb67fe45
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.3.4
@@ -0,0 +1 @@
+MD5 c24028eade9f713009a18ab541564409 nano-1.3.4.tar.gz 961756
diff --git a/app-editors/nano/nano-1.3.4.ebuild b/app-editors/nano/nano-1.3.4.ebuild
new file mode 100644
index 000000000000..20ce001d2815
--- /dev/null
+++ b/app-editors/nano/nano-1.3.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.4.ebuild,v 1.1 2004/08/18 04:09:28 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}-${PV/_}
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+SRC_URI="http://www.nano-editor.org/dist/v1.3/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390 ~macos"
+IUSE="nls build spell justify debug slang ncurses nomac"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ slang? ( sys-libs/slang )"
+PROVIDE="virtual/editor"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use nomac && epatch ${FILESDIR}/${PV}-nomac.patch
+}
+
+src_compile() {
+ local myconf=""
+ use build && myconf="${myconf} --disable-wrapping-as-root"
+ use ncurses || myconf="${myconf} `use_with slang`"
+
+ econf \
+ --bindir=/bin \
+ --enable-color \
+ --enable-multibuffer \
+ --enable-nanorc \
+ `use_enable spell` \
+ `use_enable justify` \
+ `use_enable debug` \
+ `use_enable nls` \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if use build ; then
+ rm -rf ${D}/usr/share
+ else
+ cat ${FILESDIR}/nanorc-* >> doc/nanorc.sample
+ dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+ fi
+
+ dodir /usr/bin
+ dosym ../../bin/nano /usr/bin/nano
+}