summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-25 19:25:33 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-25 19:25:33 +0000
commitc2ba75fcec97615516867263cf28033edbbc2231 (patch)
tree1cc84aa4b25f667f0999ac1c6ad072661a474f45 /app-editors/nano
parentInitial commit - this closes bug #16998. (diff)
downloadgentoo-2-c2ba75fcec97615516867263cf28033edbbc2231.tar.gz
gentoo-2-c2ba75fcec97615516867263cf28033edbbc2231.tar.bz2
gentoo-2-c2ba75fcec97615516867263cf28033edbbc2231.zip
icc support #36002
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/nano-1.3.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-editors/nano/nano-1.3.0.ebuild b/app-editors/nano/nano-1.3.0.ebuild
index 7696640d57fc..927ff9a942d3 100644
--- a/app-editors/nano/nano-1.3.0.ebuild
+++ b/app-editors/nano/nano-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.0.ebuild,v 1.3 2003/12/17 04:48:34 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.0.ebuild,v 1.4 2003/12/25 19:25:33 vapier Exp $
inherit eutils
@@ -12,7 +12,7 @@ SRC_URI="http://www.nano-editor.org/dist/v1.3/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ppc64"
-IUSE="nls build spell justify debug slang"
+IUSE="nls build spell justify debug slang icc"
DEPEND=">=sys-libs/ncurses-5.2
nls? ( sys-devel/gettext )
@@ -28,6 +28,8 @@ src_unpack() {
}
src_compile() {
+ use icc && export CC=icc
+
local myconf=""
use build && myconf="${myconf} --disable-wrapping-as-root"
[ `use ncurses` ] || myconf="${myconf} `use_with slang`"