summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-10-05 17:52:09 +0000
committerMike Frysinger <vapier@gentoo.org>2008-10-05 17:52:09 +0000
commita80bbea800d09476797293ae5789c0310b853b8f (patch)
treea5f43caa993f45f0fcf335b0e3b583e3c0174021 /app-editors/nano
parentVersion bump. (diff)
downloadgentoo-2-a80bbea800d09476797293ae5789c0310b853b8f.tar.gz
gentoo-2-a80bbea800d09476797293ae5789c0310b853b8f.tar.bz2
gentoo-2-a80bbea800d09476797293ae5789c0310b853b8f.zip
Version bump.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/ChangeLog7
-rw-r--r--app-editors/nano/nano-2.1.6.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index d915d005fe71..2ec467b4ee77 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/nano
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.205 2008/09/07 06:07:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.206 2008/10/05 17:52:09 vapier Exp $
+
+*nano-2.1.6 (05 Oct 2008)
+
+ 05 Oct 2008; Mike Frysinger <vapier@gentoo.org> +nano-2.1.6.ebuild:
+ Version bump.
*nano-2.0.9 (07 Sep 2008)
diff --git a/app-editors/nano/nano-2.1.6.ebuild b/app-editors/nano/nano-2.1.6.ebuild
new file mode 100644
index 000000000000..df27fe95891a
--- /dev/null
+++ b/app-editors/nano/nano-2.1.6.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.6.ebuild,v 1.1 2008/10/05 17:52:09 vapier Exp $
+
+inherit eutils
+if [[ ${PV} == "9999" ]] ; then
+ ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
+ ECVS_MODULE="nano"
+ ECVS_AUTH="pserver"
+ ECVS_USER="anonymous"
+ inherit cvs
+else
+ MY_P=${PN}-${PV/_}
+ SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug justify minimal ncurses nls slang spell unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ !ncurses? ( slang? ( sys-libs/slang ) )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if [[ ! -e configure ]] ; then
+ ./autogen.sh || die "autogen failed"
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use ncurses \
+ && myconf="--without-slang" \
+ || myconf="${myconf} $(use_with slang)"
+
+ econf \
+ --bindir=/bin \
+ $(use_enable !minimal color) \
+ $(use_enable !minimal multibuffer) \
+ $(use_enable !minimal nanorc) \
+ --disable-wrapping-as-root \
+ $(use_enable spell speller) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode utf8) \
+ $(use_enable minimal tiny) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+
+ insinto /usr/share/nano
+ local f
+ for f in "${FILESDIR}"/*.nanorc ; do
+ [[ -e ${D}/usr/share/nano/${f##*/} ]] && continue
+ doins "${f}" || die
+ echo "# include \"/usr/share/nano/${f##*/}\"" >> "${D}"/etc/nanorc
+ done
+}
+
+pkg_postinst() {
+ elog "More helpful info about nano, visit the GDP page:"
+ elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
+}