summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-02 14:02:57 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-02 14:02:57 +0000
commit59f5924a3133f02e50e6333993df1ca6898fc583 (patch)
tree3ded16898938131b0008e95e920871bc680b9b56 /app-editors/nano
parentold (diff)
downloadgentoo-2-59f5924a3133f02e50e6333993df1ca6898fc583.tar.gz
gentoo-2-59f5924a3133f02e50e6333993df1ca6898fc583.tar.bz2
gentoo-2-59f5924a3133f02e50e6333993df1ca6898fc583.zip
Version bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/ChangeLog16
-rw-r--r--app-editors/nano/files/digest-nano-1.3.81
-rw-r--r--app-editors/nano/files/nanorc-gentoo2
-rw-r--r--app-editors/nano/nano-1.3.8.ebuild68
4 files changed, 75 insertions, 12 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index d46f49db1ddd..ae375a946c90 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,18 +1,12 @@
# ChangeLog for app-editors/nano
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.75 2005/06/28 05:27:10 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.76 2005/07/02 14:02:57 vapier Exp $
- 28 Jun 2005; Joshua Kinard <kumba@gentoo.org> nano-1.3.7.ebuild:
- Marked stable on mips.
-
- 06 Jun 2005; Gustavo Zacarias <gustavoz@gentoo.org> nano-1.3.7.ebuild:
- Stable on sparc
+*nano-1.3.8 (02 Jul 2005)
- 06 Jun 2005; Markus Rothe <corsair@gentoo.org> nano-1.3.7.ebuild:
- Stable on ppc64
-
- 03 Jun 2005; Joseph Jezak <josejx@gentoo.org> nano-1.3.7.ebuild:
- Marked ppc stable.
+ 02 Jul 2005; Mike Frysinger <vapier@gentoo.org> files/nanorc-gentoo,
+ +nano-1.3.8.ebuild:
+ Version bump.
*nano-1.2.5 (18 May 2005)
diff --git a/app-editors/nano/files/digest-nano-1.3.8 b/app-editors/nano/files/digest-nano-1.3.8
new file mode 100644
index 000000000000..4d2955c73f81
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.3.8
@@ -0,0 +1 @@
+MD5 20633397bf5d462255f37dfcc7cad4e7 nano-1.3.8.tar.gz 1064222
diff --git a/app-editors/nano/files/nanorc-gentoo b/app-editors/nano/files/nanorc-gentoo
index 1b7e16cf3bc7..2ff46ec829ef 100644
--- a/app-editors/nano/files/nanorc-gentoo
+++ b/app-editors/nano/files/nanorc-gentoo
@@ -17,7 +17,7 @@ color red "\<(S|D|T|PV|PF|P|PN|A)\>" "\<C(XX)?FLAGS\>" "\<LDFLAGS\>" "\<C(HOST|T
color magenta "\<use(_(with|enable))?\> [!a-zA-Z0-9_+ -]*" "inherit.*"
color brightblue "e(begin|end|conf|install|make|warn|infon?|error|patch)"
color brightblue "\<die\>" "\<use(_(with|enable))?\>" "\<inherit\>" "\<has\>" "\<(has|best)_version\>" "\<unpack\>"
-color brightblue "\<(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|env|pam|menu|icon)\>"
+color brightblue "\<(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)\>"
color brightblue "\<do(python|sed|dir|hard|sym|html|jar|mo)\>" "\<keepdir\>"
color brightblue "prepall(|docs|info|man|strip)" "prep(info|lib|lib\.(so|a)|man|strip)"
color brightblue "\<(|doc|ins|exe)into\>" "\<f(owners|perms)\>" "\<(exe|ins|dir)opts\>"
diff --git a/app-editors/nano/nano-1.3.8.ebuild b/app-editors/nano/nano-1.3.8.ebuild
new file mode 100644
index 000000000000..488c6e6b43b3
--- /dev/null
+++ b/app-editors/nano/nano-1.3.8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.8.ebuild,v 1.1 2005/07/02 14:02:57 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}-${PV/_}
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+SRC_URI="http://www.nano-editor.org/dist/v1.3/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls build spell justify debug slang ncurses nomac unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ !ncurses? ( slang? ( sys-libs/slang ) )"
+PROVIDE="virtual/editor"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use nomac && epatch "${FILESDIR}"/${PN}-1.3.6-nomac.patch
+}
+
+src_compile() {
+ local myconf=""
+ use build && myconf="${myconf} --disable-wrapping-as-root"
+ use ncurses || myconf="${myconf} $(use_with slang)"
+
+ econf \
+ --bindir=/bin \
+ --enable-color \
+ --enable-multibuffer \
+ --enable-nanorc \
+ $(use_enable spell) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode utf8) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use build ; then
+ rm -rf "${D}"/usr/share
+ else
+ cat "${FILESDIR}"/nanorc-* >> doc/nanorc.sample
+ dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+ fi
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}
+
+pkg_postinst() {
+ einfo "More helpful info about nano, visit the GDP page:"
+ einfo "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
+}