summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-08-16 14:45:35 +0000
committerMike Frysinger <vapier@gentoo.org>2008-08-16 14:45:35 +0000
commit050cb312b7d7b13d2c2c8d30bc9a641f3da0efd0 (patch)
tree7235b9f4b7ab6dc31190becc03188b6d986abe28 /app-editors/nano
parentold (diff)
downloadgentoo-2-050cb312b7d7b13d2c2c8d30bc9a641f3da0efd0.tar.gz
gentoo-2-050cb312b7d7b13d2c2c8d30bc9a641f3da0efd0.tar.bz2
gentoo-2-050cb312b7d7b13d2c2c8d30bc9a641f3da0efd0.zip
Version bump and fix by Magnus Granberg for open(O_CREAT) bug #232079.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26.1 x86_64)
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/ChangeLog8
-rw-r--r--app-editors/nano/files/nano-2.1.4-open-mode.patch26
-rw-r--r--app-editors/nano/nano-2.1.4.ebuild84
3 files changed, 117 insertions, 1 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index 76964db7341b..c69456044e5e 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/nano
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.200 2008/07/28 19:41:15 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.201 2008/08/16 14:45:34 vapier Exp $
+
+*nano-2.1.4 (16 Aug 2008)
+
+ 16 Aug 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/nano-2.1.4-open-mode.patch, +nano-2.1.4.ebuild:
+ Version bump and fix by Magnus Granberg for open(O_CREAT) bug #232079.
28 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-editors/nano/files/nano-2.1.4-open-mode.patch b/app-editors/nano/files/nano-2.1.4-open-mode.patch
new file mode 100644
index 000000000000..60ce7dba94ee
--- /dev/null
+++ b/app-editors/nano/files/nano-2.1.4-open-mode.patch
@@ -0,0 +1,26 @@
+make sure we actually pass a valid mode to open() when creating files
+
+http://bugs.gentoo.org/232079
+
+patch by Magnus Granberg
+
+--- nano-2.1.1/src/files.c
++++ nano-2.1.1/src/files.c
+@@ -1572,7 +1572,7 @@
+ }
+
+ if (f_open == NULL) {
+- fd_source = open(realname, O_RDONLY | O_CREAT);
++ fd_source = open(realname, O_RDONLY | O_CREAT, S_IRUSR | S_IWUSR);
+
+ if (fd_source != -1) {
+ f_source = fdopen(fd_source, "rb");
+@@ -1691,7 +1691,7 @@
+ int fd_source;
+ FILE *f_source = NULL;
+
+- fd_source = open(tempname, O_RDONLY | O_CREAT);
++ fd_source = open(tempname, O_RDONLY | O_CREAT, S_IRUSR | S_IWUSR);
+
+ if (fd_source != -1) {
+ f_source = fdopen(fd_source, "rb");
diff --git a/app-editors/nano/nano-2.1.4.ebuild b/app-editors/nano/nano-2.1.4.ebuild
new file mode 100644
index 000000000000..6d64adcafb04
--- /dev/null
+++ b/app-editors/nano/nano-2.1.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.4.ebuild,v 1.1 2008/08/16 14:45:34 vapier Exp $
+
+inherit eutils
+if [[ ${PV} == "9999" ]] ; then
+ ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
+ ECVS_MODULE="nano"
+ ECVS_AUTH="pserver"
+ ECVS_USER="anonymous"
+ inherit cvs
+else
+ MY_P=${PN}-${PV/_}
+ SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug justify minimal ncurses nls slang spell unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ !ncurses? ( slang? ( sys-libs/slang ) )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-open-mode.patch #232079
+ if [[ ! -e configure ]] ; then
+ ./autogen.sh || die "autogen failed"
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use ncurses \
+ && myconf="--without-slang" \
+ || myconf="${myconf} $(use_with slang)"
+
+ econf \
+ --bindir=/bin \
+ $(use_enable !minimal color) \
+ $(use_enable !minimal multibuffer) \
+ $(use_enable !minimal nanorc) \
+ --disable-wrapping-as-root \
+ $(use_enable spell speller) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode utf8) \
+ $(use_enable minimal tiny) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+
+ insinto /usr/share/nano
+ local f
+ for f in "${FILESDIR}"/*.nanorc ; do
+ [[ -e ${D}/usr/share/nano/${f##*/} ]] && continue
+ doins "${f}" || die
+ echo "# include \"/usr/share/nano/${f##*/}\"" >> "${D}"/etc/nanorc
+ done
+}
+
+pkg_postinst() {
+ elog "More helpful info about nano, visit the GDP page:"
+ elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
+}