summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-04-22 01:52:55 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-04-22 01:52:55 +0000
commitf2a6e57f418ad7ffa6e6ec8717614e76b2818ea0 (patch)
treec04f456993ec047a8b258c86552c5202323ba7c1 /app-editors/mp
parentAdding Sparc support (diff)
downloadgentoo-2-f2a6e57f418ad7ffa6e6ec8717614e76b2818ea0.tar.gz
gentoo-2-f2a6e57f418ad7ffa6e6ec8717614e76b2818ea0.tar.bz2
gentoo-2-f2a6e57f418ad7ffa6e6ec8717614e76b2818ea0.zip
New ebuild. Rsolves bug #1885.
Diffstat (limited to 'app-editors/mp')
-rw-r--r--app-editors/mp/ChangeLog10
-rw-r--r--app-editors/mp/files/digest-mp-3.1.91
-rw-r--r--app-editors/mp/mp-3.1.9.ebuild27
3 files changed, 38 insertions, 0 deletions
diff --git a/app-editors/mp/ChangeLog b/app-editors/mp/ChangeLog
new file mode 100644
index 000000000000..85c21586a03b
--- /dev/null
+++ b/app-editors/mp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-editor/mp
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.1 2002/04/22 01:52:55 mkennedy Exp $
+
+*mp-3.1.9 (21 Apr 2002)
+
+ 21 Apr 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ mp-3.1.9.ebuild, files/digest-mp-3.1.9 :
+
+ New ebuild. Rsolves bug #1885.
diff --git a/app-editors/mp/files/digest-mp-3.1.9 b/app-editors/mp/files/digest-mp-3.1.9
new file mode 100644
index 000000000000..4044245c1dd2
--- /dev/null
+++ b/app-editors/mp/files/digest-mp-3.1.9
@@ -0,0 +1 @@
+MD5 356d254729ca34e4773c06af642fa948 mp-3.1.9.tar.gz 86069
diff --git a/app-editors/mp/mp-3.1.9.ebuild b/app-editors/mp/mp-3.1.9.ebuild
new file mode 100644
index 000000000000..f1928e29a533
--- /dev/null
+++ b/app-editors/mp/mp-3.1.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Matthew Kennedy <mkennedy@gentoo.org>
+# Maintainer: Matthew Kennedy <mkennedy@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.1.9.ebuild,v 1.1 2002/04/22 01:52:55 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="mp, the definitive text editor"
+SRC_URI="http://triptico.dhis.org/download/${P}.tar.gz"
+HOMEPAGE="http://www.triptico.com/software/mp.html"
+
+DEPEND="virtual/glibc
+ sys-libs/ncurses"
+
+RDEPEND="${DEPEND}
+ sys-devel/perl"
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ dodir /usr/bin
+ make install PREFIX=${D}/usr || die
+ dodoc AUTHORS ChangeLog COPYING README
+ dohtml README.html doc/mp_api.html
+}