summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 03:45:41 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 03:45:41 +0000
commitd0f86b932d4ed92834b530ab434203fc5139ef9a (patch)
treea4bd1d7594c538191cc7241bf2d26ffe5c169656 /app-editors/mp
parent (Manifest recommit) (diff)
downloadgentoo-2-d0f86b932d4ed92834b530ab434203fc5139ef9a.tar.gz
gentoo-2-d0f86b932d4ed92834b530ab434203fc5139ef9a.tar.bz2
gentoo-2-d0f86b932d4ed92834b530ab434203fc5139ef9a.zip
add inherit eutils
Diffstat (limited to 'app-editors/mp')
-rw-r--r--app-editors/mp/mp-3.2.11.ebuild32
1 files changed, 18 insertions, 14 deletions
diff --git a/app-editors/mp/mp-3.2.11.ebuild b/app-editors/mp/mp-3.2.11.ebuild
index 323e1297dcb2..de87b2d25151 100644
--- a/app-editors/mp/mp-3.2.11.ebuild
+++ b/app-editors/mp/mp-3.2.11.ebuild
@@ -1,36 +1,40 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.11.ebuild,v 1.2 2004/03/13 22:30:28 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.11.ebuild,v 1.3 2004/04/06 03:42:07 vapier Exp $
+
+inherit eutils
DESCRIPTION="mp, the definitive text editor"
+HOMEPAGE="http://www.triptico.com/software/mp.html"
SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
-HOMEPAGE="http://www.triptico.com/software/mp.html"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="ncurses gtk"
DEPEND="virtual/glibc
ncurses? ( sys-libs/ncurses )
- gtk? ( =x11-libs/gtk+-1.2* )"
-
+ gtk? ( =x11-libs/gtk+-1.2* )
+ !gtk? ( sys-libs/ncurses )"
RDEPEND="${DEPEND}
dev-lang/perl"
-IUSE="ncurses gtk"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc"
src_compile() {
epatch ${FILESDIR}/gentoo-synh-mp.patch-3.2.11
- if [ -n "`use ncurses`" ] && [ -n "`use gtk`" ]; then emake || die;
- elif [ -n "`use ncurses`" ]; then emake mp || die;
- elif [ -n "`use gtk`" ]; then emake gmp || die;
- else die "You need ncurses and/or gtk in your USE variables";
+ if use ncurses && use gtk ; then
+ emake || die "make failed"
+ elif use gtk ; then
+ emake gmp || die "make gmp failed"
+ else
+ emake mp || die "make mp failed"
fi
}
-src_install () {
+src_install() {
dodir /usr/bin
make install PREFIX=${D}/usr || die "install failed"
- dodoc AUTHORS Changelog COPYING README
+ dodoc AUTHORS Changelog README
dohtml README.html doc/mp_api.html
insinto /usr/share/pixmaps/
doins mp.xpm