summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-05 16:40:17 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-05 16:40:17 +0000
commit83e46c10b9659e00c4fbce9f32cd63119f18af52 (patch)
tree8ac5edeac10d17b9a49cceb27d53c048774d7eed /app-editors/mp
parentDOCS is array now (diff)
downloadgentoo-2-83e46c10b9659e00c4fbce9f32cd63119f18af52.tar.gz
gentoo-2-83e46c10b9659e00c4fbce9f32cd63119f18af52.tar.bz2
gentoo-2-83e46c10b9659e00c4fbce9f32cd63119f18af52.zip
Version Bump, respecting CC
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/mp')
-rw-r--r--app-editors/mp/ChangeLog8
-rw-r--r--app-editors/mp/files/mp-5.1.3-asneeded.patch227
-rw-r--r--app-editors/mp/mp-5.1.1.ebuild5
-rw-r--r--app-editors/mp/mp-5.1.3.ebuild80
4 files changed, 317 insertions, 3 deletions
diff --git a/app-editors/mp/ChangeLog b/app-editors/mp/ChangeLog
index 207703574f1e..d36d06b3cd7f 100644
--- a/app-editors/mp/ChangeLog
+++ b/app-editors/mp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/mp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.72 2010/06/20 16:18:13 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.73 2010/07/05 16:40:17 jlec Exp $
+
+*mp-5.1.3 (05 Jul 2010)
+
+ 05 Jul 2010; Justin Lecher <jlec@gentoo.org> mp-5.1.1.ebuild,
+ +mp-5.1.3.ebuild, +files/mp-5.1.3-asneeded.patch:
+ Version BUmp, respecting CC
20 Jun 2010; Markos Chandras <hwoarang@gentoo.org> mp-5.1.1.ebuild,
+files/mp-5.1.1-asneeded.patch:
diff --git a/app-editors/mp/files/mp-5.1.3-asneeded.patch b/app-editors/mp/files/mp-5.1.3-asneeded.patch
new file mode 100644
index 000000000000..7f60c2719023
--- /dev/null
+++ b/app-editors/mp/files/mp-5.1.3-asneeded.patch
@@ -0,0 +1,227 @@
+diff --git a/config.sh b/config.sh
+index 17ade83..643b07e 100755
+--- a/config.sh
++++ b/config.sh
+@@ -80,7 +80,7 @@ echo "Configuring..."
+
+ echo "/* automatically created by config.sh - do not modify */" > config.h
+ echo "# automatically created by config.sh - do not modify" > makefile.opts
+-> config.ldflags
++> config.libs
+ > config.cflags
+ > .config.log
+
+@@ -134,7 +134,7 @@ done
+
+ if [ "$MPDM" != "NOTFOUND" ] ; then
+ echo "-I$MPDM" >> config.cflags
+- echo "-L$MPDM -lmpdm" >> config.ldflags
++ echo "-L$MPDM -lmpdm" >> config.libs
+ echo "OK ($MPDM)"
+ else
+ echo "No"
+@@ -146,7 +146,7 @@ if [ ! -f $MPDM/Makefile ] ; then
+ ( echo ; cd $MPDM ; ./config.sh --prefix=$PREFIX --docdir=$PREFIX/share/doc/$APPNAME $CONF_ARGS ; echo )
+ fi
+
+-cat $MPDM/config.ldflags >> config.ldflags
++cat $MPDM/config.libs >> config.libs
+ echo "MPDM=$MPDM" >> makefile.opts
+
+ # MPSL
+@@ -160,7 +160,7 @@ done
+
+ if [ "$MPSL" != "NOTFOUND" ] ; then
+ echo "-I$MPSL" >> config.cflags
+- echo "-L$MPSL -lmpsl" >> config.ldflags
++ echo "-L$MPSL -lmpsl" >> config.libs
+ echo "OK ($MPSL)"
+ else
+ echo "No"
+@@ -172,7 +172,7 @@ if [ ! -f $MPSL/Makefile ] ; then
+ ( echo ; cd $MPSL ; ./config.sh --prefix=$PREFIX --docdir=$PREFIX/share/doc/$APPNAME $CONF_ARGS ; echo )
+ fi
+
+-cat $MPSL/config.ldflags >> config.ldflags
++cat $MPSL/config.libs >> config.libs
+ echo "MPSL=$MPSL" >> makefile.opts
+
+ # Win32
+@@ -184,7 +184,7 @@ else
+ grep CONFOPT_WIN32 ${MPDM}/config.h >/dev/null
+
+ if [ $? = 0 ] ; then
+- echo "-mwindows -lcomctl32" >> config.ldflags
++ echo "-mwindows -lcomctl32" >> config.libs
+ echo "#define CONFOPT_WIN32 1" >> config.h
+ echo "OK"
+ DRIVERS="win32 $DRIVERS"
+@@ -279,7 +279,7 @@ else
+
+ if [ $? = 0 ] ; then
+ echo $TMP_CFLAGS >> config.cflags
+- echo $TMP_LDFLAGS >> config.ldflags
++ echo $TMP_LDFLAGS >> config.libs
+
+ echo "#define CONFOPT_KDE4 1" >> config.h
+ echo "OK"
+@@ -357,7 +357,7 @@ else
+ if [ $? = 0 ] ; then
+ echo "#define CONFOPT_GTK 2" >> config.h
+ echo "$TMP_CFLAGS " >> config.cflags
+- echo "$TMP_LDFLAGS " >> config.ldflags
++ echo "$TMP_LDFLAGS " >> config.libs
+ echo "OK (2.0)"
+ DRIVERS="gtk $DRIVERS"
+ DRV_OBJS="mpv_gtk.o $DRV_OBJS"
+diff --git a/makefile.in b/makefile.in
+index 704eb57..5714f62 100644
+--- a/makefile.in
++++ b/makefile.in
+@@ -36,7 +36,7 @@ dep:
+ gcc -MM *.c `cat config.cflags` > makefile.depend
+
+ $(APPNAME): $(OBJS) $(MPDM)/libmpdm.a $(MPSL)/libmpsl.a
+- $(CCLINK) $(CFLAGS) $(OBJS) `cat config.ldflags` -o $@
++ $(CCLINK) $(CFLAGS) $(OBJS) `cat config.ldflags` `cat config.libs` -o $@
+
+ mpv_kde4.o: mpv_kde4.cpp mpv_kde4.moc
+ $(CPP) $(CFLAGS) -I. `cat config.cflags` -c $<
+@@ -54,7 +54,7 @@ mp_res.o: mp_res.rc
+ $(WINDRES) mp_res.rc mp_res.o
+
+ mp-5.exe: $(OBJS) mp_res.o $(MPDM)/libmpdm.a $(MPSL)/libmpsl.a
+- $(CC) $(CFLAGS) $(OBJS) mp_res.o `cat config.ldflags` -o $@
++ $(CC) $(CFLAGS) $(OBJS) mp_res.o `cat config.ldflags` `cat config.libs` -o $@
+
+ clean:
+ rm -f $(APPNAME) $(LIB) $(OBJS) *.o *.moc tags *.tar.gz *.exe *.zip .installer.c *.1
+@@ -62,7 +62,7 @@ clean:
+ (cd $(MPSL) ; make clean)
+
+ distclean: clean
+- rm -f config.h config.cflags config.ldflags \
++ rm -f config.h config.cflags config.ldflags config.libs \
+ makefile.opts Makefile po/minimum-profit.pot
+
+ docsclean:
+diff --git a/mpdm/config.sh b/mpdm/config.sh
+index 9e4f2f8..16033d3 100755
+--- a/mpdm/config.sh
++++ b/mpdm/config.sh
+@@ -70,7 +70,7 @@ echo "Configuring MPDM..."
+
+ echo "/* automatically created by config.sh - do not modify */" > config.h
+ echo "# automatically created by config.sh - do not modify" > makefile.opts
+-> config.ldflags
++> config.libs
+ > config.cflags
+ > .config.log
+
+@@ -169,7 +169,7 @@ if [ "$WITH_PCRE" = 1 ] ; then
+ echo "OK (using pcre library)"
+ echo "#define CONFOPT_PCRE 1" >> config.h
+ echo "$TMP_CFLAGS " >> config.cflags
+- echo "$TMP_LDFLAGS " >> config.ldflags
++ echo "$TMP_LDFLAGS " >> config.libs
+ REGEX_YET=1
+ fi
+ fi
+@@ -316,7 +316,7 @@ else
+ if [ $? = 0 ] ; then
+ echo "OK (libintl needed)"
+ echo "#define CONFOPT_GETTEXT 1" >> config.h
+- echo "$TMP_LDFLAGS" >> config.ldflags
++ echo "$TMP_LDFLAGS" >> config.libs
+ else
+ echo "No"
+ fi
+@@ -349,7 +349,7 @@ else
+ if [ $? = 0 ] ; then
+ echo "OK (libiconv needed)"
+ echo "#define CONFOPT_ICONV 1" >> config.h
+- echo "$TMP_LDFLAGS" >> config.ldflags
++ echo "$TMP_LDFLAGS" >> config.libs
+ else
+ echo "No"
+ fi
+diff --git a/mpdm/makefile.in b/mpdm/makefile.in
+index 17ee1a0..10c102d 100644
+--- a/mpdm/makefile.in
++++ b/mpdm/makefile.in
+@@ -32,7 +32,7 @@ $(LIB): $(OBJS)
+ $(AR) rv $(LIB) $(OBJS)
+
+ stress: stress.c $(LIB)
+- $(CC) $(CFLAGS) `cat config.ldflags` stress.c -L. -lmpdm -o $@
++ $(CC) $(CFLAGS) `cat config.ldflags` `cat config.libs` stress.c -L. -lmpdm -o $@
+
+ .SUFFIXES: .txt .html
+
+@@ -54,7 +54,7 @@ clean:
+ rm -f $(TARGET) $(LIB) $(OBJS) *.o tags *.tar.gz stress
+
+ distclean: clean
+- rm -f config.h config.cflags config.ldflags makefile.opts .config.log Makefile
++ rm -f config.h config.cflags config.ldflags config.libs makefile.opts .config.log Makefile
+
+ realclean: distclean docsclean
+
+diff --git a/mpsl/config.sh b/mpsl/config.sh
+index d325412..4f36b06 100755
+--- a/mpsl/config.sh
++++ b/mpsl/config.sh
+@@ -69,7 +69,7 @@ echo "Configuring MPSL..."
+
+ echo "/* automatically created by config.sh - do not modify */" > config.h
+ echo "# automatically created by config.sh - do not modify" > makefile.opts
+-> config.ldflags
++> config.libs
+ > config.cflags
+ > .config.log
+
+@@ -131,7 +131,7 @@ done
+
+ if [ "$MPDM" != "NOTFOUND" ] ; then
+ echo "-I$MPDM" >> config.cflags
+- echo "-L$MPDM -lmpdm" >> config.ldflags
++ echo "-L$MPDM -lmpdm" >> config.libs
+ echo "OK ($MPDM)"
+ else
+ echo "No"
+@@ -143,7 +143,7 @@ if [ ! -f $MPDM/Makefile ] ; then
+ ( echo ; cd $MPDM ; ./config.sh $CONF_ARGS ; echo )
+ fi
+
+-cat $MPDM/config.ldflags >> config.ldflags
++cat $MPDM/config.libs >> config.libs
+
+ # if win32, the interpreter is called mpsl.exe
+ grep CONFOPT_WIN32 ${MPDM}/config.h >/dev/null && TARGET=mpsl.exe
+diff --git a/mpsl/makefile.in b/mpsl/makefile.in
+index 14ed62d..253e278 100644
+--- a/mpsl/makefile.in
++++ b/mpsl/makefile.in
+@@ -49,11 +49,11 @@ $(LIB): $(OBJS)
+ $(AR) rv $(LIB) $(OBJS)
+
+ $(TARGET): $(LIB) $(MPDM)/libmpdm.a
+- $(CC) $(CFLAGS) -L. -lmpsl `cat config.ldflags` -o $@
++ $(CC) $(CFLAGS) -L. -lmpsl `cat config.ldflags` `cat config.libs` -o $@
+
+ stress: stress.c $(LIB) $(MPDM)/libmpdm.a
+ $(CC) $(CFLAGS) `cat config.cflags` stress.c \
+- -L. -lmpsl `cat config.ldflags` -o $@
++ -L. -lmpsl `cat config.ldflags` `cat config.libs` -o $@
+
+ clean:
+ rm -f $(TARGET) $(LIB) $(OBJS) *.o tags *.tar.gz stress
+@@ -62,7 +62,7 @@ realclean: clean
+ rm -f y.tab.c y.tab.h lex.yy.c
+
+ distclean: clean y.tab.c y.tab.h lex.yy.c
+- rm -f config.h config.cflags config.ldflags makefile.opts .config.log Makefile
++ rm -f config.h config.cflags config.ldflags config.libs makefile.opts .config.log Makefile
+
+ realclean: distclean docsclean
+
diff --git a/app-editors/mp/mp-5.1.1.ebuild b/app-editors/mp/mp-5.1.1.ebuild
index 3d25c60f4f00..e5738276b232 100644
--- a/app-editors/mp/mp-5.1.1.ebuild
+++ b/app-editors/mp/mp-5.1.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-5.1.1.ebuild,v 1.6 2010/06/20 16:18:13 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-5.1.1.ebuild,v 1.7 2010/07/05 16:40:17 jlec Exp $
EAPI="3"
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Minimum Profit: A text editor for programmers"
HOMEPAGE="http://www.triptico.com/software/mp.html"
@@ -53,6 +53,7 @@ src_configure() {
echo ${LDFLAGS} >> $i/config.ldflags
done
+ tc-export CC
sh config.sh ${myconf} || die "Configure failed"
}
diff --git a/app-editors/mp/mp-5.1.3.ebuild b/app-editors/mp/mp-5.1.3.ebuild
new file mode 100644
index 000000000000..3a6c20b10dbe
--- /dev/null
+++ b/app-editors/mp/mp-5.1.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-5.1.3.ebuild,v 1.1 2010/07/05 16:40:17 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Minimum Profit: A text editor for programmers"
+HOMEPAGE="http://www.triptico.com/software/mp.html"
+SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="gtk iconv kde ncurses nls pcre qt4"
+
+RDEPEND="
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( >=x11-libs/gtk+-2 >=x11-libs/pango-1.8.0 )
+ !gtk? ( sys-libs/ncurses )
+ nls? ( sys-devel/gettext )
+ pcre? ( dev-libs/libpcre )
+ iconv? ( virtual/libiconv )
+ app-text/grutatxt"
+DEPEND="${RDEPEND}
+ app-text/grutatxt
+ dev-util/pkgconfig
+ dev-lang/perl"
+
+src_prepare() {
+ # fix force as-needed wrt bug #278086
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
+src_configure() {
+ local myconf="--prefix=${EPREFIX}/usr --without-win32"
+
+ if use gtk; then
+ ! use ncurses && myconf="${myconf} --without-curses"
+ else
+ myconf="${myconf} --without-gtk2"
+ fi
+
+ use iconv || myconf="${myconf} --without-iconv"
+
+ use kde || myconf="${myconf} --without-kde4"
+
+ use nls || myconfig="${myconf} --without-gettext"
+
+ myconf="${myconf} $(use_with pcre)"
+ use pcre || myconf="${myconf} --with-included-regex"
+
+ use qt4 || myconf="${myconf} --without-qt4"
+
+ for i in "${S}" "${S}"/mpsl "${S}"/mpdm;do
+ echo ${CFLAGS} >> $i/config.cflags
+ echo ${LDFLAGS} >> $i/config.ldflags
+ done
+
+ tc-export CC
+ sh config.sh ${myconf} || die "Configure failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ sh config.sh --prefix="${EPREFIX}/usr"
+ make DESTDIR="${D}" install || die "Install Failed"
+# use gtk && dosym mp-5 /usr/bin/gmp
+}
+
+pkg_postinst() {
+ if use gtk ; then
+ einfo
+ einfo "mp-5 is symlinked to gmp! Use"
+ einfo "$ DISPLAY=\"\" mp-5"
+ einfo "to use text mode!"
+ einfo
+ fi
+}