summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-07-23 06:33:42 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-07-23 06:33:42 +0000
commite6a884e68c062a888e763da42440f949e070c46c (patch)
tree4bbaf2d38fb82db0223d0977f60447ac51af2d0e /app-editors/lfhex/lfhex-0.3.7-r1.ebuild
parentVersion bump of gtkguitune to 0.7. This closes Bug #45340 (Manifest recommit) (diff)
downloadgentoo-2-e6a884e68c062a888e763da42440f949e070c46c.tar.gz
gentoo-2-e6a884e68c062a888e763da42440f949e070c46c.tar.bz2
gentoo-2-e6a884e68c062a888e763da42440f949e070c46c.zip
Added patch by Jon Oberheide <jon@oberheide.org> (via email). uses different inline method for >=gcc-3.1 compilers
Diffstat (limited to 'app-editors/lfhex/lfhex-0.3.7-r1.ebuild')
-rw-r--r--app-editors/lfhex/lfhex-0.3.7-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/lfhex/lfhex-0.3.7-r1.ebuild b/app-editors/lfhex/lfhex-0.3.7-r1.ebuild
new file mode 100644
index 000000000000..60f9dcb6b083
--- /dev/null
+++ b/app-editors/lfhex/lfhex-0.3.7-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/lfhex-0.3.7-r1.ebuild,v 1.1 2004/07/23 06:33:42 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="A fast, efficient hex-editor with support for large files and comparing binary files"
+HOMEPAGE="http://freshmeat.net/projects/lfhex"
+SRC_URI="http://home.earthlink.net/~eyekode/data/${P}.tar.gz"
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+RDEPEND=">=x11-libs/qt-3
+ virtual/x11"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ sys-apps/grep
+ sys-apps/net-tools"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/lfhex-gcc3-inline-fix.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin bin/lfhex
+ dodoc LICENSE.QPL
+ dodoc README
+ dodoc README.install
+}