summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2009-06-02 17:47:52 +0000
committerHarald van Dijk <truedfx@gentoo.org>2009-06-02 17:47:52 +0000
commitc1a8a959f9e1f62f266fa9bd87857568a5768bba (patch)
treee4e5ca44dfd66b4bc27731d44773f12d3e23073c /app-editors/le
parentSparc stable, Bug #268020. (diff)
downloadgentoo-2-c1a8a959f9e1f62f266fa9bd87857568a5768bba.tar.gz
gentoo-2-c1a8a959f9e1f62f266fa9bd87857568a5768bba.tar.bz2
gentoo-2-c1a8a959f9e1f62f266fa9bd87857568a5768bba.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-editors/le')
-rw-r--r--app-editors/le/ChangeLog10
-rw-r--r--app-editors/le/files/le-1.14.2-gcc44.patch11
-rw-r--r--app-editors/le/le-1.14.2.ebuild26
-rw-r--r--app-editors/le/le-1.9.2.ebuild20
4 files changed, 45 insertions, 22 deletions
diff --git a/app-editors/le/ChangeLog b/app-editors/le/ChangeLog
index bfd55a70b8ce..1fd5b8d3f117 100644
--- a/app-editors/le/ChangeLog
+++ b/app-editors/le/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/le
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/le/ChangeLog,v 1.19 2008/03/27 21:26:35 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/le/ChangeLog,v 1.20 2009/06/02 17:47:51 truedfx Exp $
+
+*le-1.14.2 (02 Jun 2009)
+
+ 02 Jun 2009; Harald van Dijk <truedfx@gentoo.org> -le-1.9.2.ebuild,
+ +le-1.14.2.ebuild, +files/le-1.14.2-gcc44.patch:
+ Version bump
27 Mar 2008; Markus Meier <maekke@gentoo.org> le-1.13.4.ebuild:
amd64/x86 stable, bug #214902
diff --git a/app-editors/le/files/le-1.14.2-gcc44.patch b/app-editors/le/files/le-1.14.2-gcc44.patch
new file mode 100644
index 000000000000..d69b1dff1c06
--- /dev/null
+++ b/app-editors/le/files/le-1.14.2-gcc44.patch
@@ -0,0 +1,11 @@
+--- le-1.14.2/src/options.cc
++++ le-1.14.2/src/options.cc
+@@ -1245,7 +1245,7 @@
+ FindColor(new_bw_pal,color_no));
+ return -1;
+ }
+- char *l=strchr(button,'&');
++ const char *l=strchr(button,'&');
+ if(!l)
+ return -1;
+ char res=toupper(l[1]);
diff --git a/app-editors/le/le-1.14.2.ebuild b/app-editors/le/le-1.14.2.ebuild
new file mode 100644
index 000000000000..91b010722ea9
--- /dev/null
+++ b/app-editors/le/le-1.14.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/le/le-1.14.2.ebuild,v 1.1 2009/06/02 17:47:51 truedfx Exp $
+
+inherit base
+
+DESCRIPTION="Terminal text editor"
+HOMEPAGE="http://www.gnu.org/directory/text/editors/le-editor.html"
+SRC_URI="ftp://ftp.yars.free.net/pub/source/le/le-${PV}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libc
+ >=sys-libs/ncurses-5.2-r5"
+DEPEND="${RDEPEND}
+ app-arch/lzma-utils"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc44.patch )
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog FEATURES HISTORY INSTALL NEWS README TODO
+}
diff --git a/app-editors/le/le-1.9.2.ebuild b/app-editors/le/le-1.9.2.ebuild
deleted file mode 100644
index a1fc7c92a858..000000000000
--- a/app-editors/le/le-1.9.2.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/le/le-1.9.2.ebuild,v 1.12 2005/08/28 17:07:53 metalgod Exp $
-
-DESCRIPTION="Terminal text editor"
-HOMEPAGE="http://www.gnu.org/directory/text/editors/le-editor.html"
-SRC_URI="http://ftp.yars.free.net/pub/software/unix/util/texteditors/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE=""
-
-DEPEND="virtual/libc
- >=sys-libs/ncurses-5.2-r5"
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc ChangeLog FEATURES HISTORY INSTALL NEWS README TODO
-}