summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-08-05 04:53:49 +0000
committerBen de Groot <yngwin@gentoo.org>2008-08-05 04:53:49 +0000
commitade5e3c2b9df8e1fc7a396621381cd13539299b4 (patch)
tree55c2a18b2e4a00c2c61dc804cc39922152113f3e /app-editors/juffed
parentAlso remove the rest of the old versions, I thought only one was scheduled to... (diff)
downloadgentoo-2-ade5e3c2b9df8e1fc7a396621381cd13539299b4.tar.gz
gentoo-2-ade5e3c2b9df8e1fc7a396621381cd13539299b4.tar.bz2
gentoo-2-ade5e3c2b9df8e1fc7a396621381cd13539299b4.zip
Version bump. Removing betas. Patching the configure script to fix bug 231921 and to pass our currently set CXXFLAGS and LDFLAGS.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26-hg1 i686)
Diffstat (limited to 'app-editors/juffed')
-rw-r--r--app-editors/juffed/ChangeLog10
-rw-r--r--app-editors/juffed/files/juffed-0.3-configure.patch29
-rw-r--r--app-editors/juffed/juffed-0.3.ebuild (renamed from app-editors/juffed/juffed-0.3_beta20080705.ebuild)11
-rw-r--r--app-editors/juffed/juffed-0.3_beta20080421.ebuild36
4 files changed, 47 insertions, 39 deletions
diff --git a/app-editors/juffed/ChangeLog b/app-editors/juffed/ChangeLog
index 0cd37d8122f0..328818c12891 100644
--- a/app-editors/juffed/ChangeLog
+++ b/app-editors/juffed/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/juffed
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/ChangeLog,v 1.3 2008/07/27 02:09:27 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/ChangeLog,v 1.4 2008/08/05 04:53:49 yngwin Exp $
+
+*juffed-0.3 (05 Aug 2008)
+
+ 05 Aug 2008; Ben de Groot <yngwin@gentoo.org>
+ +files/juffed-0.3-configure.patch, -juffed-0.3_beta20080421.ebuild,
+ -juffed-0.3_beta20080705.ebuild, +juffed-0.3.ebuild:
+ Version bump. Removing betas. Patching the configure script to fix bug
+ 231921 and to pass our currently set CXXFLAGS and LDFLAGS.
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org>
juffed-0.3_beta20080421.ebuild, juffed-0.3_beta20080705.ebuild:
diff --git a/app-editors/juffed/files/juffed-0.3-configure.patch b/app-editors/juffed/files/juffed-0.3-configure.patch
new file mode 100644
index 000000000000..bb4f8bf24997
--- /dev/null
+++ b/app-editors/juffed/files/juffed-0.3-configure.patch
@@ -0,0 +1,29 @@
+--- juffed_0.3_orig/configure 2008-07-17 02:04:22.000000000 +0200
++++ juffed_0.3/configure 2008-08-05 06:39:30.000000000 +0200
+@@ -184,7 +184,7 @@
+ ${qmake_cmd} -project -o test.pro
+ echo "" >> test.pro
+ echo "QT += xml" >> test.pro
+-${qmake_cmd} 2>configure.log
++${qmake_cmd} "QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS} -w" 2>configure.log
+ ${make_cmd} 1>/dev/null 2>>configure.log
+
+ test_prg=`cat configure.log`
+@@ -230,7 +230,7 @@
+ echo "LIBS += -L${arg_qsci_lib_path}" >> test.pro
+ fi
+
+-${qmake_cmd} 2>configure.log
++${qmake_cmd} "QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS} -w" 2>configure.log
+ ${make_cmd} 1>/dev/null 2>>configure.log
+
+ test_prg=`cat configure.log`
+@@ -293,7 +293,7 @@
+ LRELEASE='${lrelease_cmd}'
+
+ src/juffed:
+- cd src && $(QMAKE) && $(MAKE)
++ cd src && $(QMAKE) "QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}" "QMAKE_LFLAGS_RELEASE=${LDFLAGS}" && $(MAKE)
+ cd src && $(LRELEASE) juffed.pro
+
+ distclean:
diff --git a/app-editors/juffed/juffed-0.3_beta20080705.ebuild b/app-editors/juffed/juffed-0.3.ebuild
index f561a8af6749..89525969bcc3 100644
--- a/app-editors/juffed/juffed-0.3_beta20080705.ebuild
+++ b/app-editors/juffed/juffed-0.3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/juffed-0.3_beta20080705.ebuild,v 1.3 2008/07/27 02:09:27 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/juffed-0.3.ebuild,v 1.1 2008/08/05 04:53:49 yngwin Exp $
EAPI=1
inherit qt4
-MY_P=${PN}_${PV/_beta20080705/-beta2}
+MY_P=${PN}_${PV}
DESCRIPTION="QScintilla-based tabbed text editor with syntax highlighting"
HOMEPAGE="http://www.qt-apps.org/content/show.php/JuffEd?content=59940"
@@ -22,6 +22,13 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}"/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # force our current cxxflags and ldflags, and turn off warnings in tests, bug 231921
+ epatch "${FILESDIR}"/${P}-configure.patch
+}
+
src_compile() {
# with econf it chokes on Unrecognized option: --host=...
./configure --qmake=qmake --prefix=/usr
diff --git a/app-editors/juffed/juffed-0.3_beta20080421.ebuild b/app-editors/juffed/juffed-0.3_beta20080421.ebuild
deleted file mode 100644
index bb4cf09137f4..000000000000
--- a/app-editors/juffed/juffed-0.3_beta20080421.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/juffed-0.3_beta20080421.ebuild,v 1.3 2008/07/27 02:09:27 carlo Exp $
-
-EAPI=1
-inherit qt4
-
-MY_P=${PN}_${PV/_beta/-dev-}
-
-DESCRIPTION="QScintilla-based tabbed text editor with syntax highlighting"
-HOMEPAGE="http://www.qt-apps.org/content/show.php/JuffEd?content=59940"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=x11-libs/qscintilla-2.1
- || ( x11-libs/qt-gui:4 =x11-libs/qt-4.3*:4 )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-
-src_compile() {
- # with econf it chokes on Unrecognized option: --host=...
- ./configure --qmake=qmake \
- --prefix=/usr --qt_lib_path=/usr/lib/qt4
- emake || die "Make failed!"
-}
-
-src_install() {
- emake FAKE_ROOT="${D}" install || die "Make install failed!"
- dodoc ChangeLog README
- rm "${D}"/usr/share/juffed/{COPYING,README}
-}