summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2010-10-06 19:57:35 +0000
committerTomás Touceda <chiiph@gentoo.org>2010-10-06 19:57:35 +0000
commit47e01383309c54075dd9d8a1d32186fecfd98d09 (patch)
tree080a13f5ae67bde24e4f748f2e9040455837fcef /app-editors/juffed
parentx86 stable, bug #338345 (diff)
downloadgentoo-2-47e01383309c54075dd9d8a1d32186fecfd98d09.tar.gz
gentoo-2-47e01383309c54075dd9d8a1d32186fecfd98d09.tar.bz2
gentoo-2-47e01383309c54075dd9d8a1d32186fecfd98d09.zip
Version bump
(Portage version: 2.2_rc88/cvs/Linux i686)
Diffstat (limited to 'app-editors/juffed')
-rw-r--r--app-editors/juffed/ChangeLog7
-rw-r--r--app-editors/juffed/juffed-0.8.1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/app-editors/juffed/ChangeLog b/app-editors/juffed/ChangeLog
index a710d35c848b..2e001600826b 100644
--- a/app-editors/juffed/ChangeLog
+++ b/app-editors/juffed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/juffed
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/ChangeLog,v 1.19 2010/03/02 00:11:15 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/ChangeLog,v 1.20 2010/10/06 19:57:34 chiiph Exp $
+
+*juffed-0.8.1 (06 Oct 2010)
+
+ 06 Oct 2010; Tomas Touceda <chiiph@gentoo.org> +juffed-0.8.1.ebuild:
+ Version bump
*juffed-0.8 (02 Mar 2010)
diff --git a/app-editors/juffed/juffed-0.8.1.ebuild b/app-editors/juffed/juffed-0.8.1.ebuild
new file mode 100644
index 000000000000..40bf49bc4eff
--- /dev/null
+++ b/app-editors/juffed/juffed-0.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/juffed-0.8.1.ebuild,v 1.1 2010/10/06 19:57:35 chiiph Exp $
+
+EAPI=2
+inherit multilib cmake-utils
+
+DESCRIPTION="QScintilla-based tabbed text editor with syntax highlighting"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/JuffEd?content=59940"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/qscintilla
+ x11-libs/qt-gui:4"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${P/_/-}
+
+src_prepare() {
+ sed -i -e \
+ "s:\${CMAKE_INSTALL_PREFIX}/lib:\${CMAKE_INSTALL_PREFIX}/$(get_libdir):" \
+ CMakeLists.txt || die "sed failed"
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog README || die "dodoc failed"
+}