summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2009-12-10 21:29:16 +0000
committerDror Levin <spatz@gentoo.org>2009-12-10 21:29:16 +0000
commit2b458a158f7f5961d308ae9c4102ff6bcf29a308 (patch)
tree9a71d8ac34e77e3fedf2ac357c677e362378c394 /app-editors/juffed
parentDrop KDE SC-4.3.1. (diff)
downloadgentoo-2-2b458a158f7f5961d308ae9c4102ff6bcf29a308.tar.gz
gentoo-2-2b458a158f7f5961d308ae9c4102ff6bcf29a308.tar.bz2
gentoo-2-2b458a158f7f5961d308ae9c4102ff6bcf29a308.zip
Fix multilib issues - install to proper libdir, bug 291853.
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/juffed')
-rw-r--r--app-editors/juffed/ChangeLog5
-rw-r--r--app-editors/juffed/juffed-0.6.1.ebuild10
2 files changed, 12 insertions, 3 deletions
diff --git a/app-editors/juffed/ChangeLog b/app-editors/juffed/ChangeLog
index fc9f95f3c1a3..9a5472716473 100644
--- a/app-editors/juffed/ChangeLog
+++ b/app-editors/juffed/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/juffed
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/ChangeLog,v 1.15 2009/11/09 16:11:40 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/ChangeLog,v 1.16 2009/12/10 21:29:16 spatz Exp $
+
+ 10 Dec 2009; Dror Levin <spatz@gentoo.org> juffed-0.6.1.ebuild:
+ Fix multilib issues - install to proper libdir, bug 291853.
09 Nov 2009; Markus Meier <maekke@gentoo.org> juffed-0.6.1.ebuild:
x86 stable, bug #291853
diff --git a/app-editors/juffed/juffed-0.6.1.ebuild b/app-editors/juffed/juffed-0.6.1.ebuild
index 8e94fea14186..1ac0e0aa4645 100644
--- a/app-editors/juffed/juffed-0.6.1.ebuild
+++ b/app-editors/juffed/juffed-0.6.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/juffed-0.6.1.ebuild,v 1.3 2009/11/09 16:11:40 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/juffed-0.6.1.ebuild,v 1.4 2009/12/10 21:29:16 spatz Exp $
EAPI=2
-inherit cmake-utils
+inherit multilib cmake-utils
DESCRIPTION="QScintilla-based tabbed text editor with syntax highlighting"
HOMEPAGE="http://www.qt-apps.org/content/show.php/JuffEd?content=59940"
@@ -20,6 +20,12 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}"/${P/_/-}
+src_prepare() {
+ sed -i -e \
+ "s:\${CMAKE_INSTALL_PREFIX}/lib:\${CMAKE_INSTALL_PREFIX}/$(get_libdir):" \
+ CMakeLists.txt || die "sed failed"
+}
+
src_install() {
cmake-utils_src_install
dodoc ChangeLog README