summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Knight <tomk@gentoo.org>2006-07-14 18:52:33 +0000
committerTom Knight <tomk@gentoo.org>2006-07-14 18:52:33 +0000
commit4611493addd71af7b906730f55055eea4cd37aa7 (patch)
tree589d64cf7f570a4bcd2385f4cb696ed37e22e348 /app-editors/joe
parentppc stable, bug #139612 (diff)
downloadgentoo-2-4611493addd71af7b906730f55055eea4cd37aa7.tar.gz
gentoo-2-4611493addd71af7b906730f55055eea4cd37aa7.tar.bz2
gentoo-2-4611493addd71af7b906730f55055eea4cd37aa7.zip
Version bump to joe 3.4, also fixed bug #116861 thanks to Chris Mayo for reporting it.
(Portage version: 2.1-r1)
Diffstat (limited to 'app-editors/joe')
-rw-r--r--app-editors/joe/ChangeLog8
-rw-r--r--app-editors/joe/files/digest-joe-3.43
-rw-r--r--app-editors/joe/joe-3.4.ebuild64
3 files changed, 74 insertions, 1 deletions
diff --git a/app-editors/joe/ChangeLog b/app-editors/joe/ChangeLog
index ad1a20e941ae..8a6154b05d22 100644
--- a/app-editors/joe/ChangeLog
+++ b/app-editors/joe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/joe
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.45 2006/04/27 12:29:49 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.46 2006/07/14 18:52:33 tomk Exp $
+
+*joe-3.4 (14 Jul 2006)
+
+ 14 Jul 2006; Tom Knight <tomk@gentoo.org> +joe-3.4.ebuild:
+ Version bump to joe 3.4, also fixed bug #116861 thanks to Chris Mayo for
+ reporting it.
27 Apr 2006; Marien Zwart <marienz@gentoo.org> files/digest-joe-3.0-r2,
files/digest-joe-3.1-r1, files/digest-joe-3.2, Manifest:
diff --git a/app-editors/joe/files/digest-joe-3.4 b/app-editors/joe/files/digest-joe-3.4
new file mode 100644
index 000000000000..f65643acc4f7
--- /dev/null
+++ b/app-editors/joe/files/digest-joe-3.4
@@ -0,0 +1,3 @@
+MD5 068d21205a12c6d5bbb02c55cda342ee joe-3.4.tar.gz 590679
+RMD160 0849f34ae239be8281a098532ec6b82d85f61607 joe-3.4.tar.gz 590679
+SHA256 802cf016fe0077a4567c70ba2221b59f2f1e341444fbe6d4280c52c7c8f7bbc3 joe-3.4.tar.gz 590679
diff --git a/app-editors/joe/joe-3.4.ebuild b/app-editors/joe/joe-3.4.ebuild
new file mode 100644
index 000000000000..ebd0670b6d2e
--- /dev/null
+++ b/app-editors/joe/joe-3.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.4.ebuild,v 1.1 2006/07/14 18:52:33 tomk Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="xterm"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND="!ppc-macos? ( xterm? ( >=x11-terms/xterm-215-r1 ) )"
+PROVIDE="virtual/editor"
+
+pkg_setup() {
+ if use xterm && ! built_with_use x11-terms/xterm paste64; then
+ die "For full xterm clipboard support build x11-terms/xterm with USE=paste64"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/rc
+
+ # This has since been fixed upstream, so remove it at the next version bump
+ sed -e 's:/home/Joe/etc/joe:@JOERC@:' -i joerc.in || die "sed failed"
+
+ # Enable xterm mouse support in the rc files
+ if use xterm; then
+ for i in *rc*.in; do
+ sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die "sed failed"
+ done
+ fi
+}
+
+src_compile() {
+ # Bug 34609 (joe 2.9.8 editor seg-faults on 'find and replace' when compiled with -Os)
+ replace-flags "-Os" "-O2"
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc ChangeLog HACKING HINTS LIST NEWS README TODO
+ # remove superfluous documentation, fixes bug #116861
+ rm -rf "${D}"/etc/joe/doc
+}
+
+pkg_postinst() {
+ if use xterm; then
+ einfo "To enable full xterm clipboard you need to set the allowWindowOps"
+ einfo "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
+ einfo "This is false by default due to potential security problems on some"
+ einfo "architectures (see bug #91453)."
+
+ fi
+}