summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-07 11:25:41 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-07 11:25:41 +0000
commit28b4443d0973e733606455ac77850b32530d622e (patch)
tree83ae73ad9e544633c0217a9e575031875b3ea729 /app-editors/joe
parent*** empty log message *** (diff)
downloadgentoo-2-28b4443d0973e733606455ac77850b32530d622e.tar.gz
gentoo-2-28b4443d0973e733606455ac77850b32530d622e.tar.bz2
gentoo-2-28b4443d0973e733606455ac77850b32530d622e.zip
*** empty log message ***
Diffstat (limited to 'app-editors/joe')
-rw-r--r--app-editors/joe/joe-2.8-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/joe/joe-2.8-r1.ebuild b/app-editors/joe/joe-2.8-r1.ebuild
new file mode 100644
index 000000000000..3502196afd1e
--- /dev/null
+++ b/app-editors/joe/joe-2.8-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-2.8-r1.ebuild,v 1.1 2000/08/07 11:25:41 achim Exp $
+
+P=joe-2.8
+A=joe2.8.tar.Z
+S=${WORKDIR}/joe
+CATEGORY="sys"
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+SRC_URI="ftp://ftp.std.com/src/editors/"${A}
+
+src_compile() {
+
+ make
+ make termidx
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${O}/files/joe2.8.dif
+ cp Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" Makefile.orig > Makefile
+}
+
+src_install() {
+ into /usr
+ dobin joe
+ doman joe.1
+
+ for i in jmacs jstar jpico rjoe
+ do
+ dosym /usr/bin/joe /usr/bin/$i
+ dosym /usr/man/man1/joe.1.gz /usr/man/man1/$i.1.gz
+ done
+
+ dobin termidx
+ dolib joerc
+ dolib jmacsrc
+ dolib jstarrc
+ dolib rjoerc
+ dolib jpicorc
+ dolib termcap
+ dolib terminfo
+}
+
+