summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-11 12:09:28 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-11 12:09:28 +0000
commite09bdfe4a06ad868a8a1bb3bed6605754279dbf0 (patch)
tree6012f736dc5c6584fe1be407288aefe67c9db90d /app-editors/jext
parentstable on amd64 wrt bug 96767 (diff)
downloadgentoo-2-e09bdfe4a06ad868a8a1bb3bed6605754279dbf0.tar.gz
gentoo-2-e09bdfe4a06ad868a8a1bb3bed6605754279dbf0.tar.bz2
gentoo-2-e09bdfe4a06ad868a8a1bb3bed6605754279dbf0.zip
cleanup
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-editors/jext')
-rw-r--r--app-editors/jext/files/jext-gentoo.sh4
-rw-r--r--app-editors/jext/jext-3.2_pre3.ebuild15
2 files changed, 9 insertions, 10 deletions
diff --git a/app-editors/jext/files/jext-gentoo.sh b/app-editors/jext/files/jext-gentoo.sh
index bac53dfb37a4..ea5681724daf 100644
--- a/app-editors/jext/files/jext-gentoo.sh
+++ b/app-editors/jext/files/jext-gentoo.sh
@@ -36,7 +36,7 @@ fi
if ! [ -f ~/.jext/variables ]
then
echo "JEXT_HOME="/usr/share/jext/lib > ~/.jext/variables
- echo "JAVA_CMD="`java-config --java` >>~/.jext/variables
+ echo "JAVA_CMD=java" >>~/.jext/variables
fi
@@ -47,4 +47,4 @@ JAVA_OPT=`grep JAVA_OPT ~/.jext/variables | cut -f2 -d=`
# Launch JEXT
-exec "$JAVA_CMD" $JAVA_OPTS -Dpython=`java-config --classpath=jython` -classpath "`java-config --classpath=jython`:`java-config --classpath=jext`" org.jext.Jext "$@"
+exec "$JAVA_CMD" $JAVA_OPTS -Dpython=`java-config --classpath=jython` -classpath "`java-config --classpath=jython,jext`" org.jext.Jext "$@"
diff --git a/app-editors/jext/jext-3.2_pre3.ebuild b/app-editors/jext/jext-3.2_pre3.ebuild
index 0c10b1723a8c..3c0d12754b87 100644
--- a/app-editors/jext/jext-3.2_pre3.ebuild
+++ b/app-editors/jext/jext-3.2_pre3.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/jext-3.2_pre3.ebuild,v 1.17 2005/01/01 13:28:43 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/jext-3.2_pre3.ebuild,v 1.18 2005/07/11 12:09:28 axxo Exp $
inherit java-pkg
-IUSE="doc"
-
DESCRIPTION="A cool and fully featured editor in Java"
HOMEPAGE="http://www.jext.org/"
MY_PV="${PV/_}"
@@ -13,18 +11,19 @@ SRC_URI="mirror://sourceforge/jext/${PN}-sources-${MY_PV}.tar.gz"
LICENSE="|| ( GPL-2 JPython )"
SLOT="0"
KEYWORDS="x86 ppc sparc"
+IUSE="doc"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4.1
+RDEPEND=">=virtual/jre-1.3
+ ${RDEPEND}
>=dev-java/jython-2.1-r5"
-RDEPEND=">=virtual/jre-1.3"
+DEPEND=">=virtual/jdk-1.3
+ dev-java/ant-core"
S=${WORKDIR}/${PN}-sources-${MY_PV}
src_compile() {
cd ${S}/src
- sed -e s:'<property name="classpath" value="" />':"<property name='classpath' value='`java-config --classpath=jython`' />": -i build.xml
- local antflags="jar"
+ local antflags="jar -Dclasspath=$(java-pkg_getjars jython)"
use doc && antflags="${antflags} javadocs"
ant ${antflags} || die "compile failed"
}