summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-06-18 07:10:22 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-06-18 07:10:22 +0000
commitb3b95f2c37f41ac96e033536fe524ce9d36a6313 (patch)
tree971ddb762c32821a231974e3dcc27196d4ef8655 /app-editors/jed/jed-0.99.18.ebuild
parentFix spelling mistake (diff)
downloadgentoo-2-b3b95f2c37f41ac96e033536fe524ce9d36a6313.tar.gz
gentoo-2-b3b95f2c37f41ac96e033536fe524ce9d36a6313.tar.bz2
gentoo-2-b3b95f2c37f41ac96e033536fe524ce9d36a6313.zip
added a lot of quotes around variables; fix slang dependency,see bug 141947
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-editors/jed/jed-0.99.18.ebuild')
-rw-r--r--app-editors/jed/jed-0.99.18.ebuild38
1 files changed, 17 insertions, 21 deletions
diff --git a/app-editors/jed/jed-0.99.18.ebuild b/app-editors/jed/jed-0.99.18.ebuild
index a59880bb44eb..d51d11bb5550 100644
--- a/app-editors/jed/jed-0.99.18.ebuild
+++ b/app-editors/jed/jed-0.99.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.18.ebuild,v 1.1 2006/08/09 12:47:16 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.18.ebuild,v 1.2 2007/06/18 07:10:22 opfer Exp $
inherit eutils versionator
@@ -15,15 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="X gpm truetype"
-RDEPEND=">=sys-libs/slang-2.0
- X? ( || (
- ( x11-libs/libX11 x11-libs/libXext x11-libs/libXrender )
- virtual/x11
- )
- )
- gpm? ( sys-libs/gpm )
+RDEPEND="=sys-libs/slang-2*
+ X? ( x11-libs/libX11 x11-libs/libXext x11-libs/libXrender )
X? ( truetype? ( || ( x11-libs/libXft virtual/xft )
- >=media-libs/freetype-2.0 ) )"
+ >=media-libs/freetype-2.0 ) )
+ gpm? ( sys-libs/gpm )"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
@@ -33,7 +29,7 @@ src_unpack() {
unpack ${A}
# Gennto slotted slang-2
- cd ${S}
+ cd "${S}"
sed -e 's:-lslang:-lslang-2:g' -i src/Makefile.in
sed -e 's:libslang:libslang-2:g' -i configure
@@ -57,7 +53,7 @@ src_compile() {
-e 's/#GPMMOUSEO/GPMMOUSEO/' \
-e 's/#OBJGPMMOUSEO/OBJGPMMOUSEO/' \
Makefile
- cd ${S}
+ cd "${S}"
fi
if use X && use truetype ; then
@@ -65,7 +61,7 @@ src_compile() {
sed -i -e 's/#XRENDERFONTLIBS/XRENDERFONTLIBS/' Makefile
sed -i -e 's/^CONFIG_H = config.h/xterm_C_FLAGS = `freetype-config --cflags`\nCONFIG_H = config.h/' Makefile
sed -i -e 's/#define XJED_HAS_XRENDERFONT 0/#define XJED_HAS_XRENDERFONT 1/' jed-feat.h
- cd ${S}
+ cd "${S}"
fi
make clean || die
@@ -80,19 +76,19 @@ src_compile() {
src_install() {
# make install in ${S} claims everything is up-to-date,
# so we manually cd ${S}/src before installing
- cd ${S}/src
- make DESTDIR=${D} install || die
+ cd "${S}/src"
+ make DESTDIR="${D}" install || die
- cd ${S}/doc
+ cd "${S}/doc"
cp README AUTHORS
- cd ${S}
+ cd "${S}"
dodoc INSTALL INSTALL.unx README doc/AUTHORS doc/manual/jed.tex
- cd ${S}/info
+ cd "${S}/info"
rm info.info
#epatch ${FILESDIR}/jed.info.diff
- cd ${S}
+ cd "${S}"
insinto /usr/share/info
doins info/*
@@ -101,9 +97,9 @@ src_install() {
doins lib/jed.conf
# replace IDE mode with EMACS mode
- sed -i -e 's/\(_Jed_Default_Emulation = \).*/\1"emacs";/' ${D}/etc/jed.conf || die "patching jed.conf failed"
+ sed -i -e 's/\(_Jed_Default_Emulation = \).*/\1"emacs";/' "${D}/etc/jed.conf" || die "patching jed.conf failed"
- cd ${D}
+ cd "${D}"
rm -rf usr/share/jed/info
# can't rm usr/share/jed/doc -- used internally by jed/xjed
}